Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 4.1.3
    • Fix Version/s: 4.1.6
    • Component/s: JavaScript
    • Labels:
      None

      Activity

      Andreas Andreou added a comment -

      Please, follow the progress in tacos...

      The idea is that you add a dep. to the (still evolving) tacos-dojo module
      (found @ http://tacos.sourceforge.net/nightly/ )
      <dependency>
      <groupId>net.sf.tacos</groupId>
      <artifactId>tacos-dojo</artifactId>
      <version>0.1.102</version>
      </dependency>

      and then you provide the following ajaxDelegate to your @Shell or @ScriptIncludes component

      @InjectObject("service:tacos.dojo.DojoOneShellDelegate")
      public abstract IRender getDelegate();

      ... and that's it!

      So, i'll probably close this issue if all goes well there

      Andreas Andreou added a comment -

      Nothing more to be done for this inside tapestry core...
      http://tacos.sourceforge.net/tacos4.1/tacos-dojo/index.html

      Paul Stanton added a comment - - edited

      Hi Andreas,

      I'm trying to do this without maven, is that possible?

      Thanks, P.

      Paul Stanton added a comment -

      Yep, I've read all of that, but:

      I've got tacos-core-4.1.1.jar and tacos-dojo-0.1.102-20071228.134503-2.jar in my classpath and the entries in .application, but am stil getting the exception:

      Caused by: org.apache.hivemind.ApplicationRuntimeException: Service point tacos.dojo.DojoOneShellDelegate does not exist.
      at org.apache.hivemind.impl.RegistryInfrastructureImpl.getServicePoint(RegistryInfrastructureImpl.java:179)
      at org.apache.hivemind.impl.RegistryInfrastructureImpl.getService(RegistryInfrastructureImpl.java:205)
      at org.apache.hivemind.impl.ModuleImpl.getService(ModuleImpl.java:105)
      at org.apache.hivemind.service.impl.ServiceObjectProvider.provideObject(ServiceObjectProvider.java:40)
      at $ObjectProvider_11950b55a2e.provideObject($ObjectProvider_11950b55a2e.java)
      at org.apache.hivemind.service.impl.ObjectTranslator.translate(ObjectTranslator.java:75)
      ... 88 more

      Andreas Andreou added a comment -

      1) You dont need maven
      2) Are you sure the tacos-dojo jar is in the classpath? Its hivemodule file defines tacos.dojo.DojoOneShellDelegate

      Paul Stanton added a comment -

      ok, it's on my classpath now, the exception has gone away but, all of my ajax components/features have stopped working for example, my Autocompleter.

      Here are some of the javascript errors:
      dojo.event has no properties
      uncaught exception: Could not load cross-domain resources: dojo.widget.Manager dojo.widget.Select tapestry.widget.Widget dojo.widget.DropdownDatePicker

      also, forms don't seem to be registering with dojo

      the relevant head content:

      <script type="text/javascript" src="http://o.aolcdn.com/dojo/1.0.2/dojo/dojo.xd.js"></script>

      <script type="text/javascript">
      dojo.registerModulePath("tapestry", "....../app?service=asset&path=%2Ftacos-js%2F");
      </script>
      <script type="text/javascript" src="/..../app?service=asset&path=%2Ftacos-js%2Ftap-dojo1.0.2.js"></script>

      sorry for the jumbled post, i'm in a huge rush ... any ideas andreas?

      Andreas Andreou added a comment -

      sorry - you're on your own now... widgets have changed in dojo1,
      so tapestry components that use them will not work as is.

      See http://tacos.sourceforge.net/tacos4.1/tacos-dojo/index.html
      on what's missing


        People

        • Assignee:
          Andreas Andreou
          Reporter:
          Richard Pack
        • Votes:
          0 Vote for this issue
          Watchers:
          2 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved:

            Development