Tapestry
  1. Tapestry
  2. TAPESTRY-1752

Expansions used in bound parameters are never re-evaluated

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 5.0.5
    • Fix Version/s: 5.0.6
    • Component/s: tapestry-core
    • Labels:
      None

      Description

      Expansions used in formal component parameter bindings will be evaluated once and only once.

      This gotcha has appeared a couple of times in the user list now.
      (It also affected my TAPESTRY-1642 example.)

      Here's one example from the user list:
      <t:outputraw value = "$

      {CurrentUser.about}

      "/>

      This one's easy to fix, but either the documentation should explicitly warn about the dangers, or it should be supported.

      Expansions cause bound parameters of type prop to be literals.
      Literal bindings are cached - and disabling that caching is not possible.
      Cached parameters are never never re-evaluated.

      Cheers,
      Nick.

        Activity

        Nick Westgate created issue -
        Nick Westgate added a comment -

        Duplicate of TAPESTRY-1667.

        Nick Westgate made changes -
        Field Original Value New Value
        Status Open [ 1 ] Closed [ 6 ]
        Fix Version/s 5.0.6 [ 12312544 ]
        Resolution Duplicate [ 3 ]
        Mark Thomas made changes -
        Workflow jira [ 12413025 ] Default workflow, editable Closed status [ 12568192 ]
        Mark Thomas made changes -
        Workflow Default workflow, editable Closed status [ 12568192 ] jira [ 12591273 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        3h 37m 1 Nick Westgate 17/Sep/07 08:29

          People

          • Assignee:
            Unassigned
            Reporter:
            Nick Westgate
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development