Tapestry
  1. Tapestry
  2. TAPESTRY-1723

tapestry-upload does not use character encoding

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 5.0.5
    • Fix Version/s: 5.0.7
    • Component/s: tapestry-upload
    • Labels:
      None

      Description

      tapestry-upload ignores the character encoding set in the request and falls back to default character encoding.

      The problem is that when extracting the parameter values the FileItem#getString() instead of FileItem#getString(String encoding) is used. The same problem is described and solved in JBoss Portal CMS:
      See also: http://jira.jboss.com/jira/browse/JBPORTAL-1550

      The getString method should be called with the encoding of the request:
      item.getString(request.getCharacterEncoding());

        Activity

        Christian Köberl added a comment -

        This patch corrects the issue and also fixes the testcase (which failed because of the changes in this patch).


          People

          • Assignee:
            Howard M. Lewis Ship
            Reporter:
            Christian Köberl
          • Votes:
            2 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development