(I'm top posting over our previous correspondence below.)
My initial response would be that the optional context parameters signature is
very natural and that prepending a boolean would dilute the current API's clarity.
Do these events need to share the same name? It smacks of the rewind.
(Not to malign what was, at the time, a great idea.)
Howard Lewis Ship wrote:
> I could change Form to pass along a boolean indicating whether it was
> for render or for submit. Please add an issue to JIRA.
> On 6/22/07, Nick Westgate <email@example.com> wrote:
>> Does anyone see a way to differentiate these prepare events?
>> I'm using an ugly hack because I can't find another way.
>> boolean rendering;
>> void setupRender()
>> public void onPrepareFromHistoryItemForm(int index)
>> if (rendering)