Tapestry
  1. Tapestry
  2. TAPESTRY-1526

Strip the folder name used to identify libraries from logical page names, just as the subfolder is stripped

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 5.0.5
    • Fix Version/s: 5.0.8
    • Component/s: tapestry-core
    • Labels:
      None

      Description

      For a library mapping it would be really nice to have shorter logical page names.

      The library mapping is e.g. the following:

      public static void contributeComponentClassResolver( Configuration<LibraryMapping> configuration )

      { configuration.add( new LibraryMapping( "user", "org.comp.app.user.presentation" ) ); }

      For the page class org.comp.app.user.presentation.pages.CreateUser it would be nice to get
      the url /app/user/create instead of /app/user/createuser.

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open In Progress In Progress
        235d 10h 29m 1 Howard M. Lewis Ship 20/Jan/08 18:37
        In Progress In Progress Closed Closed
        39m 48s 1 Howard M. Lewis Ship 20/Jan/08 19:17
        Mark Thomas made changes -
        Workflow Default workflow, editable Closed status [ 12567240 ] jira [ 12589938 ]
        Mark Thomas made changes -
        Workflow jira [ 12405133 ] Default workflow, editable Closed status [ 12567240 ]
        Howard M. Lewis Ship made changes -
        Status In Progress [ 3 ] Closed [ 6 ]
        Resolution Fixed [ 1 ]
        Fix Version/s 5.0.8 [ 12312898 ]
        Howard M. Lewis Ship made changes -
        Summary shorter logical page name for pages of contributed library Strip the folder name used to identify libraries from logical page names, just as the subfolder is stripped
        Howard M. Lewis Ship made changes -
        Status Open [ 1 ] In Progress [ 3 ]
        Howard M. Lewis Ship made changes -
        Field Original Value New Value
        Assignee Howard M. Lewis Ship [ hlship ]
        Hide
        Howard M. Lewis Ship added a comment -

        Good thought; currently on the package name is taken into account when stripping redundant prefixes and suffixes from the class name, but we should be able to "seed" in the library mapping virtual folder ('user", in this example) as well.

        Show
        Howard M. Lewis Ship added a comment - Good thought; currently on the package name is taken into account when stripping redundant prefixes and suffixes from the class name, but we should be able to "seed" in the library mapping virtual folder ('user", in this example) as well.
        Martin Grotzke created issue -

          People

          • Assignee:
            Howard M. Lewis Ship
            Reporter:
            Martin Grotzke
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development