Tapestry
  1. Tapestry
  2. TAPESTRY-1488

A duplicated item is generated when double-click the top item on Palette component.

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0.2
    • Fix Version/s: 4.1.5
    • Component/s: Contrib
    • Labels:
      None
    • Environment:
      Server: Windows XP SP2, Tomcat 5.5,
      Client: Windows IE 6.0

      Description

      There are many items in left list (Scroll bar is available) of the Palette component. The operations are as below.
      1. Move the scroll bar of the left list to the center.
      2. Double-click the top item of the left list to make the item be moved to the right list.
      3. An Empty item is generated after the top item. When you click the empty item, the duplicated item is generated.

        Activity

        Aimin created issue -
        Jesse Kuhnert made changes -
        Field Original Value New Value
        Fix Version/s 4.1.3 [ 12312516 ]
        Jesse Kuhnert made changes -
        Fix Version/s 4.1.3 [ 12312516 ]
        Fix Version/s 4.1.4 [ 12312763 ]
        Andreas Andreou added a comment -

        Amazing, but this is true!

        Actually the problem isn't that an empty item is generated - nor that it is duplicated...
        The issue here is that the select in that perticular case, in that particular browser doesn't refresh
        its display area - so, it doesn't show its actual (and new) contents.

        Andreas Andreou added a comment -

        special handling for ie added

        Andreas Andreou made changes -
        Assignee Andreas Andreou [ andyhot ]
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Mark Thomas made changes -
        Workflow jira [ 12404530 ] Default workflow, editable Closed status [ 12568301 ]
        Mark Thomas made changes -
        Workflow Default workflow, editable Closed status [ 12568301 ] jira [ 12591367 ]

          People

          • Assignee:
            Andreas Andreou
            Reporter:
            Aimin
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development