Tapestry
  1. Tapestry
  2. TAPESTRY-1215

Autocomplete triggers a syntax error in dojo.js when getValues() returns an empty list

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.1.1
    • Fix Version/s: 4.1.2
    • Component/s: JavaScript
    • Labels:
      None
    • Environment:
      WinXP. FireFox 2.0. Tomcat 5.5.

      Description

      1. Open the Home page.
      2. Type "x" (or anything that has no match) into the autocompleter.
      3. The browser will display:
      DEBUG: [SyntaxError: syntax error, file: http://localhost:8080/DynamicForms/app?service=asset&path=%2Fdojo%2Fdojo.js, line: 15]
      DEBUG:

      Home.html, Home.page and Home.java are attached.

      BTW, the code in dojo is using dojo.debug() to output the message. This by-passes the log level set (defaulted
      to WARNING) and makes this issue much more visible.

      1. User.java
        0.6 kB
        Kent Tong
      2. Home.java
        0.5 kB
        Kent Tong
      3. Home.page
        0.5 kB
        Kent Tong
      4. Home.html
        0.2 kB
        Kent Tong

        Activity

        Hide
        Michael Gloegl added a comment -

        I can confirm this one - looks really ugly in my app

        Show
        Michael Gloegl added a comment - I can confirm this one - looks really ugly in my app
        Hide
        Jesse Kuhnert added a comment -

        This looks to be resolved in the most current versions.

        Show
        Jesse Kuhnert added a comment - This looks to be resolved in the most current versions.
        Hide
        Paul Stanton added a comment -

        jesse,

        do you know what version this was fixed in? i've upgraded to 4.1.5 but it has broken something else (https://issues.apache.org/jira/browse/TAPESTRY-2157) so i need to roll back to an earlier version where (hopefully) both work.

        thanks, p.

        Show
        Paul Stanton added a comment - jesse, do you know what version this was fixed in? i've upgraded to 4.1.5 but it has broken something else ( https://issues.apache.org/jira/browse/TAPESTRY-2157 ) so i need to roll back to an earlier version where (hopefully) both work. thanks, p.

          People

          • Assignee:
            Jesse Kuhnert
            Reporter:
            Kent Tong
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development