Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.1
    • Fix Version/s: 4.1.1
    • Component/s: tapestry-core
    • Labels:
      None

      Description

      Tapestry 4.1 doesn't run under JRE 1.4.

      andreas:
      "There are currently just 4 source files using the @Override annotation
      and one using enums."

        Activity

        Hide
        Jesse Kuhnert added a comment -

        Cool thanks. I think I'm done fixing it now anyways but I'm glad you reminded me about that retrotranslator project. If it would allow us to start writing components with annotations it would sure make our lives much easier.

        Show
        Jesse Kuhnert added a comment - Cool thanks. I think I'm done fixing it now anyways but I'm glad you reminded me about that retrotranslator project. If it would allow us to start writing components with annotations it would sure make our lives much easier.
        Hide
        Andreas Andreou added a comment -

        BTW, i used the procedure outlined at
        http://retrotranslator.sourceforge.net/#commandline
        to get a 'retro' tapestry-framework-4.1.1-SNAPSHOT.jar

        Once I (or someone else) tries this, we can post the results.

        Show
        Andreas Andreou added a comment - BTW, i used the procedure outlined at http://retrotranslator.sourceforge.net/#commandline to get a 'retro' tapestry-framework-4.1.1-SNAPSHOT.jar Once I (or someone else) tries this, we can post the results.

          People

          • Assignee:
            Jesse Kuhnert
            Reporter:
            Greg Cormier
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development