Tapestry
  1. Tapestry
  2. TAPESTRY-1186

Error pages not properly caught/displayed in dojo ajax request if "forwarded"

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 4.1.1
    • Fix Version/s: 4.1.1
    • Component/s: XHR/dhtml/Ajax
    • Labels:
      None
    • Environment:
      ajax dojo request

      Description

      Certain exceptions get caught by AbstractEngine and aren't properly handled by the DojoAjaxResponseBuilder in the response because the data available in the original set of request headers that marked it as ajax are lost and so the DefaultResponseBuilder ends up handling it instead.

      Need some way to handle forwards in the specific case of StaleLink or other exception cases handled in AbstractEngine for ajax requests so that client side Exception panes are properly displayed.

        Activity

        Jesse Kuhnert added a comment -

        Try as I might I just can't get this to happen now.


          People

          • Assignee:
            Jesse Kuhnert
            Reporter:
            Jesse Kuhnert
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development