Uploaded image for project: 'Tapestry'
  1. Tapestry
  2. TAPESTRY-1177

ForBean can cause NullPointerException when rendered without a template

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 4.1.1
    • Fix Version/s: 4.1.1
    • Component/s: Framework
    • Labels:
      None

      Description

      Create a component which doesn't implement ITemplateComponent. In the component specification, declare a For component, but don't bind its optional "element" parameter. Call the For component's render() method.

      Stacktrace is:

      java.lang.NullPointerException
      Stack Trace:

      • org.apache.tapestry.markup.MarkupWriterImpl.end(MarkupWriterImpl.java:261)
      • org.apache.tapestry.components.ForBean.renderComponent(ForBean.java:183)
      • ...

      The problem is caused by line 140 of ForBean.java:

      String element = HiveMind.isNonBlank(getElement()) ? getElement() : getTemplateTagName();

      Because no element binding was specified, and there's no template, this returns null. The markup writer pushes the null value when begin(null) is called, then barfs when it is popped in end().

      Fix is to not call loopWriter.begin()/end() when element is null.

        Activity

        jkuhnert Jesse Kuhnert added a comment -

        Resolved issue by changing line of logic that sets the local "render" boolean to just check if element is null. Thanks for the patch!

        phl Phil McCarthy added a comment -

        Only surround For loop's body in a tag if element is non-null


          People

          • Assignee:
            jkuhnert Jesse Kuhnert
            Reporter:
            phl Phil McCarthy
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development