Tapestry
  1. Tapestry
  2. TAPESTRY-1173

Rendering error messages get swallowed on async requests.

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 4.1.1
    • Fix Version/s: 4.1.1
    • Component/s: Framework
    • Labels:
      None

      Description

      I have a component template that looks like this:

      <table>
      <span jwcid="@For" value="ognl:current" element="tr" source="ognl:messageEndPoints" keyExpression="keyExpression">
      <td>
      <a href="#" jwcid="@DirectLink"
      listener="listener:selectEndPoint" parameters="ognl:current.keyExpression"
      async="true" updateComponents="renderingArea">
      <span jwcid="@Insert" value="ognl:current.listDisplayValue"/>
      </a></td>
      </span>
      </table>
      <div jwcid="renderingArea@Any">
      <span jwcid="renderBlock@RenderBlock" block="ognl:selectedBlock"/>

      <span jwcid="websiteBlock@Block">
      <span jwcid="websiteEndPointEntry"/>
      </span>
      <span jwcid="rssBlock@Block">
      <span jwcid="rssEndPointEntry"/>
      </span>
      </div>

      The user selected an item that would cause the rssEndPointEntry Block to be the selectedBlock.
      I had a rendering error in the rssEndPointEntry component ( FormComponent not in a Form).
      The exception doesn't get display nor logged. just quietely swallowed.

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        5d 8m 1 Jesse Kuhnert 09/Dec/06 23:42
        Mark Thomas made changes -
        Workflow Default workflow, editable Closed status [ 12569239 ] jira [ 12590493 ]
        Mark Thomas made changes -
        Workflow jira [ 12391494 ] Default workflow, editable Closed status [ 12569239 ]
        Jesse Kuhnert made changes -
        Resolution Cannot Reproduce [ 5 ]
        Status Open [ 1 ] Resolved [ 5 ]
        Jesse Kuhnert added a comment -

        Resolving as un-reproducable for now. If someone can give me a more definite example that I can reproduce I'll open it back up and take a look.

        Jesse Kuhnert added a comment -

        Hi Patrick,

        I just did a test to confirm and wasn't able to re-produce. Exceptions are properly caught and displayed as per normal when thrown as ApplicationRuntimeException. Could it be that these were some other form of exception ?

        Jesse Kuhnert made changes -
        Assignee Jesse Kuhnert [ jkuhnert ]
        Jesse Kuhnert made changes -
        Field Original Value New Value
        Fix Version/s 4.1.1 [ 12312021 ]
        Patrick Moore created issue -

          People

          • Assignee:
            Jesse Kuhnert
            Reporter:
            Patrick Moore
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development