Tapestry 5
  1. Tapestry 5
  2. TAP5-895

Tracking issue for Tapestry/JSR-303 integration

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 5.1.0.5
    • Fix Version/s: 5.2.0
    • Component/s: None
    • Labels:
      None

      Description

      The integration should be provided until 5.2.0.0

        Activity

        Howard M. Lewis Ship added a comment -

        Wasn't this implemented? Is this a duplicate?

        Igor Drobiazko added a comment -

        This was not implemented yet. I'm in process right now.This is not a duplicate, at least I'm not aware of any other issue for JSR 303 support.

        Igor Drobiazko added a comment - - edited

        Howard, now I see the reason for your question. You might be confused by the fact that the JSR-303 integration library is mentioned in the 'New And Of Note' section on the 5.2 site but this issue is still in progress.

        The issue is open because the library lacks the client-side validation. I'm on the verge of finalizing this and committed some code few minutes ago.

        Igor Drobiazko added a comment -

        Closing the issue because the integration is now available. There might be some minor internal changes and/or improvements in the future which can be reported in extra jira issues. Few validation constraints like @AssertTrue still don't have a client-side counterpart.


          People

          • Assignee:
            Igor Drobiazko
            Reporter:
            Igor Drobiazko
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development