Uploaded image for project: 'Tapestry 5'
  1. Tapestry 5
  2. TAP5-788

ParallelExecutor service throws RejectedExecutionException if more then THREAD_POOL_MAX_SIZE jobs are submitted

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 5.2, 5.1.0.0, 5.1.0.1, 5.1.0.2, 5.1.0.3, 5.1.0.4, 5.1.0.5, 5.1
    • Fix Version/s: 5.2.0
    • Component/s: tapestry-ioc
    • Labels:
      None

      Description

      ParallelExecutor service building method is backed by a bounded BlockingQueue which is the cause of RejectedExecutionException if THREAD_POOL_MAX_SIZE is reached during parallel execution of jobs.

      Changing it to use an unbounded queue will cause new jobs to wait before ParallelExecutor is able to accept new ones.

      1. patch
        2 kB
        Massimo Lusetti

        Activity

        mlusetti Massimo Lusetti added a comment -

        Patch against current trunk, with modified test


          People

          • Assignee:
            hlship Howard M. Lewis Ship
            Reporter:
            mlusetti Massimo Lusetti
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development