Tapestry 5
  1. Tapestry 5
  2. TAP5-608

Quickstart archetype is broken for 5.1.0.2: missing META-INF/maven/archetype.xml

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 5.1.0.2
    • Fix Version/s: 5.1.0.3
    • Component/s: quickstart
    • Labels:
      None

      Description

      Choose archetype:
      1: http://tapestry.formos.com/maven-snapshot-repository -> quickstart (Tapestry 5.1.0.3-SNAPSHOT Quickstart Project)
      Choose a number: (1): 1
      [DEBUG] Not found archetype org.apache.tapestry:quickstart:5.1.0.3-SNAPSHOT in cache
      [INFO] snapshot org.apache.tapestry:quickstart:5.1.0.3-SNAPSHOT: checking for updates from quickstart-repo
      [DEBUG] Skipping disabled repository central
      [DEBUG] quickstart: resolved to version 5.1.0.3-20090327.090350-1 from repository quickstart-repo
      [DEBUG] Found archetype org.apache.tapestry:quickstart:5.1.0.3-SNAPSHOT in cache: /Users/Howard/.m2/repository/org/apache/tapestry/quickstart/5.1.0.3-SNAPSHOT/quickstart-5.1.0.3-SNAPSHOT.jar
      [DEBUG] Found archetype org.apache.tapestry:quickstart:5.1.0.3-SNAPSHOT in cache: /Users/Howard/.m2/repository/org/apache/tapestry/quickstart/5.1.0.3-SNAPSHOT/quickstart-5.1.0.3-SNAPSHOT.jar
      [DEBUG] No found META-INF/maven/archetype.xml retrying with windows path
      [DEBUG] Can not load old archetype
      java.io.IOException: The META-INF/maven/archetype.xml descriptor cannot be found.
      at org.apache.maven.archetype.common.DefaultArchetypeArtifactManager.getOldArchetypeDescriptorReader(DefaultArchetypeArtifactManager.java:679)
      at org.apache.maven.archetype.common.DefaultArchetypeArtifactManager.loadOldArchetypeDescriptor(DefaultArchetypeArtifactManager.java:618)
      at org.apache.maven.archetype.common.DefaultArchetypeArtifactManager.isOldArchetype(DefaultArchetypeArtifactManager.java:582)
      at org.apache.maven.archetype.common.DefaultArchetypeArtifactManager.isOldArchetype(DefaultArchetypeArtifactManager.java:300)
      at org.apache.maven.archetype.ui.DefaultArchetypeGenerationConfigurator.configureArchetype(DefaultArchetypeGenerationConfigurator.java:150)
      at org.apache.maven.archetype.mojos.CreateProjectFromArchetypeMojo.execute(CreateProjectFromArchetypeMojo.java:182)
      at org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPluginManager.java:447)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:539)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeStandaloneGoal(DefaultLifecycleExecutor.java:493)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:463)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:311)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:224)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:143)
      at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:333)
      at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:126)
      at org.apache.maven.cli.MavenCli.main(MavenCli.java:282)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
      at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
      at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
      at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
      [DEBUG] No found META-INF/archetype.xml retrying with windows path
      [INFO] ------------------------------------------------------------------------
      [ERROR] BUILD FAILURE
      [INFO] ------------------------------------------------------------------------
      [INFO] The defined artifact is not an archetype
      [INFO] ------------------------------------------------------------------------
      [DEBUG] Trace
      org.apache.maven.BuildFailureException: The defined artifact is not an archetype
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:560)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeStandaloneGoal(DefaultLifecycleExecutor.java:493)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:463)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:311)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:224)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:143)
      at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:333)
      at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:126)
      at org.apache.maven.cli.MavenCli.main(MavenCli.java:282)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
      at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
      at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
      at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
      Caused by: org.apache.maven.plugin.MojoFailureException: The defined artifact is not an archetype
      at org.apache.maven.archetype.mojos.CreateProjectFromArchetypeMojo.execute(CreateProjectFromArchetypeMojo.java:201)
      at org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPluginManager.java:447)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:539)
      ... 16 more

        Activity

        thomas w knych made changes -
        Comment [ Attached a good archetype.xml (not -metadata.xml - there code doesn't expect this filename). The mvn code is a little confused in that they define the filename constant in two places with different values. (Once in Constants.java and once in OldArchetype.java).

        Also note that I've added an id tag to the archetype.xml as the code was expecting this later on. According to their docs the id tag must match the pom.xml's projectId.

        ]
        thomas w knych made changes -
        Attachment archetype.xml [ 12414543 ]
        thomas w knych made changes -
        Attachment archetype.xml [ 12414543 ]
        Howard M. Lewis Ship made changes -
        Field Original Value New Value
        Status Open [ 1 ] Closed [ 6 ]
        Assignee Howard M. Lewis Ship [ hlship ]
        Fix Version/s 5.1.0.3 [ 12313782 ]
        Resolution Fixed [ 1 ]
        Howard M. Lewis Ship added a comment - - edited

        I believe this to be a Maven issue:

        http://jira.codehaus.org/browse/ARCHETYPE-236

        Howard M. Lewis Ship created issue -

          People

          • Assignee:
            Howard M. Lewis Ship
            Reporter:
            Howard M. Lewis Ship
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development