Tapestry 5
  1. Tapestry 5
  2. TAP5-600

The new Blackbird console makes Safari JavaScript completely non-functional

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 5.1.0.2
    • Fix Version/s: 5.1.0.2
    • Component/s: None
    • Labels:
      None

      Description

      Not clear why, but all JavaScript in Safari, including client validation and Ajax, appears to be broken.

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        12m 21s 1 Howard M. Lewis Ship 26/Mar/09 01:18
        Howard M. Lewis Ship made changes -
        Summary JavaScript in Safari appears to be completely nonfunctional The new Blackbird console makes Safari JavaScript completely non-functional
        Priority Major [ 3 ] Blocker [ 1 ]
        Howard M. Lewis Ship made changes -
        Field Original Value New Value
        Status Open [ 1 ] Closed [ 6 ]
        Assignee Howard M. Lewis Ship [ hlship ]
        Fix Version/s 5.1.0.2 [ 12313706 ]
        Resolution Fixed [ 1 ]
        Howard M. Lewis Ship added a comment -

        Appears to have been caused by unquoted keys, i.e.

        { class: "foo"}

        which should be

        { "class": "foo" }

        ... Safari cares, FireFox is more relaxed.

        Howard M. Lewis Ship added a comment -

        It may only be a problem when using combined JavaScript. Safari seems to care about that, using -Dtapestry.combine-scripts=false seems to avoid the issue.

        Howard M. Lewis Ship created issue -

          People

          • Assignee:
            Howard M. Lewis Ship
            Reporter:
            Howard M. Lewis Ship
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development