Uploaded image for project: 'Tapestry 5'
  1. Tapestry 5
  2. TAP5-311

NPE in BeanDisplay if used in a form with a default model

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 5.0.15
    • Fix Version/s: 5.4, 5.3.8
    • Component/s: tapestry-core
    • Labels:
      None

      Description

      Create something like this:

      <t:form>
      <t:beandisplay object="foo" include="bar" />
      </t:form>

      and submit the form. You get a NPE in beandisplay. The workaround is to create the model yourself.

        Issue Links

          Activity

          hlship Howard M. Lewis Ship added a comment -

          How about a stack trace?

          hlship Howard M. Lewis Ship added a comment -

          I suspect the problem here is that BeanDisplay has an internal Loop that's driven off of the model property of BeanDisplay, and that is null with no form-aware logic to set it up, the way that BeanEditor does.

          The solution is to provide the model parameter.

          hlship Howard M. Lewis Ship added a comment -

          There's easy workarounds for this, and it seems like an edge case to me.

          hlship Howard M. Lewis Ship added a comment -

          Insufficient detail.

          windy Stephan Windmüller added a comment -

          Same problem here with Tapestry 5.1.0. The Stacktracke:

          org.apache.tapestry5.runtime.ComponentEventException: Failure reading parameter 'source' of component MyComponent:beandisplay.loop: Property 'model' (within property expression 'model.propertyNames', of org.apache.tapestry5.corelib.components.BeanDisplay@10290442) is null. [at context:MyComponent.tml, line 19]
          at org.apache.tapestry5.internal.structure.ComponentPageElementImpl.triggerContextEvent(ComponentPageElementImpl.java:1098)
          at org.apache.tapestry5.internal.services.ComponentEventRequestHandlerImpl.handle(ComponentEventRequestHandlerImpl.java:75)
          at org.apache.tapestry5.internal.services.ImmediateActionRenderResponseFilter.handle(ImmediateActionRenderResponseFilter.java:42)
          at $ComponentEventRequestHandler_12622d29109.handle($ComponentEventRequestHandler_12622d29109.java)
          at org.apache.tapestry5.internal.services.AjaxFilter.handle(AjaxFilter.java:42)
          at $ComponentEventRequestHandler_12622d29109.handle($ComponentEventRequestHandler_12622d29109.java)
          at org.apache.tapestry5.upload.internal.services.UploadExceptionFilter.handle(UploadExceptionFilter.java:75)
          at $ComponentEventRequestHandler_12622d29109.handle($ComponentEventRequestHandler_12622d29109.java)
          at org.apache.tapestry5.services.TapestryModule$36.handle(TapestryModule.java:2164)
          at $ComponentEventRequestHandler_12622d29109.handle($ComponentEventRequestHandler_12622d29109.java)
          at $ComponentEventRequestHandler_12622d28fbb.handle($ComponentEventRequestHandler_12622d28fbb.java)
          at org.apache.tapestry5.internal.services.ComponentRequestHandlerTerminator.handleComponentEvent(ComponentRequestHandlerTerminator.java:43)
          at $ComponentRequestHandler_12622d28faf.handleComponentEvent($ComponentRequestHandler_12622d28faf.java)
          at org.apache.tapestry5.internal.services.ComponentEventDispatcher.dispatch(ComponentEventDispatcher.java:46)
          at $Dispatcher_12622d28fb2.dispatch($Dispatcher_12622d28fb2.java)
          at $Dispatcher_12622d28fa8.dispatch($Dispatcher_12622d28fa8.java)
          at org.apache.tapestry5.services.TapestryModule$RequestHandlerTerminator.service(TapestryModule.java:245)
          at org.apache.tapestry5.internal.services.RequestErrorFilter.service(RequestErrorFilter.java:26)
          at $RequestHandler_12622d28fa9.service($RequestHandler_12622d28fa9.java)
          at org.apache.tapestry5.services.TapestryModule$4.service(TapestryModule.java:778)
          at $RequestHandler_12622d28fa9.service($RequestHandler_12622d28fa9.java)
          at org.apache.tapestry5.services.TapestryModule$3.service(TapestryModule.java:767)
          at $RequestHandler_12622d28fa9.service($RequestHandler_12622d28fa9.java)
          at org.apache.tapestry5.internal.services.StaticFilesFilter.service(StaticFilesFilter.java:85)
          at $RequestHandler_12622d28fa9.service($RequestHandler_12622d28fa9.java)
          at org.apache.tapestry5.internal.services.CheckForUpdatesFilter$2.invoke(CheckForUpdatesFilter.java:90)
          at org.apache.tapestry5.internal.services.CheckForUpdatesFilter$2.invoke(CheckForUpdatesFilter.java:81)
          at org.apache.tapestry5.ioc.internal.util.ConcurrentBarrier.withRead(ConcurrentBarrier.java:85)
          at org.apache.tapestry5.internal.services.CheckForUpdatesFilter.service(CheckForUpdatesFilter.java:103)
          at $RequestHandler_12622d28fa9.service($RequestHandler_12622d28fa9.java)
          at $RequestHandler_12622d28fa0.service($RequestHandler_12622d28fa0.java)
          at org.apache.tapestry5.services.TapestryModule$HttpServletRequestHandlerTerminator.service(TapestryModule.java:197)
          at org.apache.tapestry5.internal.gzip.GZipFilter.service(GZipFilter.java:53)
          at $HttpServletRequestHandler_12622d28fa2.service($HttpServletRequestHandler_12622d28fa2.java)
          at org.apache.tapestry5.upload.internal.services.MultipartServletRequestFilter.service(MultipartServletRequestFilter.java:44)
          at $HttpServletRequestHandler_12622d28fa2.service($HttpServletRequestHandler_12622d28fa2.java)
          at org.apache.tapestry5.internal.services.IgnoredPathsFilter.service(IgnoredPathsFilter.java:62)
          at $HttpServletRequestFilter_12622d28f9f.service($HttpServletRequestFilter_12622d28f9f.java)
          at $HttpServletRequestHandler_12622d28fa2.service($HttpServletRequestHandler_12622d28fa2.java)
          at org.apache.tapestry5.services.TapestryModule$2.service(TapestryModule.java:726)
          at $HttpServletRequestHandler_12622d28fa2.service($HttpServletRequestHandler_12622d28fa2.java)
          at $HttpServletRequestHandler_12622d28f9c.service($HttpServletRequestHandler_12622d28f9c.java)
          at org.apache.tapestry5.TapestryFilter.doFilter(TapestryFilter.java:127)
          at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
          at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
          at org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96)
          at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
          at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
          at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:235)
          at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
          at org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:190)
          at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:525)
          at org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:92)
          at org.jboss.web.tomcat.security.SecurityContextEstablishmentValve.process(SecurityContextEstablishmentValve.java:126)
          at org.jboss.web.tomcat.security.SecurityContextEstablishmentValve.invoke(SecurityContextEstablishmentValve.java:70)
          at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
          at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
          at org.jboss.web.tomcat.service.jca.CachedConnectionValve.invoke(CachedConnectionValve.java:158)
          at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
          at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:330)
          at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:829)
          at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:598)
          at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)
          at java.lang.Thread.run(Thread.java:619)
          Caused by: org.apache.tapestry5.ioc.internal.util.TapestryException: Failure reading parameter 'source' of component MyComponent:beandisplay.loop: Property 'model' (within property expression 'model.propertyNames', of org.apache.tapestry5.corelib.components.BeanDisplay@10290442) is null. [at classpath:org/apache/tapestry5/corelib/components/BeanDisplay.tml, line 4]
          at org.apache.tapestry5.corelib.components.Form.executeStoredActions(Form.java:495)
          at org.apache.tapestry5.corelib.components.Form._$advised$onAction(Form.java:378)
          at org.apache.tapestry5.corelib.components.Form$onAction$invocation_12622de686b.invokeAdvisedMethod(Form$onAction$invocation_12622de686b.java)
          at org.apache.tapestry5.internal.services.AbstractComponentMethodInvocation.proceed(AbstractComponentMethodInvocation.java:71)
          at org.apache.tapestry5.ioc.internal.services.LoggingAdvice.advise(LoggingAdvice.java:37)
          at org.apache.tapestry5.internal.transform.LogWorker$1.advise(LogWorker.java:54)
          at org.apache.tapestry5.internal.services.AbstractComponentMethodInvocation.proceed(AbstractComponentMethodInvocation.java:80)
          at org.apache.tapestry5.corelib.components.Form.onAction(Form.java)
          at org.apache.tapestry5.corelib.components.Form.dispatchComponentEvent(Form.java)
          at org.apache.tapestry5.internal.structure.ComponentPageElementImpl.dispatchEvent(ComponentPageElementImpl.java:910)
          at org.apache.tapestry5.internal.structure.ComponentPageElementImpl.triggerContextEvent(ComponentPageElementImpl.java:1081)
          ... 63 more
          Caused by: org.apache.tapestry5.ioc.internal.util.TapestryException: Failure reading parameter 'source' of component MyComponent:beandisplay.loop: Property 'model' (within property expression 'model.propertyNames', of org.apache.tapestry5.corelib.components.BeanDisplay@10290442) is null. [at classpath:org/apache/tapestry5/corelib/components/BeanDisplay.tml, line 4]
          at org.apache.tapestry5.internal.structure.InternalComponentResourcesImpl$1.read(InternalComponentResourcesImpl.java:516)
          at org.apache.tapestry5.internal.structure.InternalComponentResourcesImpl$1.read(InternalComponentResourcesImpl.java:496)
          at org.apache.tapestry5.corelib.components.Loop._$read_parameter_source(Loop.java)
          at org.apache.tapestry5.corelib.components.Loop.setupForVolatile(Loop.java:358)
          at org.apache.tapestry5.corelib.components.Loop.access$100(Loop.java:44)
          at org.apache.tapestry5.corelib.components.Loop$2.execute(Loop.java:75)
          at org.apache.tapestry5.corelib.components.Loop$2.execute(Loop.java:79)
          at org.apache.tapestry5.corelib.components.Form.executeStoredActions(Form.java:480)
          ... 73 more
          Caused by: org.apache.tapestry5.ioc.internal.util.TapestryException: Property 'model' (within property expression 'model.propertyNames', of org.apache.tapestry5.corelib.components.BeanDisplay@10290442) is null. [at classpath:org/apache/tapestry5/corelib/components/BeanDisplay.tml, line 4]
          at org.apache.tapestry5.internal.bindings.PropBinding.get(PropBinding.java:62)
          at org.apache.tapestry5.internal.structure.InternalComponentResourcesImpl$1.read(InternalComponentResourcesImpl.java:510)
          ... 80 more
          Caused by: java.lang.NullPointerException: Property 'model' (within property expression 'model.propertyNames', of org.apache.tapestry5.corelib.components.BeanDisplay@10290442) is null.
          at org.apache.tapestry5.internal.services.PropertyConduitSourceImpl.nullTerm(PropertyConduitSourceImpl.java:1256)
          at $PropertyConduit_12622d290ec.navigate($PropertyConduit_12622d290ec.java)
          at $PropertyConduit_12622d290ec.get($PropertyConduit_12622d290ec.java)
          at org.apache.tapestry5.internal.bindings.PropBinding.get(PropBinding.java:58)
          ... 81 more

          thiagohp Thiago H. de Paula Figueiredo added a comment -

          Reopening to close it with a different resolution.

          thiagohp Thiago H. de Paula Figueiredo added a comment -

          TAP5-2270 was already fixed and had the same source as this ticket.


            People

            • Assignee:
              Unassigned
              Reporter:
              hagios17 Dan Adams
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development