Uploaded image for project: 'Tapestry 5'
  1. Tapestry 5
  2. TAP5-2379

Upgrade to Less4j 1.8.1 and ANTLR 3.5.2

    Details

    • Type: Dependency upgrade
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 5.4
    • Fix Version/s: 5.4
    • Component/s: tapestry-webresources
    • Labels:

      Description

      Less4j 1.8.1 is now using antlr 3.5.2 which fixes NPE in CompositeGrammer.getIndirectDelegates in Java 8.

      I think this was the issue that prevented the release of 5.4-beta-14 back in July.

        Attachments

          Activity

            People

            • Assignee:
              hlship Howard M. Lewis Ship
              Reporter:
              fscheffer Felix Scheffer
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: