Uploaded image for project: 'Tapestry 5'
  1. Tapestry 5
  2. TAP5-2321

Tapestry 5.3.7 does not run with Java 8

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 5.3.7
    • Fix Version/s: 5.3.8
    • Component/s: plastic
    • Labels:
      None

      Description

      Tapestry 5.3.7 does not run on Java 8 due to ASM issues.
      The same fix applied to Tapestry 5.4 should be applied to Tapestry 5.3
      and 5.3.8 should be release.

        Issue Links

          Activity

          Hide
          lprimak Lenny Primak added a comment -
          Show
          lprimak Lenny Primak added a comment - Related Ticket: https://issues.apache.org/jira/browse/TAP5-2214
          Hide
          kaosko Kalle Korhonen added a comment -

          TAP5-2214 Was merged to 5.3 branch:
          commit a0ac605dbd89f543b0396d747f5909e1ba38205b
          Author: kaosko <kaosko@apache.org>
          Date: Tue Mar 25 11:29:43 2014 -0700

          FIXED - TAP5-2214: Make tapestry5 java8 compatible

          • update ASM source to 5.0.1, should be jdk 1.5 compatible, see ASM bug
            "317132 ASM 5.0 do not supported JDK 1.5?"
          Show
          kaosko Kalle Korhonen added a comment - TAP5-2214 Was merged to 5.3 branch: commit a0ac605dbd89f543b0396d747f5909e1ba38205b Author: kaosko <kaosko@apache.org> Date: Tue Mar 25 11:29:43 2014 -0700 FIXED - TAP5-2214 : Make tapestry5 java8 compatible update ASM source to 5.0.1, should be jdk 1.5 compatible, see ASM bug "317132 ASM 5.0 do not supported JDK 1.5?"

            People

            • Assignee:
              kaosko Kalle Korhonen
              Reporter:
              lprimak Lenny Primak
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development