Tapestry 5
  1. Tapestry 5
  2. TAP5-1728

Quickstart archetype does not include the build.gradle

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 5.3
    • Fix Version/s: 5.3
    • Component/s: quickstart
    • Labels:
      None

      Description

      Just tested this with 5.3-beta-28 and the newly generate project is missing the build.gradle file.

      Update: noticed that the generate pom.xml references beta-23, not beta-28. Something may be wrong with the build.

        Activity

        Hudson added a comment -

        Integrated in tapestry-trunk-freestyle #611 (See https://builds.apache.org/job/tapestry-trunk-freestyle/611/)
        TAP5-1728: Quickstart archetype does not include the build.gradle
        TAP5-1728: Undo damage caused by code reformatting
        TAP5-1728: Make quickstart smarter about rebuilding its files when the project build.gradle changes (typically, a change of version number)
        TAP5-1728: Quickstart archetype does not include the build.gradle

        hlship : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1189373
        Files :

        • /tapestry/tapestry5/trunk/quickstart/src/main/resources/META-INF/maven/archetype-metadata.xml

        hlship : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1189372
        Files :

        • /tapestry/tapestry5/trunk/quickstart/filtered/archetype-resources/src/main/java/components/Layout.java
        • /tapestry/tapestry5/trunk/quickstart/filtered/archetype-resources/src/main/java/pages/About.java
        • /tapestry/tapestry5/trunk/quickstart/filtered/archetype-resources/src/main/java/pages/Contact.java
        • /tapestry/tapestry5/trunk/quickstart/filtered/archetype-resources/src/main/java/pages/Index.java
        • /tapestry/tapestry5/trunk/quickstart/filtered/archetype-resources/src/main/java/services/AppModule.java
        • /tapestry/tapestry5/trunk/quickstart/filtered/archetype-resources/src/main/java/services/DevelopmentModule.java
        • /tapestry/tapestry5/trunk/quickstart/filtered/archetype-resources/src/main/java/services/QaModule.java
        • /tapestry/tapestry5/trunk/quickstart/src/main/resources/META-INF/maven/archetype-metadata.xml

        hlship : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1189371
        Files :

        • /tapestry/tapestry5/trunk/build.gradle
        • /tapestry/tapestry5/trunk/quickstart/build.gradle

        hlship : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1189337
        Files :

        • /tapestry/tapestry5/trunk/build.gradle
        • /tapestry/tapestry5/trunk/quickstart/build.gradle
        • /tapestry/tapestry5/trunk/quickstart/filtered
        • /tapestry/tapestry5/trunk/quickstart/filtered/archetype-resources
        • /tapestry/tapestry5/trunk/quickstart/filtered/archetype-resources/build.gradle
        • /tapestry/tapestry5/trunk/quickstart/filtered/archetype-resources/pom.xml
        • /tapestry/tapestry5/trunk/quickstart/filtered/archetype-resources/src
        • /tapestry/tapestry5/trunk/quickstart/filtered/archetype-resources/src/main
        • /tapestry/tapestry5/trunk/quickstart/filtered/archetype-resources/src/main/java
        • /tapestry/tapestry5/trunk/quickstart/filtered/archetype-resources/src/main/java/components
        • /tapestry/tapestry5/trunk/quickstart/filtered/archetype-resources/src/main/java/components/Layout.java
        • /tapestry/tapestry5/trunk/quickstart/filtered/archetype-resources/src/main/java/pages
        • /tapestry/tapestry5/trunk/quickstart/filtered/archetype-resources/src/main/java/pages/About.java
        • /tapestry/tapestry5/trunk/quickstart/filtered/archetype-resources/src/main/java/pages/Contact.java
        • /tapestry/tapestry5/trunk/quickstart/filtered/archetype-resources/src/main/java/pages/Index.java
        • /tapestry/tapestry5/trunk/quickstart/filtered/archetype-resources/src/main/java/services
        • /tapestry/tapestry5/trunk/quickstart/filtered/archetype-resources/src/main/java/services/AppModule.java
        • /tapestry/tapestry5/trunk/quickstart/filtered/archetype-resources/src/main/java/services/DevelopmentModule.java
        • /tapestry/tapestry5/trunk/quickstart/filtered/archetype-resources/src/main/java/services/QaModule.java
        • /tapestry/tapestry5/trunk/quickstart/filtered/archetype-resources/src/main/resources
        • /tapestry/tapestry5/trunk/quickstart/filtered/archetype-resources/src/main/resources/components
        • /tapestry/tapestry5/trunk/quickstart/filtered/archetype-resources/src/main/resources/components/Layout.tml
        • /tapestry/tapestry5/trunk/quickstart/filtered/archetype-resources/src/main/resources/log4j.properties
        • /tapestry/tapestry5/trunk/quickstart/filtered/archetype-resources/src/main/resources/pages
        • /tapestry/tapestry5/trunk/quickstart/filtered/archetype-resources/src/main/resources/pages/About.tml
        • /tapestry/tapestry5/trunk/quickstart/filtered/archetype-resources/src/main/resources/pages/Contact.tml
        • /tapestry/tapestry5/trunk/quickstart/filtered/archetype-resources/src/main/resources/pages/Index.properties
        • /tapestry/tapestry5/trunk/quickstart/filtered/archetype-resources/src/main/resources/pages/Index.tml
        • /tapestry/tapestry5/trunk/quickstart/prototypes/META-INF/DEPENDENCIES
        • /tapestry/tapestry5/trunk/quickstart/prototypes/META-INF/LICENSE
        • /tapestry/tapestry5/trunk/quickstart/prototypes/META-INF/NOTICE
        • /tapestry/tapestry5/trunk/quickstart/prototypes/META-INF/maven/archetype-metadata.xml
        • /tapestry/tapestry5/trunk/quickstart/prototypes/META-INF/maven/plugin.xml
        • /tapestry/tapestry5/trunk/quickstart/prototypes/archetype-resources/build.gradle
        • /tapestry/tapestry5/trunk/quickstart/prototypes/archetype-resources/pom.xml
        • /tapestry/tapestry5/trunk/quickstart/prototypes/archetype-resources/src/main/java/components/Layout.java
        • /tapestry/tapestry5/trunk/quickstart/prototypes/archetype-resources/src/main/java/pages/About.java
        • /tapestry/tapestry5/trunk/quickstart/prototypes/archetype-resources/src/main/java/pages/Contact.java
        • /tapestry/tapestry5/trunk/quickstart/prototypes/archetype-resources/src/main/java/pages/Index.java
        • /tapestry/tapestry5/trunk/quickstart/prototypes/archetype-resources/src/main/java/services/AppModule.java
        • /tapestry/tapestry5/trunk/quickstart/prototypes/archetype-resources/src/main/java/services/DevelopmentModule.java
        • /tapestry/tapestry5/trunk/quickstart/prototypes/archetype-resources/src/main/java/services/QaModule.java
        • /tapestry/tapestry5/trunk/quickstart/prototypes/archetype-resources/src/main/resources/components/Layout.tml
        • /tapestry/tapestry5/trunk/quickstart/prototypes/archetype-resources/src/main/resources/log4j.properties
        • /tapestry/tapestry5/trunk/quickstart/prototypes/archetype-resources/src/main/resources/pages/About.tml
        • /tapestry/tapestry5/trunk/quickstart/prototypes/archetype-resources/src/main/resources/pages/Contact.tml
        • /tapestry/tapestry5/trunk/quickstart/prototypes/archetype-resources/src/main/resources/pages/Index.properties
        • /tapestry/tapestry5/trunk/quickstart/prototypes/archetype-resources/src/main/resources/pages/Index.tml
        • /tapestry/tapestry5/trunk/quickstart/prototypes/archetype-resources/src/main/webapp/WEB-INF/app.properties
        • /tapestry/tapestry5/trunk/quickstart/prototypes/archetype-resources/src/main/webapp/WEB-INF/web.xml
        • /tapestry/tapestry5/trunk/quickstart/prototypes/archetype-resources/src/main/webapp/favicon.ico
        • /tapestry/tapestry5/trunk/quickstart/prototypes/archetype-resources/src/main/webapp/layout/images/img01.jpg
        • /tapestry/tapestry5/trunk/quickstart/prototypes/archetype-resources/src/main/webapp/layout/images/img03.jpg
        • /tapestry/tapestry5/trunk/quickstart/prototypes/archetype-resources/src/main/webapp/layout/images/img04.jpg
        • /tapestry/tapestry5/trunk/quickstart/prototypes/archetype-resources/src/main/webapp/layout/images/img08.gif
        • /tapestry/tapestry5/trunk/quickstart/prototypes/archetype-resources/src/main/webapp/layout/images/img09.gif
        • /tapestry/tapestry5/trunk/quickstart/prototypes/archetype-resources/src/main/webapp/layout/images/img10.gif
        • /tapestry/tapestry5/trunk/quickstart/prototypes/archetype-resources/src/main/webapp/layout/images/img11.gif
        • /tapestry/tapestry5/trunk/quickstart/prototypes/archetype-resources/src/main/webapp/layout/images/img12.gif
        • /tapestry/tapestry5/trunk/quickstart/prototypes/archetype-resources/src/main/webapp/layout/images/img13.gif
        • /tapestry/tapestry5/trunk/quickstart/prototypes/archetype-resources/src/main/webapp/layout/images/img14.gif
        • /tapestry/tapestry5/trunk/quickstart/prototypes/archetype-resources/src/main/webapp/layout/images/img18.gif
        • /tapestry/tapestry5/trunk/quickstart/prototypes/archetype-resources/src/main/webapp/layout/images/img19.gif
        • /tapestry/tapestry5/trunk/quickstart/prototypes/archetype-resources/src/main/webapp/layout/images/img20.gif
        • /tapestry/tapestry5/trunk/quickstart/prototypes/archetype-resources/src/main/webapp/layout/layout.css
        • /tapestry/tapestry5/trunk/quickstart/prototypes/archetype-resources/src/main/webapp/layout/license.txt
        • /tapestry/tapestry5/trunk/quickstart/prototypes/archetype-resources/src/site/apt/index.apt
        • /tapestry/tapestry5/trunk/quickstart/prototypes/archetype-resources/src/site/site.xml
        • /tapestry/tapestry5/trunk/quickstart/prototypes/archetype-resources/src/test/conf/testng.xml
        • /tapestry/tapestry5/trunk/quickstart/prototypes/archetype-resources/src/test/conf/webdefault.xml
        • /tapestry/tapestry5/trunk/quickstart/prototypes/archetype-resources/src/test/java/PLACEHOLDER
        • /tapestry/tapestry5/trunk/quickstart/prototypes/archetype-resources/src/test/resources/PLACEHOLDER
        • /tapestry/tapestry5/trunk/quickstart/src/main/resources/META-INF/DEPENDENCIES
        • /tapestry/tapestry5/trunk/quickstart/src/main/resources/META-INF/LICENSE
        • /tapestry/tapestry5/trunk/quickstart/src/main/resources/META-INF/NOTICE
        • /tapestry/tapestry5/trunk/quickstart/src/main/resources/META-INF/maven/archetype-metadata.xml
        • /tapestry/tapestry5/trunk/quickstart/src/main/resources/META-INF/maven/plugin.xml
        • /tapestry/tapestry5/trunk/quickstart/src/main/resources/archetype-resources/src/main/webapp/WEB-INF/app.properties
        • /tapestry/tapestry5/trunk/quickstart/src/main/resources/archetype-resources/src/main/webapp/WEB-INF/web.xml
        • /tapestry/tapestry5/trunk/quickstart/src/main/resources/archetype-resources/src/main/webapp/favicon.ico
        • /tapestry/tapestry5/trunk/quickstart/src/main/resources/archetype-resources/src/main/webapp/layout/images/img01.jpg
        • /tapestry/tapestry5/trunk/quickstart/src/main/resources/archetype-resources/src/main/webapp/layout/images/img03.jpg
        • /tapestry/tapestry5/trunk/quickstart/src/main/resources/archetype-resources/src/main/webapp/layout/images/img04.jpg
        • /tapestry/tapestry5/trunk/quickstart/src/main/resources/archetype-resources/src/main/webapp/layout/images/img08.gif
        • /tapestry/tapestry5/trunk/quickstart/src/main/resources/archetype-resources/src/main/webapp/layout/images/img09.gif
        • /tapestry/tapestry5/trunk/quickstart/src/main/resources/archetype-resources/src/main/webapp/layout/images/img10.gif
        • /tapestry/tapestry5/trunk/quickstart/src/main/resources/archetype-resources/src/main/webapp/layout/images/img11.gif
        • /tapestry/tapestry5/trunk/quickstart/src/main/resources/archetype-resources/src/main/webapp/layout/images/img12.gif
        • /tapestry/tapestry5/trunk/quickstart/src/main/resources/archetype-resources/src/main/webapp/layout/images/img13.gif
        • /tapestry/tapestry5/trunk/quickstart/src/main/resources/archetype-resources/src/main/webapp/layout/images/img14.gif
        • /tapestry/tapestry5/trunk/quickstart/src/main/resources/archetype-resources/src/main/webapp/layout/images/img18.gif
        • /tapestry/tapestry5/trunk/quickstart/src/main/resources/archetype-resources/src/main/webapp/layout/images/img19.gif
        • /tapestry/tapestry5/trunk/quickstart/src/main/resources/archetype-resources/src/main/webapp/layout/images/img20.gif
        • /tapestry/tapestry5/trunk/quickstart/src/main/resources/archetype-resources/src/main/webapp/layout/layout.css
        • /tapestry/tapestry5/trunk/quickstart/src/main/resources/archetype-resources/src/main/webapp/layout/license.txt
        • /tapestry/tapestry5/trunk/quickstart/src/main/resources/archetype-resources/src/site/apt/index.apt
        • /tapestry/tapestry5/trunk/quickstart/src/main/resources/archetype-resources/src/site/site.xml
        • /tapestry/tapestry5/trunk/quickstart/src/main/resources/archetype-resources/src/test/conf/testng.xml
        • /tapestry/tapestry5/trunk/quickstart/src/main/resources/archetype-resources/src/test/conf/webdefault.xml
        • /tapestry/tapestry5/trunk/quickstart/src/main/resources/archetype-resources/src/test/java/PLACEHOLDER
        • /tapestry/tapestry5/trunk/quickstart/src/main/resources/archetype-resources/src/test/resources/PLACEHOLDER

          People

          • Assignee:
            Howard M. Lewis Ship
            Reporter:
            Howard M. Lewis Ship
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development