Tapestry 5
  1. Tapestry 5
  2. TAP5-1395

contributeTranslatorSource compatibility is broken with T5.1

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 5.2.4
    • Fix Version/s: None
    • Component/s: tapestry-core
    • Labels:
      None

      Description

      My project use equanda.
      After evolving from T5.1 to T5.2.4, when i go to the first page of my app, i get an exception ;

      Caused by: java.lang.RuntimeException: Error invoking service contribution method org.equanda.tapestry5.services.EquandaModule.contributeTranslatorSource(Configuration): Service 'TranslatorSource' is configured using org.apache.tapestry5.ioc.MappedConfiguration, not org.apache.tapestry5.ioc.Configuration.

        Activity

        Howard M. Lewis Ship added a comment -

        This is unfortunate, but there was no backwards compatible solution.


          People

          • Assignee:
            Unassigned
            Reporter:
            Philippe Lacaze
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development