Tapestry 5
  1. Tapestry 5
  2. TAP5-1258

Maven quickstart archetype puts the wrong version in the pom.xml

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 5.2.1, 5.2
    • Fix Version/s: 5.2.1
    • Component/s: quickstart
    • Labels:
      None

      Description

      Running the command mvn archetype:generate -DarchetypeCatalog=http://tapestry.apache.org (taken from http://tapestry.apache.org/tapestry5.2-dev/quickstart/) and specifying 5.2.0 creates the project as expected, but the pom.xml contains <tapestry-release-version>5.2.0-SNAPSHOT</tapestry-release-version> which is incorrect - this project doesn't compile. The line should be <tapestry-release-version>5.2.0</tapestry-release-version>

      Here are the steps to reproduce:
      run: mvn archetype:generate -DarchetypeCatalog=http://tapestry.apache.org
      [INFO] [archetype:generate

      {execution: default-cli}

      ]
      [INFO] Generating project in Interactive mode
      [INFO] No archetype defined. Using maven-archetype-quickstart (org.apache.maven.archetypes:maven-archetype-quickstart:1.0)
      Choose archetype:
      1: http://tapestry.apache.org -> quickstart (Tapestry 5.2.1-SNAPSHOT Quickstart Project)
      2: http://tapestry.apache.org -> tapestry-archetype (Tapestry 4.1.6 Archetype)
      Choose a number: : 1
      Choose version:
      1: 5.0.19
      2: 5.1.0.5
      3: 5.2.0
      4: 5.2.1-SNAPSHOT
      Choose a number: : 3
      [[fill in any info for the groupId, artifactId, etc]] and then mvn jetty:run

      In addition, trying to create a project for tapestry 5.2.1-SNAPSHOT also has the incorrect version <tapestry-release-version>5.2.0-SNAPSHOT</tapestry-release-version>, which should be <tapestry-release-version>5.2.1-SNAPSHOT</tapestry-release-version>

      The steps are the same as above, but choosing 4 instead of 3.

        Activity

        Hudson added a comment -

        Integrated in tapestry-5.2-freestyle #180 (See https://hudson.apache.org/hudson/job/tapestry-5.2-freestyle/180/)
        TAP5-1258: update archetype version

        Andreas Andreou added a comment -

        fixed for 5.2.1-SNAPSHOT - unfortunately, there's no way to change this for 5.2.0 since it's already been published


          People

          • Assignee:
            Andreas Andreou
            Reporter:
            Donny Nadolny
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development