Tapestry 5
  1. Tapestry 5
  2. TAP5-1023

(5.2.0-SPNAPSHOT Maven dependencies) tapestry-hibernate-5.2.0 jar generated with tapestry-hibernate-5.2.0-yyyyMMdd.hhmmss-?.jar > tapestry-hibernate-5.2.0-SNAPSHOT.jar whereas all other jar are using -5.2.0-SNAPSHOT

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: 5.2.0
    • Component/s: None
    • Labels:
      None
    • Environment:
      osx snow leopard, linux redhat

      Description

      Cause duplicate of tapestry-hibernate-XXX.jar at the deployment.

      Example:
      tapestry-core-5.2.0-SNAPSHOT.jar
      tapestry-hibernate-5.2.0-20100217.091747-192.jar
      tapestry-hibernate-5.2.0-20100219.090323-194.jar
      tapestry-hibernate-core-5.2.0-SNAPSHOT.jar
      tapestry-ioc-5.2.0-SNAPSHOT.jar
      tapestry5-annotations-5.2.0-SNAPSHOT.jar

        Activity

        Basile Chandesris created issue -
        Basile Chandesris made changes -
        Field Original Value New Value
        Summary tapestry-hibernate-5.2.0 jar generated with tapestry-hibernate-5.2.0-yyyyMMdd.hhmmss-?.jar > tapestry-hibernate-5.2.0-SNAPSHOT.jar whereas alo (5.2.0-SPNAPSHOT Maven dependencies) tapestry-hibernate-5.2.0 jar generated with tapestry-hibernate-5.2.0-yyyyMMdd.hhmmss-?.jar > tapestry-hibernate-5.2.0-SNAPSHOT.jar whereas all other jar are using -5.2.0-SNAPSHOT
        Environment osx snow leopard, linux redhat
        Description causing duplicate of tapestry-hibernate-XXX.jar at the deployment.

        tapestry-hibernate-5.2.0-20100217.091747-192.jar
        tapestry-hibernate-5.2.0-20100219.090323-194.jar
        tapestry-hibernate-core-5.2.0-SNAPSHOT.jar
        tapestry-ioc-5.2.0-SNAPSHOT.jar
        tapestry5-annotations-5.2.0-SNAPSHOT.jar
        tapestry-core-5.2.0-SNAPSHOT.jar
        Cause duplicate of tapestry-hibernate-XXX.jar at the deployment.

        Example:
        tapestry-core-5.2.0-SNAPSHOT.jar
        tapestry-hibernate-5.2.0-20100217.091747-192.jar
        tapestry-hibernate-5.2.0-20100219.090323-194.jar
        tapestry-hibernate-core-5.2.0-SNAPSHOT.jar
        tapestry-ioc-5.2.0-SNAPSHOT.jar
        tapestry5-annotations-5.2.0-SNAPSHOT.jar
        Fix Version/s 5.2.0 [ 12314122 ]
        Ulrich Stärk added a comment -

        Could you please rephrase that? I don't get what your problem is...

        Basile Chandesris added a comment -

        When I use in my pom.xml:

        Extract:
        ...
        <dependencies>
        <dependency>
        <groupId>javassist</groupId>
        <artifactId>javassist</artifactId>
        <version>3.10.0.GA</version>
        </dependency>

        <dependency>
        <groupId>org.hibernate</groupId>
        <artifactId>hibernate-core</artifactId>
        <version>3.3.2.GA</version>
        </dependency>

        <dependency>
        <groupId>org.hibernate</groupId>
        <artifactId>hibernate-c3p0</artifactId>
        <version>3.3.2.GA</version>
        </dependency>

        <dependency>
        <groupId>org.hibernate</groupId>
        <artifactId>hibernate-annotations</artifactId>
        <version>3.4.0.GA</version>
        </dependency>

        <dependency>
        <groupId>org.apache.tapestry</groupId>
        <artifactId>tapestry-hibernate</artifactId>
        <version>$

        {tapestry-release-version}</version>
        </dependency>

        <dependency>
        <groupId>org.apache.tapestry</groupId>
        <artifactId>tapestry-hibernate-core</artifactId>
        <version>${tapestry-release-version}

        </version>
        </dependency>

        <dependency>
        <groupId>org.apache.tapestry</groupId>
        <artifactId>tapestry-core</artifactId>
        <version>$

        {tapestry-release-version}</version>
        </dependency>

        <dependency>
        <groupId>org.apache.tapestry</groupId>
        <artifactId>tapestry-ioc</artifactId>
        <version>${tapestry-release-version}

        </version>
        </dependency>

        <dependency>
        <groupId>org.apache.tapestry</groupId>
        <artifactId>tapestry5-annotations</artifactId>
        <version>$

        {tapestry-release-version}

        </version>
        </dependency>
        ...

        with
        <properties>
        <tapestry-release-version>5.2.0-SNAPSHOT</tapestry-release-version>
        <!-- <tapestry-release-version>5.1.0.7</tapestry-release-version> -->
        </properties>

        Launching each day 'mvn install',
        add a new tapestry-hibernate- .jar
        without removing the old one.
        The names here are always different.

        tapestry-hibernate-5.2.0-20100217.091747-192.jar
        tapestry-hibernate-5.2.0-20100219.090323-194.jar

        But this process is working for all jar named with 5.2.0-SNAPSHOT,
        all the other jar of Tapestry 5.2.0-SNAPSHOT.

        Howard M. Lewis Ship made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Assignee Howard M. Lewis Ship [ hlship ]
        Resolution Cannot Reproduce [ 5 ]
        Basile Chandesris made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        112d 6h 11m 1 Howard M. Lewis Ship 11/Jun/10 19:39
        Resolved Resolved Closed Closed
        1440d 1h 29m 1 Basile Chandesris 21/May/14 21:08

          People

          • Assignee:
            Howard M. Lewis Ship
            Reporter:
            Basile Chandesris
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development