Tapestry 5
  1. Tapestry 5
  2. TAP5-1018

Request to Application Root path ignores ComponentRequestFilter's

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 5.2, 5.1.0.5
    • Fix Version/s: 5.2.0
    • Component/s: tapestry-core
    • Labels:
      None

      Description

      Example:

      I've made a ComponentRequestFilter to handle Locale issues... And if I request [ /t5app/Start ] page, my Filter code is executed. But, if I request the Application Root path [ /t5app or /t5app/ ] it ignores the Filter and avoids it.

      -------------

      Following [Thiago H. de Paula Figueiredo] comment:

      I've looked at the sources and I've found that RootPathDispatcher, the dispatcher that handles the root URL, doesn't invoke the ComponentEventHandler, which is the pipeline that invokes the ComponentEventFilter's. This is a bug, so please file a JIRA about it.

        Activity

        Everton Agner Ramos created issue -
        Leonard Lu added a comment -

        This issue could be handled by having the RootPathDispatcher send a redirect rather than handling the request itself.

        For other searchers, a lovely graphic with the Tapestry5 request processing pipelines is available at http://tapestry.formos.com/nightly/tapestry5/images/tapestry_request_processing_800.png, which makes it clear that the current intended behavior is for RootPath to completely bypass the Asset, ComponentEvent and PageRender Dispatchers.

        Ulrich Stärk added a comment -

        You should consider using index pages instead of the deprecated Start page.

        Ulrich Stärk made changes -
        Field Original Value New Value
        Remaining Estimate 0h [ 0 ]
        Assignee Ulrich Stärk [ ulrich.staerk ]
        Original Estimate 0h [ 0 ]
        Fix Version/s 5.2.0 [ 12314122 ]
        Affects Version/s 5.2 [ 12313900 ]
        Fix Version/s 5.1.0.8 [ 12314520 ]
        Ulrich Stärk made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Jochen Kemnade made changes -
        Fix Version/s 5.1.0.8 [ 12314520 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        25d 3h 16m 1 Ulrich Stärk 14/Mar/10 20:26

          People

          • Assignee:
            Ulrich Stärk
            Reporter:
            Everton Agner Ramos
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development