Uploaded image for project: 'Tajo'
  1. Tajo
  2. TAJO-852

Integration test using HCatalog as a catalog store is failed

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.8.0, 0.9.0
    • Fix Version/s: 0.9.0
    • Component/s: None
    • Labels:
      None

      Description

      When I tried to do integration test using HCatalog as a catalog store, the test is failed.

      mvn clean install -Phcatalog-0.12.0 
      -Dtajo.catalog.store.class=org.apache.tajo.catalog.store.HCatalogStore
      
      2014-05-27 10:48:22,392 INFO: org.apache.tajo.master.querymaster.QueryMasterManagerService (stop(111)) - QueryMasterManagerService stopped
      2014-05-27 10:48:22,392 INFO: org.apache.tajo.master.querymaster.QueryMaster (run(434)) - QueryMaster heartbeat thread stopped
      2014-05-27 10:48:22,392 INFO: org.apache.tajo.master.TajoAsyncDispatcher (stop(122)) - AsyncDispatcher stopped:querymaster_1401155008909
      2014-05-27 10:48:22,393 INFO: org.apache.tajo.master.querymaster.QueryMaster (stop(160)) - QueryMaster stop
      2014-05-27 10:48:22,393 INFO: org.apache.tajo.worker.TajoWorkerClientService (stop(109)) - TajoWorkerClientService stopping
      2014-05-27 10:48:22,393 INFO: org.apache.tajo.rpc.NettyServerBase (shutdown(128)) - Rpc (QueryMasterClientProtocol) listened on 0:0:0:0:0:0:0:0:18372) shutdown
      2014-05-27 10:48:22,393 INFO: org.apache.tajo.worker.TajoWorkerClientService (stop(113)) - TajoWorkerClientService stopped
      2014-05-27 10:48:22,393 INFO: org.apache.tajo.worker.TajoWorker (stop(334)) - TajoWorker main thread exiting
      
      Results :
      
      Failed tests:   testQueryCasesOnColumnPartitionedTable(org.apache.tajo.engine.query.TestTablePartitions): Result Verification expected:<...-------------------(..)
        testKillScheduledQuery(org.apache.tajo.scheduler.TestFifoScheduler): expected:<QUERY_MASTER_INIT> but was:<QUERY_RUNNING>
        testScheduledQuery(org.apache.tajo.scheduler.TestFifoScheduler): expected:<QUERY_RUNNING> but was:<QUERY_MASTER_INIT>
        testForwardedQuery(org.apache.tajo.scheduler.TestFifoScheduler): expected:<QUERY_RUNNING> but was:<QUERY_MASTER_INIT>
        case3(org.apache.tajo.master.querymaster.TestQueryUnitStatusUpdate): expected:<7> but was:<10>
      
      Tests in error: 
        testCreateTableLike1(org.apache.tajo.engine.query.TestCreateTable)
      
      Tests run: 756, Failures: 5, Errors: 1, Skipped: 0
      
      [INFO] ------------------------------------------------------------------------
      [INFO] Reactor Summary:
      

        Activity

        jhkim Jinho Kim added a comment -

        The bug is caused by varchar type with hcatalog in hive-0.12.0
        I think that we need bump up the hive version at next release

        tajoqa Tajo QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12654486/TAJO-852.patch
        against master revision b9a3972.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 3 new or modified test files.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. The applied patch does not increase the total number of javadoc warnings.

        +1 checkstyle. The patch generated 0 code style errors.

        -1 findbugs. The patch appears to introduce 199 new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed unit tests in tajo-catalog/tajo-catalog-drivers/tajo-hcatalog tajo-common tajo-core tajo-rpc.

        Test results: https://builds.apache.org/job/PreCommit-TAJO-Build/460//testReport/
        Findbugs warnings: https://builds.apache.org/job/PreCommit-TAJO-Build/460//artifact/incubator-tajo/patchprocess/newPatchFindbugsWarningstajo-common.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-TAJO-Build/460//artifact/incubator-tajo/patchprocess/newPatchFindbugsWarningstajo-core.html
        Console output: https://builds.apache.org/job/PreCommit-TAJO-Build/460//console

        This message is automatically generated.

        hyunsik Hyunsik Choi added a comment -

        +1

        The patch looks good to me. I also verified 'mvn clean install'.

        blrunner Jaehwa Jung added a comment -

        +1.

        Jinho, thank you for your contribution.
        It looks good overall, and 'mvn clean install -Phcatalog-0.12.0 -Dtajo.catalog.store.class=org.apache.tajo.catalog.store.HCatalogStore' finished successfully. But I recommend for you to add some comments at unit test cases. Because other contributors may not understand why you check HCatalogStoreRunning status.

        jhkim Jinho Kim added a comment -

        Jaehwa Jung
        I've added comment in TestResultSet
        Thanks guys for the review.

        hudson Hudson added a comment -

        FAILURE: Integrated in Tajo-master-build #289 (See https://builds.apache.org/job/Tajo-master-build/289/)
        TAJO-852: Integration test using HCatalog as a catalog store is failed. (jinho) (jinossy: rev a17bd0f182d5405450b3e47be81f45dd6cdc362e)

        • tajo-core/src/test/java/org/apache/tajo/jdbc/TestResultSet.java
        • tajo-catalog/tajo-catalog-drivers/tajo-hcatalog/src/main/java/org/apache/tajo/catalog/store/HCatalogStore.java
        • tajo-catalog/tajo-catalog-drivers/tajo-hcatalog/src/main/java/org/apache/tajo/catalog/store/HCatalogStoreClientPool.java
        • tajo-common/src/main/java/org/apache/tajo/util/KeyValueSet.java
        • CHANGES
        • tajo-rpc/src/test/java/org/apache/tajo/rpc/TestAsyncRpc.java
        • tajo-core/src/test/java/org/apache/tajo/engine/query/TestCreateTable.java

          People

          • Assignee:
            jhkim Jinho Kim
            Reporter:
            hyunsik Hyunsik Choi
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development