Uploaded image for project: 'Tajo'
  1. Tajo
  2. TAJO-831

Project wrong column in the case of having same alias in subquery.

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: 0.10.0
    • Component/s: None
    • Labels:
      None

      Description

      The following query should return L_RECEIPTDATE column from lineitem table, but return O_ORDERKEY from orders table.

      select
          a.L_RECEIPTDATE as col1
      from
          (select * from lineitem) a
      join
          (select O_ORDERKEY col1 from orders) b
      on
          a.L_ORDERKEY = b.col1
      

        Activity

        mhthanh Mai Hai Thanh added a comment -

        Hi Hyoungjun Kim,
        When I test this query, the content of L_RECEIPTDATE column is returned correctly, not O_ORDERKEY. Maybe, this is no longer a bug.

        blrunner Jaehwa Jung added a comment -

        I also can't reproduce it.


          People

          • Assignee:
            Unassigned
            Reporter:
            hjkim Hyoungjun Kim
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development