Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 0.8.0
    • Fix Version/s: 0.8.0, 0.9.0
    • Component/s: None
    • Labels:
      None
    • Environment:

      Linux machine

      Description

      See the title. When I run 'mvn clean install', the following error occurred.

      경고: An exception was thrown by a user handler while handling an exception event ([id: 0xf94e9a31] EXCEPTION: java.nio.channels.UnresolvedAddressException)
      java.lang.NullPointerException
      	at org.apache.tajo.rpc.NettyClientBase.getRemoteAddress(NettyClientBase.java:78)
      	at org.apache.tajo.rpc.AsyncRpcClient$ClientChannelUpstreamHandler.exceptionCaught(AsyncRpcClient.java:220)
      	at org.jboss.netty.handler.codec.oneone.OneToOneDecoder.handleUpstream(OneToOneDecoder.java:60)
      	at org.jboss.netty.handler.codec.frame.FrameDecoder.exceptionCaught(FrameDecoder.java:377)
      	at org.jboss.netty.channel.Channels.fireExceptionCaught(Channels.java:525)
      	at org.jboss.netty.channel.socket.nio.NioClientSocketPipelineSink.connect(NioClientSocketPipelineSink.java:131)
      	at org.jboss.netty.channel.socket.nio.NioClientSocketPipelineSink.eventSunk(NioClientSocketPipelineSink.java:70)
      	at org.jboss.netty.handler.codec.oneone.OneToOneEncoder.handleDownstream(OneToOneEncoder.java:54)
      	at org.jboss.netty.handler.codec.oneone.OneToOneEncoder.handleDownstream(OneToOneEncoder.java:54)
      	at org.jboss.netty.channel.Channels.connect(Channels.java:634)
      	at org.jboss.netty.channel.AbstractChannel.connect(AbstractChannel.java:207)
      	at org.jboss.netty.bootstrap.ClientBootstrap.connect(ClientBootstrap.java:229)
      	at org.jboss.netty.bootstrap.ClientBootstrap.connect(ClientBootstrap.java:182)
      	at org.apache.tajo.rpc.NettyClientBase.connect(NettyClientBase.java:65)
      	at org.apache.tajo.rpc.NettyClientBase.init(NettyClientBase.java:57)
      	at org.apache.tajo.rpc.AsyncRpcClient.<init>(AsyncRpcClient.java:77)
      	at org.apache.tajo.rpc.RpcConnectionPool.makeConnection(RpcConnectionPool.java:64)
      	at org.apache.tajo.rpc.RpcConnectionPool.getConnection(RpcConnectionPool.java:78)
      	at org.apache.tajo.master.querymaster.QueryInProgress.connectQueryMaster(QueryInProgress.java:200)
      	at org.apache.tajo.master.querymaster.QueryInProgress.submmitQueryToMaster(QueryInProgress.java:213)
      	at org.apache.tajo.master.querymaster.QueryInProgress.access$200(QueryInProgress.java:49)
      	at org.apache.tajo.master.querymaster.QueryInProgress$QueryInProgressEventHandler.handle(QueryInProgress.java:181)
      	at org.apache.tajo.master.querymaster.QueryInProgress$QueryInProgressEventHandler.handle(QueryInProgress.java:173)
      	at org.apache.tajo.master.TajoAsyncDispatcher.dispatch(TajoAsyncDispatcher.java:137)
      	at org.apache.tajo.master.TajoAsyncDispatcher$1.run(TajoAsyncDispatcher.java:79)
      	at java.lang.Thread.run(Thread.java:744)
      
      java.nio.channels.UnresolvedAddressException
      	at sun.nio.ch.Net.checkAddress(Net.java:127)
      	at sun.nio.ch.SocketChannelImpl.connect(SocketChannelImpl.java:644)
      	at org.jboss.netty.channel.socket.nio.NioClientSocketPipelineSink.connect(NioClientSocketPipelineSink.java:108)
      	at org.jboss.netty.channel.socket.nio.NioClientSocketPipelineSink.eventSunk(NioClientSocketPipelineSink.java:70)
      	at org.jboss.netty.handler.codec.oneone.OneToOneEncoder.handleDownstream(OneToOneEncoder.java:54)
      	at org.jboss.netty.handler.codec.oneone.OneToOneEncoder.handleDownstream(OneToOneEncoder.java:54)
      	at org.jboss.netty.channel.Channels.connect(Channels.java:634)
      	at org.jboss.netty.channel.AbstractChannel.connect(AbstractChannel.java:207)
      	at org.jboss.netty.bootstrap.ClientBootstrap.connect(ClientBootstrap.java:229)
      	at org.jboss.netty.bootstrap.ClientBootstrap.connect(ClientBootstrap.java:182)
      	at org.apache.tajo.rpc.NettyClientBase.connect(NettyClientBase.java:65)
      	at org.apache.tajo.rpc.NettyClientBase.init(NettyClientBase.java:57)
      	at org.apache.tajo.rpc.AsyncRpcClient.<init>(AsyncRpcClient.java:77)
      	at org.apache.tajo.rpc.RpcConnectionPool.makeConnection(RpcConnectionPool.java:64)
      	at org.apache.tajo.rpc.RpcConnectionPool.getConnection(RpcConnectionPool.java:78)
      	at org.apache.tajo.master.querymaster.QueryInProgress.connectQueryMaster(QueryInProgress.java:200)
      	at org.apache.tajo.master.querymaster.QueryInProgress.submmitQueryToMaster(QueryInProgress.java:213)
      	at org.apache.tajo.master.querymaster.QueryInProgress.access$200(QueryInProgress.java:49)
      	at org.apache.tajo.master.querymaster.QueryInProgress$QueryInProgressEventHandler.handle(QueryInProgress.java:181)
      	at org.apache.tajo.master.querymaster.QueryInProgress$QueryInProgressEventHandler.handle(QueryInProgress.java:173)
      	at org.apache.tajo.master.TajoAsyncDispatcher.dispatch(TajoAsyncDispatcher.java:137)
      	at org.apache.tajo.master.TajoAsyncDispatcher$1.run(TajoAsyncDispatcher.java:79)
      	at java.lang.Thread.run(Thread.java:744)
      2014-03-28 19:06:24,052 ERROR querymaster.QueryInProgress (QueryInProgress.java:submmitQueryToMaster(233)) - java.nio.channels.UnresolvedAddressException
      java.io.IOException: java.nio.channels.UnresolvedAddressException
      	at org.apache.tajo.rpc.NettyClientBase.init(NettyClientBase.java:60)
      	at org.apache.tajo.rpc.AsyncRpcClient.<init>(AsyncRpcClient.java:77)
      	at org.apache.tajo.rpc.RpcConnectionPool.makeConnection(RpcConnectionPool.java:64)
      	at org.apache.tajo.rpc.RpcConnectionPool.getConnection(RpcConnectionPool.java:78)
      	at org.apache.tajo.master.querymaster.QueryInProgress.connectQueryMaster(QueryInProgress.java:200)
      	at org.apache.tajo.master.querymaster.QueryInProgress.submmitQueryToMaster(QueryInProgress.java:213)
      	at org.apache.tajo.master.querymaster.QueryInProgress.access$200(QueryInProgress.java:49)
      	at org.apache.tajo.master.querymaster.QueryInProgress$QueryInProgressEventHandler.handle(QueryInProgress.java:181)
      	at org.apache.tajo.master.querymaster.QueryInProgress$QueryInProgressEventHandler.handle(QueryInProgress.java:173)
      	at org.apache.tajo.master.TajoAsyncDispatcher.dispatch(TajoAsyncDispatcher.java:137)
      	at org.apache.tajo.master.TajoAsyncDispatcher$1.run(TajoAsyncDispatcher.java:79)
      	at java.lang.Thread.run(Thread.java:744)
      Caused by: java.nio.channels.UnresolvedAddressException
      	at sun.nio.ch.Net.checkAddress(Net.java:127)
      	at sun.nio.ch.SocketChannelImpl.connect(SocketChannelImpl.java:644)
      	at org.jboss.netty.channel.socket.nio.NioClientSocketPipelineSink.connect(NioClientSocketPipelineSink.java:108)
      	at org.jboss.netty.channel.socket.nio.NioClientSocketPipelineSink.eventSunk(NioClientSocketPipelineSink.java:70)
      	at org.jboss.netty.handler.codec.oneone.OneToOneEncoder.handleDownstream(OneToOneEncoder.java:54)
      	at org.jboss.netty.handler.codec.oneone.OneToOneEncoder.handleDownstream(OneToOneEncoder.java:54)
      	at org.jboss.netty.channel.Channels.connect(Channels.java:634)
      	at org.jboss.netty.channel.AbstractChannel.connect(AbstractChannel.java:207)
      	at org.jboss.netty.bootstrap.ClientBootstrap.connect(ClientBootstrap.java:229)
      	at org.jboss.netty.bootstrap.ClientBootstrap.connect(ClientBootstrap.java:182)
      	at org.apache.tajo.rpc.NettyClientBase.connect(NettyClientBase.java:65)
      	at org.apache.tajo.rpc.NettyClientBase.init(NettyClientBase.java:57)
      	... 11 more
      

        Activity

        jhkim Jinho Kim added a comment -

        I've attached the patch. and verified 'mvn clean install'.

        tajoqa Tajo QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12637422/TAJO-719.patch
        against master revision 36007d7.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 2 new or modified test files.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. The applied patch does not increase the total number of javadoc warnings.

        +1 checkstyle. The patch generated 0 code style errors.

        -1 findbugs. The patch appears to introduce 197 new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed unit tests in tajo-core/tajo-core-backend tajo-rpc.

        Test results: https://builds.apache.org/job/PreCommit-TAJO-Build/281//testReport/
        Findbugs warnings: https://builds.apache.org/job/PreCommit-TAJO-Build/281//artifact/incubator-tajo/patchprocess/newPatchFindbugsWarningstajo-core-backend.html
        Console output: https://builds.apache.org/job/PreCommit-TAJO-Build/281//console

        This message is automatically generated.

        jihoonson Jihoon Son added a comment -

        +1.
        This patch looks good to me!

        jhkim Jinho Kim added a comment -

        Thank you for the review. I've just committed it.

        hudson Hudson added a comment -

        SUCCESS: Integrated in Tajo-0.8.0-build #50 (See https://builds.apache.org/job/Tajo-0.8.0-build/50/)
        TAJO-719: JUnit test failures. (jinho) (jinossy: rev 8c2703c2d2d779f26942de23d55069f47618bd93)

        • CHANGES.txt
        • tajo-core/tajo-core-backend/src/main/java/org/apache/tajo/master/querymaster/QueryInProgress.java
        • tajo-rpc/src/main/java/org/apache/tajo/rpc/NettyClientBase.java
        • tajo-rpc/src/test/java/org/apache/tajo/rpc/TestBlockingRpc.java
        • tajo-rpc/src/test/java/org/apache/tajo/rpc/TestAsyncRpc.java
        hudson Hudson added a comment -

        SUCCESS: Integrated in Tajo-master-build #146 (See https://builds.apache.org/job/Tajo-master-build/146/)
        TAJO-719: JUnit test failures. (jinho) (jinossy: rev bbbf21dc1b8383d0ddf842887aa656b171ce6463)

        • tajo-rpc/src/test/java/org/apache/tajo/rpc/TestBlockingRpc.java
        • tajo-rpc/src/test/java/org/apache/tajo/rpc/TestAsyncRpc.java
        • tajo-rpc/src/main/java/org/apache/tajo/rpc/NettyClientBase.java
        • CHANGES.txt
        • tajo-core/tajo-core-backend/src/main/java/org/apache/tajo/master/querymaster/QueryInProgress.java

          People

          • Assignee:
            jhkim Jinho Kim
            Reporter:
            jihoonson Jihoon Son
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development