Column class has some ambiguous methods and some complex logics.
This patch simplifies and refactors Column class as follows:
- Rename getColumnNum() to size()
- Remove qualifier variable from Column and ColumnProto
- Rename getColumnName to getSimpleName
- Move some codes for qualification and simple name to CatalogUtil and refactor them for common identifiers including database, table and column names
- Change Column as an immutable object