Uploaded image for project: 'Tajo'
  1. Tajo
  2. TAJO-423

Using aggregation query on local file system.

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 0.8.0
    • Fix Version/s: 0.8.0
    • Component/s: None
    • Labels:
      None

      Description

      I found a bug to use aggregation query which scan external table stored on local file system as follows:

      • make just directory on local file system.
        • location: /Users/blrunner/data/tajo/table1
      • create table on tsql
        • create external table table1 (id int, name text, score float, type text) using csv with ('csvfile.delimiter'='|') location 'file:/Users/blrunner/data/tajo/table1';
      • query test
        • select count from table1: PASSED
        • select id, count from table1 group by id: PASSED
      • make csv file on location which is '/Users/blrunner/data/tajo/table1'
      • query test again
        • select count from table1: PASSED
        • select id, count from table1 group by id: FAILED
          2013-12-16 18:54:38,080 INFO  planner.PhysicalPlannerImpl (PhysicalPlannerImpl.java:createBestAggregationPlan(727)) - The planner chooses [Hash Aggregation]
          2013-12-16 18:54:38,080 INFO  planner.PhysicalPlannerImpl (PhysicalPlannerImpl.java:createInMemoryHashAggregation(679)) - The planner chooses [Hash Aggregation]
          2013-12-16 18:54:38,080 ERROR worker.Task (Task.java:run(366)) - java.lang.IllegalArgumentException: The number of partitions must be positive: 0
          	at com.google.common.base.Preconditions.checkArgument(Preconditions.java:119)
          	at org.apache.tajo.engine.planner.logical.StoreTableNode.setPartitions(StoreTableNode.java:88)
          	at org.apache.tajo.engine.planner.PhysicalPlannerImpl.buildOutputOperator(PhysicalPlannerImpl.java:97)
          	at org.apache.tajo.engine.planner.PhysicalPlannerImpl.createPlan(PhysicalPlannerImpl.java:80)
          	at org.apache.tajo.worker.TajoQueryEngine.createPlan(TajoQueryEngine.java:44)
          	at org.apache.tajo.worker.Task.run(Task.java:355)
          	at org.apache.tajo.worker.TaskRunner$1.run(TaskRunner.java:376)
          	at java.lang.Thread.run(Thread.java:680)
          
          2013-12-16 18:54:38,081 INFO  worker.Task (Task.java:run(411)) - Task Counter - total:5, succeeded: 2, failed: 3
          2013-12-16 18:54:38,081 INFO  worker.TaskRunner (TaskRunner.java:run(318)) - Request GetTask: eb_1387181184478_0005_000001,container_1387181184478_0005_01_000003
          2013-12-16 18:54:38,081 ERROR querymaster.QueryUnitAttempt (QueryUnitAttempt.java:transition(292)) - FROM 192.168.0.187 >> java.lang.IllegalArgumentException: The number of partitions must be positive: 0
          	at com.google.common.base.Preconditions.checkArgument(Preconditions.java:119)
          	at org.apache.tajo.engine.planner.logical.StoreTableNode.setPartitions(StoreTableNode.java:88)
          	at org.apache.tajo.engine.planner.PhysicalPlannerImpl.buildOutputOperator(PhysicalPlannerImpl.java:97)
          	at org.apache.tajo.engine.planner.PhysicalPlannerImpl.createPlan(PhysicalPlannerImpl.java:80)
          	at org.apache.tajo.worker.TajoQueryEngine.createPlan(TajoQueryEngine.java:44)
          	at org.apache.tajo.worker.Task.run(Task.java:355)
          	at org.apache.tajo.worker.TaskRunner$1.run(TaskRunner.java:376)
          	at java.lang.Thread.run(Thread.java:680)
          

        Activity

        hyunsik Hyunsik Choi added a comment -

        Is this issue still reasonable? I couldn't reproduce this issue.


          People

          • Assignee:
            Unassigned
            Reporter:
            blrunner Jaehwa Jung
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development