Details

    • Type: New Feature
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.10.0
    • Component/s: Catalog
    • Labels:

      Description

      Like TAJO-179, we need to support oracle catalog store.

        Activity

        ykrips Jihun Kang added a comment -

        This patch made for Oracle 11g and 12c. It does not specify the default schema name, tablespaces, and any other session variables.

        hyunsik Hyunsik Choi added a comment -

        If you have some problem to upload the patch, please let me know what I can do for you.

        githubbot ASF GitHub Bot added a comment -

        GitHub user ykrips opened a pull request:

        https://github.com/apache/tajo/pull/154

        TAJO-235: Support Oracle CatalogStore

        It has been tested on Oracle 11g and Oracle 12c DBMS.

        You can merge this pull request into a Git repository by running:

        $ git pull https://github.com/ykrips/tajo TAJO-235

        Alternatively you can review and apply these changes as the patch at:

        https://github.com/apache/tajo/pull/154.patch

        To close this pull request, make a commit to your master/trunk branch
        with (at least) the following in the commit message:

        This closes #154


        commit d4c2f0533f122fc8ca087d49ad99a30a1d8c3b26
        Author: Jihun Kang <ykrips@gmail.com>
        Date: 2014-09-23T23:56:47Z

        TAJO-235: Support Oracle CatalogStore


        ykrips Jihun Kang added a comment -

        Hyunsik Choi, Sorry for giving confusion. I would like to add some features to Oracle CatalogStore class, but it would be affected to another catalog store and it would be better to create a separate issue. I will post soon.

        hyunsik Hyunsik Choi added a comment -

        No problem

        githubbot ASF GitHub Bot added a comment -

        Github user jinossy commented on the pull request:

        https://github.com/apache/tajo/pull/154#issuecomment-57434558

        Great work!!
        I’ll review soon after 0.9.0 release
        Thank you for your contribution!

        githubbot ASF GitHub Bot added a comment -

        Github user ykrips commented on the pull request:

        https://github.com/apache/tajo/pull/154#issuecomment-59327535

        It also pass the TestCatalog testcase with these parameters "-Dtajo.catalog.store.class=org.apache.tajo.catalog.store.OracleStore -Dtajo.catalog.connection.id=tajo -Dtajo.catalog.connection.password=password -Dtajo.catalog.uri=jdbc:oracle:thin:@localhost:1521:orcl12c".

        githubbot ASF GitHub Bot added a comment -

        Github user hyunsik commented on the pull request:

        https://github.com/apache/tajo/pull/154#issuecomment-59451194

        @ykrips Thank you for sharing your test result. Actually, I don't have Oracle in my machine. It was hard to test it on my machine. According to offline chat with @jinossy , he had a plan to test it on his machine.

        I'll review the patch, and I'll finish the review soon.

        githubbot ASF GitHub Bot added a comment -

        Github user jinossy commented on a diff in the pull request:

        https://github.com/apache/tajo/pull/154#discussion_r19006723

        — Diff: tajo-catalog/tajo-catalog-server/src/main/resources/schemas/oracle/partition_methods.sql —
        @@ -0,0 +1,7 @@
        +CREATE TABLE PARTITION_METHODS (
        + TID INT NOT NULL PRIMARY KEY,
        + PARTITION_TYPE VARCHAR2(10) NOT NULL,
        + EXPRESSION VARCHAR2(1024) NOT NULL,
        + EXPRESSION_SCHEMA VARCHAR2(1024) NOT NULL,
        — End diff –

        I can't run TestCatalogStore. Could you change the EXPRESSION_SCHEMA type to binary type ?
        Additionally, please add the driverClass in TestCatalog.isConnectionIdRequired()

        ```
        Caused by: com.google.protobuf.InvalidProtocolBufferException: Protocol message tag had invalid wire type.
        at com.google.protobuf.InvalidProtocolBufferException.invalidWireType(InvalidProtocolBufferException.java:99)
        at com.google.protobuf.UnknownFieldSet$Builder.mergeFieldFrom(UnknownFieldSet.java:498)
        at com.google.protobuf.GeneratedMessage.parseUnknownField(GeneratedMessage.java:193)
        at org.apache.tajo.catalog.proto.CatalogProtos$SchemaProto.<init>(CatalogProtos.java:1617)
        at org.apache.tajo.catalog.proto.CatalogProtos$SchemaProto.<init>(CatalogProtos.java:1575)
        at org.apache.tajo.catalog.proto.CatalogProtos$SchemaProto$1.parsePartialFrom(CatalogProtos.java:1664)
        at org.apache.tajo.catalog.proto.CatalogProtos$SchemaProto$1.parsePartialFrom(CatalogProtos.java:1659)
        at com.google.protobuf.AbstractParser.parsePartialFrom(AbstractParser.java:141)
        at com.google.protobuf.AbstractParser.parseFrom(AbstractParser.java:176)
        at com.google.protobuf.AbstractParser.parseFrom(AbstractParser.java:188)
        at com.google.protobuf.AbstractParser.parseFrom(AbstractParser.java:193)
        at com.google.protobuf.AbstractParser.parseFrom(AbstractParser.java:49)
        at org.apache.tajo.catalog.proto.CatalogProtos$SchemaProto.parseFrom(CatalogProtos.java:1806)
        at org.apache.tajo.catalog.store.AbstractDBStore.resultToPartitionMethodProto(AbstractDBStore.java:1953)
        at org.apache.tajo.catalog.store.AbstractDBStore.getTable(AbstractDBStore.java:1295)
        ... 35 more
        ```

        githubbot ASF GitHub Bot added a comment -

        Github user jinossy commented on the pull request:

        https://github.com/apache/tajo/pull/154#issuecomment-59482989

        @ykrips
        I'm sorry for late response. I left some comments

        githubbot ASF GitHub Bot added a comment -

        Github user ykrips commented on the pull request:

        https://github.com/apache/tajo/pull/154#issuecomment-59548104

        I'm sorry not to upload changes on this work. I habitually stashed my changes on my local branch, and I forgot to push my changes to git servers. I have recovered my changes and pushed to git repository, and will you review it again?

        githubbot ASF GitHub Bot added a comment -

        Github user jinossy commented on the pull request:

        https://github.com/apache/tajo/pull/154#issuecomment-59684426

        Thank you for your quick update.
        I ran unit test twice. first was successfully but second is failure
        Additionally, dropBaseTable() does not work. Maybe deletion table is incorrectly ordered.

        Thanks
        ```
        java.lang.IllegalArgumentException: createTable() requires a qualified table name, but it is "mynewcooltable".
        at org.apache.tajo.catalog.CatalogUtil.splitFQTableName(CatalogUtil.java:182)
        at org.apache.tajo.catalog.AbstractCatalogClient.dropTable(AbstractCatalogClient.java:365)
        at org.apache.tajo.catalog.TestCatalog.setUp(TestCatalog.java:117)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:47)
        at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:12)
        at org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:44)
        at org.junit.internal.runners.statements.RunBefores.evaluate(RunBefores.java:24)
        at org.junit.internal.runners.statements.RunAfters.evaluate(RunAfters.java:27)
        at org.junit.runners.ParentRunner.run(ParentRunner.java:309)
        at org.junit.runner.JUnitCore.run(JUnitCore.java:160)
        at com.intellij.junit4.JUnit4IdeaTestRunner.startRunnerWithArgs(JUnit4IdeaTestRunner.java:74)
        at com.intellij.rt.execution.junit.JUnitStarter.prepareStreamsAndStart(JUnitStarter.java:211)
        at com.intellij.rt.execution.junit.JUnitStarter.main(JUnitStarter.java:67)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
        at com.intellij.rt.execution.application.AppMain.main(AppMain.java:134)
        ```

        githubbot ASF GitHub Bot added a comment -

        Github user hyunsik commented on the pull request:

        https://github.com/apache/tajo/pull/154#issuecomment-59684830

        Hi @jinossy,

        Other stores will be the same to this oracle store. In the second test, TestCatalogServer will be failed except for Derby.

        In my opinion, it is a problem, but it is not related to this patch. It would be good if we solve the problem in another jira.

        I hope that my comment would be helpful to you.

        githubbot ASF GitHub Bot added a comment -

        Github user jinossy commented on the pull request:

        https://github.com/apache/tajo/pull/154#issuecomment-59685372

        @hyunsik
        You are right. we should fix in other jira.
        I verified all driver is implemented incorrectly.

        @ykrips
        Sorry for confusing you.
        Here is my +1.

        githubbot ASF GitHub Bot added a comment -

        Github user ykrips commented on the pull request:

        https://github.com/apache/tajo/pull/154#issuecomment-59688578

        Hi @jinossy,
        Thank you for reviewing this request.

        hyunsik Hyunsik Choi added a comment -

        committed the patch to master branch. Thank you for your contribution!

        githubbot ASF GitHub Bot added a comment -

        Github user asfgit closed the pull request at:

        https://github.com/apache/tajo/pull/154

        hudson Hudson added a comment -

        SUCCESS: Integrated in Tajo-master-build #415 (See https://builds.apache.org/job/Tajo-master-build/415/)
        TAJO-235: Support Oracle CatalogStore. (Jihun Kang via hyunsik) (hyunsik: rev 0563a6a26fd97a3e8cfa9c6ae99772436c58da76)

        • tajo-catalog/tajo-catalog-server/src/test/java/org/apache/tajo/catalog/TestCatalog.java
        • tajo-catalog/tajo-catalog-server/src/main/resources/schemas/oracle/stats.sql
        • tajo-catalog/tajo-catalog-server/src/main/resources/schemas/oracle/tables.sql
        • tajo-catalog/tajo-catalog-server/src/main/resources/schemas/oracle/columns.sql
        • CHANGES
        • tajo-catalog/tajo-catalog-server/src/main/resources/schemas/oracle/table_properties.sql
        • tajo-catalog/tajo-catalog-server/src/main/resources/schemas/oracle/partition_methods.sql
        • tajo-catalog/tajo-catalog-server/src/main/java/org/apache/tajo/catalog/store/OracleStore.java
        • tajo-catalog/tajo-catalog-server/src/main/resources/schemas/oracle/indexes.sql
        • tajo-catalog/tajo-catalog-server/src/main/resources/schemas/oracle/tablespaces.sql
        • tajo-catalog/tajo-catalog-server/src/main/resources/schemas/oracle/partitions.sql
        • tajo-catalog/tajo-catalog-server/src/main/resources/schemas/oracle/databases.sql
        hudson Hudson added a comment -

        SUCCESS: Integrated in Tajo-master-CODEGEN-build #57 (See https://builds.apache.org/job/Tajo-master-CODEGEN-build/57/)
        TAJO-235: Support Oracle CatalogStore. (Jihun Kang via hyunsik) (hyunsik: rev 0563a6a26fd97a3e8cfa9c6ae99772436c58da76)

        • tajo-catalog/tajo-catalog-server/src/main/resources/schemas/oracle/stats.sql
        • CHANGES
        • tajo-catalog/tajo-catalog-server/src/main/resources/schemas/oracle/tablespaces.sql
        • tajo-catalog/tajo-catalog-server/src/main/resources/schemas/oracle/tables.sql
        • tajo-catalog/tajo-catalog-server/src/main/resources/schemas/oracle/table_properties.sql
        • tajo-catalog/tajo-catalog-server/src/main/resources/schemas/oracle/indexes.sql
        • tajo-catalog/tajo-catalog-server/src/main/resources/schemas/oracle/partitions.sql
        • tajo-catalog/tajo-catalog-server/src/main/java/org/apache/tajo/catalog/store/OracleStore.java
        • tajo-catalog/tajo-catalog-server/src/test/java/org/apache/tajo/catalog/TestCatalog.java
        • tajo-catalog/tajo-catalog-server/src/main/resources/schemas/oracle/databases.sql
        • tajo-catalog/tajo-catalog-server/src/main/resources/schemas/oracle/columns.sql
        • tajo-catalog/tajo-catalog-server/src/main/resources/schemas/oracle/partition_methods.sql

          People

          • Assignee:
            ykrips Jihun Kang
            Reporter:
            jhkim Jinho Kim
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development