Uploaded image for project: 'Tajo'
  1. Tajo
  2. TAJO-1863

CTAS with union clause does not work properly

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Not A Problem
    • Affects Version/s: None
    • Fix Version/s: 0.11.0
    • Component/s: None
    • Labels:
      None

      Description

      You can reproduce as follows:

      default> create table test as select * from customer union select * from customer;
      Progress: 0%, response time: 1.268 sec
      Progress: 0%, response time: 1.27 sec
      Progress: 0%, response time: 1.673 sec
      Progress: 0%, response time: 2.476 sec
      Progress: 100%, response time: 3.361 sec
      (150000 rows, 3.361 sec, 23.1 MiB inserted)
      default> select count(*) from test;
      Progress: 100%, response time: 0.38 sec
      ?count
      -------------------------------
      150000
      (1 rows, 0.38 sec, 7 B selected)
      default> select count(*) from customer;
      Progress: 100%, response time: 0.263 sec
      ?count
      -------------------------------
      150000
      (1 rows, 0.263 sec, 7 B selected)
      

        Activity

        jihoonson Jihoon Son added a comment -

        Right. Sorry for my mistake.

        hyunsik Hyunsik Choi added a comment -

        The result seems to be correct because you executed UNION DISTINCT.


          People

          • Assignee:
            Unassigned
            Reporter:
            jihoonson Jihoon Son
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development