Uploaded image for project: 'Tajo'
  1. Tajo
  2. TAJO-1797

Workers cannot bind web server address when it starts

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Not A Problem
    • Affects Version/s: None
    • Fix Version/s: 0.11.0
    • Component/s: Worker
    • Labels:
      None
    • Environment:

      Mac OS X

      Description

      Here is the log.

      2015-08-22 16:14:34,378 WARN org.apache.tajo.webapp.HttpServer: listener.getLocalPort returned -1
      2015-08-22 16:14:34,378 INFO org.apache.tajo.webapp.HttpServer: Retrying listener.getLocalPort()
      2015-08-22 16:14:34,583 INFO org.apache.tajo.webapp.HttpServer: Retrying listener.getLocalPort()
      2015-08-22 16:14:34,789 INFO org.apache.tajo.webapp.HttpServer: Bouncing the listener
      2015-08-22 16:14:35,892 WARN org.apache.tajo.webapp.HttpServer: listener.getLocalPort returned -1
      2015-08-22 16:14:35,892 INFO org.apache.tajo.webapp.HttpServer: Retrying listener.getLocalPort()
      2015-08-22 16:14:36,095 INFO org.apache.tajo.webapp.HttpServer: Retrying listener.getLocalPort()
      2015-08-22 16:14:36,296 INFO org.apache.tajo.webapp.HttpServer: Bouncing the listener
      2015-08-22 16:14:36,441 ERROR org.apache.tajo.worker.TajoWorker: RECEIVED SIGNAL 15: SIGTERM
      2015-08-22 16:14:36,442 INFO org.apache.tajo.worker.TajoWorker: ============================================
      2015-08-22 16:14:36,442 INFO org.apache.tajo.worker.TajoWorker: TajoWorker received SIGINT Signal
      2015-08-22 16:14:36,442 INFO org.apache.tajo.worker.TajoWorker: ============================================
      2015-08-22 16:14:36,443 INFO org.apache.tajo.worker.TajoWorker: SHUTDOWN_MSG:
      /************************************************************
      SHUTDOWN_MSG: Shutting down TajoWorker at SonJihoonui-MacBook-Pro.local/218.38.137.8
      ************************************************************/
      2015-08-22 16:14:37,401 WARN org.apache.tajo.webapp.HttpServer: listener.getLocalPort returned -1
      2015-08-22 16:14:37,401 INFO org.apache.tajo.webapp.HttpServer: Retrying listener.getLocalPort()
      2015-08-22 16:14:37,607 INFO org.apache.tajo.webapp.HttpServer: Retrying listener.getLocalPort()
      2015-08-22 16:14:37,812 INFO org.apache.tajo.webapp.HttpServer: Bouncing the listener
      ...
      

      As you can see in the log, worker is not stopped even though it received the SIGTERM signal.

        Activity

        jihoonson Jihoon Son added a comment -

        This problem is caused by that Inet4Address.getLocalHost().getHostName() returns mac's local network name instead of just "localhost".
        The simple solution is enrolling mac's local network name as 127.0.0.1. You can find your mac's local network name at Sharing preferences. Please refer to https://support.apple.com/kb/PH18720?locale=en_US.


          People

          • Assignee:
            jihoonson Jihoon Son
            Reporter:
            jihoonson Jihoon Son
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development