Uploaded image for project: 'Tajo'
  1. Tajo
  2. TAJO-1676

Queries on information_schema.partitions table return invalid result

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: 0.11.0
    • Component/s: None
    • Labels:
      None

      Description

      See the title.
      You can reproduce as follows.

      default> create table partitioned_nation (n_name text, n_comment text) partition by column (n_nationkey int8, n_regionkey int8) ;
      OK
      default> insert into partitioned_nation select * from nation;
      Progress: 100%, response time: 0.811 sec
      (25 rows, 0.811 sec, 267 B inserted)
      default> \d partitioned_nation
      
      table name: default.partitioned_nation
      table uri: hdfs://localhost:7020/tajo/warehouse/default/partitioned_nation
      store type: CSV
      number of rows: 0
      volume: 0 B
      Options: 
      	'text.delimiter'='|'
      
      schema: 
      n_name	TEXT
      n_comment	TEXT
      
      Partitions: 
      type:COLUMN
      columns::n_nationkey (INT8), n_regionkey (INT8)
      
      information_schema> \dfs -ls hdfs://localhost:7020/tajo/warehouse/default/partitioned_nation/
      Found 5 items
      drwxr-xr-x   - jihoonson supergroup          0 2015-07-06 18:14 hdfs://localhost:7020/tajo/warehouse/default/partitioned_nation/n_nationkey=0
      drwxr-xr-x   - jihoonson supergroup          0 2015-07-06 18:14 hdfs://localhost:7020/tajo/warehouse/default/partitioned_nation/n_nationkey=1
      drwxr-xr-x   - jihoonson supergroup          0 2015-07-06 18:14 hdfs://localhost:7020/tajo/warehouse/default/partitioned_nation/n_nationkey=2
      drwxr-xr-x   - jihoonson supergroup          0 2015-07-06 18:14 hdfs://localhost:7020/tajo/warehouse/default/partitioned_nation/n_nationkey=3
      drwxr-xr-x   - jihoonson supergroup          0 2015-07-06 18:14 hdfs://localhost:7020/tajo/warehouse/default/partitioned_nation/n_nationkey=4
      
      information_schema> select * from partitions;
      partition_id,  tid,  partition_name,  path
      -------------------------------
      (0 rows, 0.008 sec, 0 B selected)
      

        Issue Links

          Activity

          blrunner Jaehwa Jung added a comment -

          Currently, I can't reproduce it because of TAJO-1346 issue.


            People

            • Assignee:
              blrunner Jaehwa Jung
              Reporter:
              jihoonson Jihoon Son
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development