Uploaded image for project: 'Tajo'
  1. Tajo
  2. TAJO-1530

Display warn message when the query kill button is clicked in WEB UI.

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: 0.10.0
    • Fix Version/s: 0.11.0
    • Component/s: None
    • Labels:
      None

      Description

      Currently If user click the 'kill query' button in WEB UI, the browser sends immediately the kill request to TajoMaster. I think this is very dangerous because user can click by mistake.
      Tajo WEB UI should display warn message when the query kill button is clicked.

        Activity

        githubbot ASF GitHub Bot added a comment -

        GitHub user dongjoon-hyun opened a pull request:

        https://github.com/apache/tajo/pull/525

        TAJO-1530: Display warn message when the query kill button is clicked in Web UI

        You can test clicking kill button confirmation during the following command.
        ```
        tsql -c 'create table t(a int)'
        tsql -c 'insert into t select 1'
        tsql -c 'select a from t union select sleep(10) from t'
        ```

        You can merge this pull request into a Git repository by running:

        $ git pull https://github.com/dongjoon-hyun/tajo TAJO-1530

        Alternatively you can review and apply these changes as the patch at:

        https://github.com/apache/tajo/pull/525.patch

        To close this pull request, make a commit to your master/trunk branch
        with (at least) the following in the commit message:

        This closes #525


        commit 226cd2e5da3c1f4bd710afe3b9c868d05c8c4100
        Author: Dongjoon Hyun <dongjoon@apache.org>
        Date: 2015-04-08T01:10:10Z

        TAJO-1530: Display warn message when the query kill button is clicked in WEB UI


        tajoqa Tajo QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12723805/TAJO-1530.Hyun.150408.0.patch.txt
        against master revision release-0.9.0-rc0-245-ga1cf248.

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. The applied patch does not increase the total number of javadoc warnings.

        +1 checkstyle. The patch generated 0 code style errors.

        -1 findbugs. The patch appears to introduce 17 new Findbugs (version 2.0.3) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed unit tests in tajo-core.

        Test results: https://builds.apache.org/job/PreCommit-TAJO-Build/725//testReport/
        Findbugs warnings: https://builds.apache.org/job/PreCommit-TAJO-Build/725//artifact/incubator-tajo/patchprocess/newPatchFindbugsWarningstajo-core.html
        Console output: https://builds.apache.org/job/PreCommit-TAJO-Build/725//console

        This message is automatically generated.

        githubbot ASF GitHub Bot added a comment -

        Github user dongjoon-hyun commented on the pull request:

        https://github.com/apache/tajo/pull/525#issuecomment-92145198

        Hi, @babokim . Could you review your issue? The change is just trivial Javascript code.

        githubbot ASF GitHub Bot added a comment -

        Github user babokim commented on the pull request:

        https://github.com/apache/tajo/pull/525#issuecomment-92780957

        This patch looks good to me. Here is my +1.
        The Travis CI failed but it may be caused by TAJO-1526. This issue is trivial and not related any test case. All tests passed on my laptop. So I'll commit soon.

        githubbot ASF GitHub Bot added a comment -

        Github user asfgit closed the pull request at:

        https://github.com/apache/tajo/pull/525

        hudson Hudson added a comment -

        FAILURE: Integrated in Tajo-master-CODEGEN-build #305 (See https://builds.apache.org/job/Tajo-master-CODEGEN-build/305/)
        TAJO-1530: Display warn message when the query kill button is clicked in WEB UI. (babokim: rev c42d4b3c5c5b6452a82a81fd51dc8e2f30e0816c)

        • CHANGES
        • tajo-core/src/main/resources/webapps/admin/query.jsp
        hudson Hudson added a comment -

        SUCCESS: Integrated in Tajo-master-build #667 (See https://builds.apache.org/job/Tajo-master-build/667/)
        TAJO-1530: Display warn message when the query kill button is clicked in WEB UI. (babokim: rev c42d4b3c5c5b6452a82a81fd51dc8e2f30e0816c)

        • tajo-core/src/main/resources/webapps/admin/query.jsp
        • CHANGES
        githubbot ASF GitHub Bot added a comment -

        Github user dongjoon-hyun commented on the pull request:

        https://github.com/apache/tajo/pull/525#issuecomment-93183910

        Thank you, @babokim !


          People

          • Assignee:
            dongjoon Dongjoon Hyun
            Reporter:
            hjkim Hyoungjun Kim
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development