Uploaded image for project: 'Tajo'
  1. Tajo
  2. TAJO-1440

Some tests fail in parallel test environment in TestKillQuery

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 0.10.0
    • Fix Version/s: 0.11.0, 0.10.1
    • Component/s: Unit Test
    • Labels:
      None

      Description

      Running following command, test process often fails.

      mvn clean install -Pparallel-test,hcatalog-0.12.0 -DLOG_LEVEL=ERROR -Dmaven.fork.count=2

      But it is not 100% failure rate.

      It looks like a concurrency problem.

      The reason why is :

      1. When INFO instead of ERROR for log level is used, it doesn't seem that it happens.
      2. Only it happens in parallel test.

      Usual failure spot is at TestKillQuery.

      1. TAJO-1440_2.patch
        6 kB
        Jongyoung Park
      2. TAJO-1440.log.bz2
        19 kB
        Jongyoung Park
      3. TAJO-1440.patch
        4 kB
        Jongyoung Park

        Issue Links

          Activity

          dongjoon Dongjoon Hyun added a comment -

          Thank you, Jongyoung Park. I was very curious about this.

          jihoonson Jihoon Son added a comment -

          Since this problem induces frequent test failures, I'll increase the issue priority to the blocker.

          dongjoon Dongjoon Hyun added a comment -

          +1

          jihoonson Jihoon Son added a comment -

          Dongjoon Hyun, the test failure which you shared (https://app.box.com/s/c33avo137b7201sa1jgwjxtaqd0cvzyf) was caused by a BindException at TestHAServiceHDFSImpl during TestHAServiceHDFSImpl. testAutoFailOver() test.
          However, I cannot reproduce it.
          I sometimes meet only the TestKillQuery test failure.
          Would you mind checking it again?

          dongjoon Dongjoon Hyun added a comment -

          Sure! I will test again on my desktop and report the result.

          dongjoon Dongjoon Hyun added a comment -

          At this time, I rebooted my labtop and ran the test 5 times with redirection stdin/stderr together for detail reports.
          However, they suceeded.
          ```
          mvn clean install -Pparallel-test,hcatalog-0.12.0 -DLOG_LEVEL=ERROR -Dmaven.fork.count=2 &> TAJO-1440.travis.log.ERROR.txt
          mvn clean install -Pparallel-test,hcatalog-0.12.0 -DLOG_LEVEL=ERROR -Dmaven.fork.count=2 &> TAJO-1440.travis.log2.ERROR.txt
          mvn clean install -Pparallel-test,hcatalog-0.12.0 -DLOG_LEVEL=ERROR -Dmaven.fork.count=2 &> TAJO-1440.travis.log3.ERROR.txt
          mvn clean install -Pparallel-test,hcatalog-0.12.0 -DLOG_LEVEL=ERROR -Dmaven.fork.count=2 &> TAJO-1440.travis.log4.ERROR.txt
          mvn clean install -Pparallel-test,hcatalog-0.12.0 -DLOG_LEVEL=ERROR -Dmaven.fork.count=2 &> TAJO-1440.travis.log5.ERROR.txt
          ```
          https://app.box.com/s/ycvfdinkg7tn469u7f9qsk9f9z1q7mv7
          https://app.box.com/s/rlsirzszvjn5mvnaqup2aeh9slj88lq2
          https://app.box.com/s/492256tt2x51j9wsvnvutva46sp56g2z
          https://app.box.com/s/xc780kytenaet9jtzbgg9nls1ugdzfh5
          https://app.box.com/s/fo3b6v49itiyeqliryetqm866dgoewhb

          Only, I've got the following message, but I think it's normal.
          ```
          $ grep AssertionError TAJO-1440*
          TAJO-1440.travis.log3.ERROR.txt:java.lang.AssertionError: expected:<QUERY_ERROR> but was:<QUERY_MASTER_LAUNCHED>
          TAJO-1440.travis.log4.ERROR.txt:Exception in thread "Thread-11014" java.lang.AssertionError: expected:<QUERY_ERROR> but was:<QUERY_MASTER_LAUNCHED>
          ```

          Jihoon Son, I will try more with redirecting stdin only again. (it's the same condition at the first time I met that error).

          jihoonson Jihoon Son added a comment -

          Ok. Thanks Dongjoon Hyun.

          dongjoon Dongjoon Hyun added a comment -

          To Jihoon Son and Jongyoung Park, after rebooting, I can not reproduce that error.

          mvn clean install -Pparallel-test,hcatalog-0.12.0 -DLOG_LEVEL=ERROR -Dmaven.fork.count=2 > TAJO-1440.travis.log6.ERROR.txt
          mvn clean install -Pparallel-test,hcatalog-0.12.0 -DLOG_LEVEL=ERROR -Dmaven.fork.count=2 > TAJO-1440.travis.log7.ERROR.txt
          mvn clean install -Pparallel-test,hcatalog-0.12.0 -DLOG_LEVEL=ERROR -Dmaven.fork.count=2 > TAJO-1440.travis.log8.ERROR.txt
          mvn clean install -Pparallel-test,hcatalog-0.12.0 -DLOG_LEVEL=ERROR -Dmaven.fork.count=2 > TAJO-1440.travis.log9.ERROR.txt
          mvn clean install -Pparallel-test,hcatalog-0.12.0 -DLOG_LEVEL=ERROR -Dmaven.fork.count=2 > TAJO-1440.travis.log10.ERROR.txt
          

          The results are all successful.
          https://app.box.com/s/qv845vtle466ie3zz6fn4lcd2d16wz4p
          https://app.box.com/s/k9akpw1h245w73db9zh7kakxw0ebkrza
          https://app.box.com/s/qdu77lqcwexbx9wzrw9tdf01yf4rhlnf
          https://app.box.com/s/gneixm5umubl1hn0xm0ri3c7juwbj53x
          https://app.box.com/s/w11vkajav48evhy8atdxdth9kuz6nx4m

          I'm very sorry for this. In daytime, I met that error everytime I built if I use ERROR level.
          By the way, I should change my branch into TAJO-1403 'SimpleQuery', so I stopped today's testing here.

          jihoonson Jihoon Son added a comment -

          No problem.
          The problem of TestKillQuery failure seems to be duplicated with TAJO-1138.
          Jongyoung Park, would you close this issue?

          eminency Jongyoung Park added a comment -

          Sure

          eminency Jongyoung Park added a comment -

          By a duplicate, this issue is closed.

          eminency Jongyoung Park added a comment -

          The log generated from my local test is attached.

          Because it seems the reason and log are different, this issue is reopened.

          githubbot ASF GitHub Bot added a comment -

          GitHub user eminency opened a pull request:

          https://github.com/apache/tajo/pull/451

          TAJO-1440: Some tests fail in parallel test environment in TestKillQuery

          Currently, state variable is exposed directly to outside.
          Thus, changing state operation is out of locking scope and consistency may be broken.

          Changing state should be protected by acquiring write lock.

          You can merge this pull request into a Git repository by running:

          $ git pull https://github.com/eminency/tajo TAJO-1440

          Alternatively you can review and apply these changes as the patch at:

          https://github.com/apache/tajo/pull/451.patch

          To close this pull request, make a commit to your master/trunk branch
          with (at least) the following in the commit message:

          This closes #451


          commit 0c0cb5b9092050de8403ba4b00636acba885b89d
          Author: Jongyoung Park <eminency@gmail.com>
          Date: 2015-03-23T02:14:03Z

          Changing state should be protected by lock acquiring

          commit 302ebf7a154c9f3830ab3480ae821127774475bf
          Author: Jongyoung Park <eminency@gmail.com>
          Date: 2015-03-23T02:20:15Z

          Debugging code is removed


          tajoqa Tajo QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12706431/TAJO-1440.patch
          against master revision release-0.9.0-rc0-213-g3aaff38.

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 1 new or modified test files.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. The applied patch does not increase the total number of javadoc warnings.

          +1 checkstyle. The patch generated 0 code style errors.

          -1 findbugs. The patch appears to introduce 2 new Findbugs (version 2.0.3) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in tajo-core.

          Test results: https://builds.apache.org/job/PreCommit-TAJO-Build/639//testReport/
          Findbugs warnings: https://builds.apache.org/job/PreCommit-TAJO-Build/639//artifact/incubator-tajo/patchprocess/newPatchFindbugsWarningstajo-core.html
          Console output: https://builds.apache.org/job/PreCommit-TAJO-Build/639//console

          This message is automatically generated.

          githubbot ASF GitHub Bot added a comment -

          Github user blrunner commented on the pull request:

          https://github.com/apache/tajo/pull/451#issuecomment-85529409

          Thanks for your contribution.
          I'll review the patch tomorrow.

          blrunner Jaehwa Jung added a comment -

          Could you rebase the patch against latest master branch?

          eminency Jongyoung Park added a comment -

          It's done.

          githubbot ASF GitHub Bot added a comment -

          Github user eminency closed the pull request at:

          https://github.com/apache/tajo/pull/451

          githubbot ASF GitHub Bot added a comment -

          Github user eminency closed the pull request at:

          https://github.com/apache/tajo/pull/471

          githubbot ASF GitHub Bot added a comment -

          GitHub user eminency opened a pull request:

          https://github.com/apache/tajo/pull/472

          TAJO-1440: Some tests fail in parallel test environment in TestKillQuery

          To trigger CI, I re-create.

          You can merge this pull request into a Git repository by running:

          $ git pull https://github.com/eminency/tajo TAJO-1440

          Alternatively you can review and apply these changes as the patch at:

          https://github.com/apache/tajo/pull/472.patch

          To close this pull request, make a commit to your master/trunk branch
          with (at least) the following in the commit message:

          This closes #472


          commit 0a334d2ad81d111fbc4c435275e9aa9ee9711497
          Author: Jongyoung Park <eminency@gmail.com>
          Date: 2015-03-27T06:58:25Z

          MockAsyncDispatcher added and synchronze by CountDownLatch


          githubbot ASF GitHub Bot added a comment -

          Github user jinossy commented on the pull request:

          https://github.com/apache/tajo/pull/472#issuecomment-86860482

          Thank you for your contribution
          I'm reviewing

          tajoqa Tajo QA added a comment -

          +1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12707708/TAJO-1440_2.patch
          against master revision release-0.9.0-rc0-222-gb1e174e.

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 1 new or modified test files.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. The applied patch does not increase the total number of javadoc warnings.

          +1 checkstyle. The patch generated 0 code style errors.

          +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in tajo-core.

          Test results: https://builds.apache.org/job/PreCommit-TAJO-Build/666//testReport/
          Console output: https://builds.apache.org/job/PreCommit-TAJO-Build/666//console

          This message is automatically generated.

          githubbot ASF GitHub Bot added a comment -

          Github user jinossy commented on the pull request:

          https://github.com/apache/tajo/pull/472#issuecomment-86863839

          +1
          The change looks straightforward.

          jhkim Jinho Kim added a comment -

          committed it

          githubbot ASF GitHub Bot added a comment -

          Github user jinossy commented on the pull request:

          https://github.com/apache/tajo/pull/472#issuecomment-86877954

          committed it, please close this PR

          hudson Hudson added a comment -

          ABORTED: Integrated in Tajo-master-CODEGEN-build #272 (See https://builds.apache.org/job/Tajo-master-CODEGEN-build/272/)
          TAJO-1440: Some tests fail in parallel test environment in TestKillQuery. (jhkim: rev 373d53cb93ac98fce07c0be0a626c08a86cf113e)

          • tajo-core/src/main/java/org/apache/tajo/querymaster/QueryMasterTask.java
          • tajo-core/src/main/java/org/apache/tajo/querymaster/Query.java
          • CHANGES
          • tajo-core/src/test/java/org/apache/tajo/querymaster/TestKillQuery.java
          hudson Hudson added a comment -

          ABORTED: Integrated in Tajo-master-build #634 (See https://builds.apache.org/job/Tajo-master-build/634/)
          TAJO-1440: Some tests fail in parallel test environment in TestKillQuery. (jhkim: rev 373d53cb93ac98fce07c0be0a626c08a86cf113e)

          • tajo-core/src/main/java/org/apache/tajo/querymaster/Query.java
          • tajo-core/src/main/java/org/apache/tajo/querymaster/QueryMasterTask.java
          • tajo-core/src/test/java/org/apache/tajo/querymaster/TestKillQuery.java
          • CHANGES
          githubbot ASF GitHub Bot added a comment -

          Github user eminency closed the pull request at:

          https://github.com/apache/tajo/pull/472


            People

            • Assignee:
              eminency Jongyoung Park
              Reporter:
              eminency Jongyoung Park
            • Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development