Uploaded image for project: 'Tajo'
  1. Tajo
  2. TAJO-1308

QueryInprogress can not release when query is QUERY_ERROR

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 0.10.0
    • Fix Version/s: 0.10.0
    • Component/s: QueryMaster, TajoMaster
    • Labels:
      None

      Description

      See the title.
      The main problem is caused by a missing QUERY_ERROR, It will be resource leak.

        Activity

        jhkim Jinho Kim added a comment - - edited

        Additionally, I’ve fix the error message issue when query is failed.

        ERROR: org.apache.tajo.rpc.TajoServiceException: Message missing required fields: resultSet
        java.sql.SQLException: org.apache.tajo.rpc.TajoServiceException: Message missing required fields: resultSet
                at org.apache.tajo.jdbc.TajoResultSetBase.next(TajoResultSetBase.java:786)
                at org.apache.tajo.cli.tsql.DefaultTajoCliOutputFormatter.printResult(DefaultTajoCliOutputFormatter.java:104)
                at org.apache.tajo.cli.tsql.TajoCli.localQueryCompleted(TajoCli.java:571)
                at org.apache.tajo.cli.tsql.TajoCli.executeQuery(TajoCli.java:545)
                at org.apache.tajo.cli.tsql.TajoCli.executeParsedResults(TajoCli.java:447)
                at org.apache.tajo.cli.tsql.TajoCli.runShell(TajoCli.java:419)
                at org.apache.tajo.cli.tsql.TajoCli.main(TajoCli.java:699)
        Caused by: java.io.IOException: org.apache.tajo.rpc.TajoServiceException: Message missing required fields: resultSet
                at org.apache.tajo.jdbc.FetchResultSet.nextTuple(FetchResultSet.java:81)
                at org.apache.tajo.jdbc.TajoResultSetBase.next(TajoResultSetBase.java:780)
                ... 6 more
        

        https://github.com/apache/tajo/pull/354

        githubbot ASF GitHub Bot added a comment -

        Github user asfgit closed the pull request at:

        https://github.com/apache/tajo/pull/354

        jhkim Jinho Kim added a comment -

        This issue got +1 from https://github.com/apache/tajo/pull/354, I've just committed it

        hudson Hudson added a comment -

        FAILURE: Integrated in Tajo-master-CODEGEN-build #200 (See https://builds.apache.org/job/Tajo-master-CODEGEN-build/200/)
        TAJO-1308: QueryInprogress can not release when query is QUERY_ERROR. (jinho) (jhkim: rev f80ec425dcdd8917d1408bd20f837de39e9f0c4b)

        • tajo-core/src/main/java/org/apache/tajo/master/QueryInProgress.java
        • tajo-core/src/main/java/org/apache/tajo/master/QueryManager.java
        • tajo-client/src/main/java/org/apache/tajo/client/QueryClientImpl.java
        • tajo-core/src/main/java/org/apache/tajo/master/TajoMasterClientService.java
        • CHANGES
        hudson Hudson added a comment -

        SUCCESS: Integrated in Tajo-master-build #561 (See https://builds.apache.org/job/Tajo-master-build/561/)
        TAJO-1308: QueryInprogress can not release when query is QUERY_ERROR. (jinho) (jhkim: rev f80ec425dcdd8917d1408bd20f837de39e9f0c4b)

        • tajo-core/src/main/java/org/apache/tajo/master/QueryManager.java
        • tajo-client/src/main/java/org/apache/tajo/client/QueryClientImpl.java
        • CHANGES
        • tajo-core/src/main/java/org/apache/tajo/master/QueryInProgress.java
        • tajo-core/src/main/java/org/apache/tajo/master/TajoMasterClientService.java

          People

          • Assignee:
            jhkim Jinho Kim
            Reporter:
            jhkim Jinho Kim
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development