Uploaded image for project: 'Tajo'
  1. Tajo
  2. TAJO-1279

Cleanup TajoAsyncDispatcher and interrupt stop events

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 0.8.0, 0.9.0
    • Fix Version/s: 0.10.0
    • Component/s: QueryMaster
    • Labels:
      None

      Description

      See the titile.
      TajoAsyncDispatcher is an implementation copied from yarn AsyncDispatcher for log message handling. but too many create the thread interrupted message.
      We should improve the stop event.

      2014-12-17 10:08:35,327 WARN: org.apache.tajo.master.TajoAsyncDispatcher (stop(115)) - Interrupted Exception while stopping
      2014-12-17 10:08:35,328 WARN: org.apache.tajo.master.TajoAsyncDispatcher (stop(115)) - Interrupted Exception while stopping
      2014-12-17 10:08:36,896 WARN: org.apache.tajo.master.TajoAsyncDispatcher (stop(115)) - Interrupted Exception while stopping
      2014-12-17 10:08:36,898 WARN: org.apache.tajo.master.TajoAsyncDispatcher (stop(115)) - Interrupted Exception while stopping
      2014-12-17 10:08:37,745 FATAL: org.apache.tajo.master.TajoAsyncDispatcher (dispatch(143)) - Error in dispatcher thread:QUERY_JOB_HEARTBEAT
      org.apache.hadoop.yarn.exceptions.YarnRuntimeException: java.lang.InterruptedException
      	at org.apache.tajo.master.TajoAsyncDispatcher$GenericEventHandler.handle(TajoAsyncDispatcher.java:204)
      	at org.apache.tajo.master.querymaster.QueryInProgress.heartbeat(QueryInProgress.java:290)
      	at org.apache.tajo.master.querymaster.QueryInProgress.access$000(QueryInProgress.java:53)
      	at org.apache.tajo.master.querymaster.QueryInProgress$QueryInProgressEventHandler.handle(QueryInProgress.java:196)
      	at org.apache.tajo.master.querymaster.QueryInProgress$QueryInProgressEventHandler.handle(QueryInProgress.java:192)
      	at org.apache.tajo.master.TajoAsyncDispatcher.dispatch(TajoAsyncDispatcher.java:137)
      	at org.apache.tajo.master.TajoAsyncDispatcher$1.run(TajoAsyncDispatcher.java:79)
      	at java.lang.Thread.run(Thread.java:701)
      Caused by: java.lang.InterruptedException
      	at java.util.concurrent.locks.AbstractQueuedSynchronizer.acquireInterruptibly(AbstractQueuedSynchronizer.java:1222)
      	at java.util.concurrent.locks.ReentrantLock.lockInterruptibly(ReentrantLock.java:340)
      	at java.util.concurrent.LinkedBlockingQueue.put(LinkedBlockingQueue.java:269)
      	at org.apache.tajo.master.TajoAsyncDispatcher$GenericEventHandler.handle(TajoAsyncDispatcher.java:199)
      	... 7 more
      2014-12-17 10:08:37,746 WARN: org.apache.tajo.master.TajoAsyncDispatcher (stop(115)) - Interrupted Exception while stopping
      

        Issue Links

          Activity

          githubbot ASF GitHub Bot added a comment -

          GitHub user jinossy opened a pull request:

          https://github.com/apache/tajo/pull/331

          TAJO-1279: Cleanup TajoAsyncDispatcher and interrupt stop events.

          You can merge this pull request into a Git repository by running:

          $ git pull https://github.com/jinossy/tajo TAJO-1279

          Alternatively you can review and apply these changes as the patch at:

          https://github.com/apache/tajo/pull/331.patch

          To close this pull request, make a commit to your master/trunk branch
          with (at least) the following in the commit message:

          This closes #331


          commit 747aa7bea774195a1500d805dccb31be7866fc4e
          Author: jhkim <jhkim@apache.org>
          Date: 2015-01-06T03:24:59Z

          TAJO-1279: Cleanup TajoAsyncDispatcher and interrupt stop events.


          tajoqa Tajo QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12690529/TAJO-1279.patch
          against master revision release-0.9.0-rc0-125-g54b2c64.

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 9 new or modified test files.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. The applied patch does not increase the total number of javadoc warnings.

          +1 checkstyle. The patch generated 0 code style errors.

          -1 findbugs. The patch appears to introduce 176 new Findbugs (version 2.0.3) warnings.

          -1 release audit. The applied patch generated 714 release audit warnings.

          +1 core tests. The patch passed unit tests in tajo-core.

          Test results: https://builds.apache.org/job/PreCommit-TAJO-Build/566//testReport/
          Release audit warnings: https://builds.apache.org/job/PreCommit-TAJO-Build/566//artifact/incubator-tajo/patchprocess/patchReleaseAuditProblems.txt
          Findbugs warnings: https://builds.apache.org/job/PreCommit-TAJO-Build/566//artifact/incubator-tajo/patchprocess/newPatchFindbugsWarningstajo-core.html
          Console output: https://builds.apache.org/job/PreCommit-TAJO-Build/566//console

          This message is automatically generated.

          githubbot ASF GitHub Bot added a comment -

          Github user jihoonson commented on the pull request:

          https://github.com/apache/tajo/pull/331#issuecomment-69015436

          I'm reviewing the patch.

          githubbot ASF GitHub Bot added a comment -

          Github user jihoonson commented on the pull request:

          https://github.com/apache/tajo/pull/331#issuecomment-69020962

          When I run 'mvn clean install', tests are frequently hanged with the following error.
          ```
          2015-01-07 21:58:07,530 INFO: org.apache.zookeeper.ClientCnxn (logStartConnect(975)) - Opening socket connection to server xxx.xxx.xxx.xxx/xxx.xxx.xxx.xxx:58986. Will not attempt to authenticate using SASL (unknown error)
          ```
          It seems that the zookeeper client cannot find the proper server address.
          Would you check this, please?

          githubbot ASF GitHub Bot added a comment -

          Github user jinossy commented on the pull request:

          https://github.com/apache/tajo/pull/331#issuecomment-69024228

          @jihoonson
          Thank you for the review!
          Your log looks like security information. Could you show the error log to me ?
          In my log, the connection was established successfully
          ```
          2015-01-07 22:31:46,996 INFO: org.apache.zookeeper.ZooKeeper (<init>(438)) - Initiating client connection, connectString=kimjh.localhost:61503 sessionTimeout=90000 watcher=catalogtracker-on-hconnection-0x3dbc3890, quorum=kimjh.localhost:61503, baseZNode=/hbase
          2015-01-07 22:31:46,998 INFO: org.apache.zookeeper.ClientCnxn (logStartConnect(975)) - Opening socket connection to server kimjh.localhost/192.168.101.41:61503. Will not attempt to authenticate using SASL (unknown error)
          2015-01-07 22:31:46,998 INFO: org.apache.zookeeper.ClientCnxn (primeConnection(852)) - Socket connection established to kimjh.localhost/192.168.101.41:61503, initiating session
          2015-01-07 22:31:46,998 INFO: org.apache.zookeeper.server.NIOServerCnxnFactory (run(197)) - Accepted socket connection from /192.168.101.41:65438
          ```

          githubbot ASF GitHub Bot added a comment -

          Github user hyunsik commented on the pull request:

          https://github.com/apache/tajo/pull/331#issuecomment-69127199

          +1
          The patch looks good to me. The unit tests are successfully passed. The patch seems to find unreleased resources.

          @jihoonson,

          Do you have more stuff that you need to review? If not, I want that this patch is committed to master as soon as possible due to recently frequent CI failures.

          githubbot ASF GitHub Bot added a comment -

          Github user jihoonson commented on the pull request:

          https://github.com/apache/tajo/pull/331#issuecomment-69137847

          @hyunsik thanks for your review. I also think that we should resolve this issue as soon as possible.

          All changes look good to me, too. The only thing I concern is, as commented above, the frequent hangs during unit tests. Whenever a zookeeper client fails to establish a connection, the test waits for 10 ~ 50 seconds. I think that it will significantly bother us.

          I cannot find this error in the current master branch. Thus, I suspect that an existing, but hidden error is exposed due to the changed HBase-related configurations. Maybe we can fix it in another issue.

          What do you think about it?

          githubbot ASF GitHub Bot added a comment -

          Github user jinossy commented on the pull request:

          https://github.com/apache/tajo/pull/331#issuecomment-69138246

          @jihoonson I will remove the HBase-related codes

          ```
          + conf.setInt(HConstants.HBASE_CLIENT_IPC_POOL_SIZE, 5);
          + conf.setInt(HConstants.REGION_SERVER_HANDLER_COUNT, 5);
          + conf.setInt(HConstants.REGION_SERVER_META_HANDLER_COUNT, 2);
          + conf.setInt(HConstants.MASTER_HANDLER_COUNT, 5);
          + conf.setInt("hbase.hconnection.threads.max", 5);
          + conf.setInt("hbase.hconnection.threads.core", 5);
          ```

          githubbot ASF GitHub Bot added a comment -

          Github user jihoonson commented on the pull request:

          https://github.com/apache/tajo/pull/331#issuecomment-69138719

          @jinossy thanks. We can commit the patch immediately.
          Anyway, we must resolve the zookeeper-related problem in another issue.

          githubbot ASF GitHub Bot added a comment -

          Github user jinossy commented on the pull request:

          https://github.com/apache/tajo/pull/331#issuecomment-69139443

          @jihoonson
          I don’t think so. Hbase was merge by TAJO-1233. and This patch is not related miniZookeeperCluster binding issue.
          Have your problem is in this patch ?

          githubbot ASF GitHub Bot added a comment -

          Github user jihoonson commented on the pull request:

          https://github.com/apache/tajo/pull/331#issuecomment-69142903

          @jinossy, I have tested the latest patch. It worked well.
          Here is my +1.
          Thanks!

          githubbot ASF GitHub Bot added a comment -

          Github user jinossy commented on the pull request:

          https://github.com/apache/tajo/pull/331#issuecomment-69143276

          @jihoonson Thanks!
          I'll commit it shortly.

          githubbot ASF GitHub Bot added a comment -

          Github user asfgit closed the pull request at:

          https://github.com/apache/tajo/pull/331

          jhkim Jinho Kim added a comment -

          committed it

          hudson Hudson added a comment -

          SUCCESS: Integrated in Tajo-master-build #539 (See https://builds.apache.org/job/Tajo-master-build/539/)
          TAJO-1279: Cleanup TajoAsyncDispatcher and interrupt stop events. (jinho) (jhkim: rev 6582d8656a3e8147984a86a9e62688b52ec1f681)

          • tajo-core/src/test/java/org/apache/tajo/cli/tsql/TestTajoCli.java
          • tajo-core/src/main/java/org/apache/tajo/master/TajoAsyncDispatcher.java
          • tajo-core/src/main/java/org/apache/tajo/master/event/QueryStopEvent.java
          • tajo-core/src/test/java/org/apache/tajo/scheduler/TestFifoScheduler.java
          • tajo-core/src/main/java/org/apache/tajo/master/querymaster/Stage.java
          • tajo-core/src/test/java/org/apache/tajo/worker/TestHistory.java
          • tajo-core/src/test/java/org/apache/tajo/jdbc/TestTajoJdbc.java
          • tajo-core/src/test/java/org/apache/tajo/TajoTestingCluster.java
          • tajo-core/src/test/java/org/apache/tajo/master/querymaster/TestKillQuery.java
          • tajo-core/src/main/java/org/apache/tajo/master/DefaultTaskScheduler.java
          • tajo-core/src/main/java/org/apache/tajo/master/querymaster/QueryInProgress.java
          • tajo-core/src/main/java/org/apache/tajo/master/querymaster/QueryJobEvent.java
          • tajo-core/src/main/java/org/apache/tajo/master/querymaster/QueryMasterTask.java
          • tajo-core/src/test/java/org/apache/tajo/TpchTestBase.java
          • tajo-core/src/main/java/org/apache/tajo/benchmark/TPCH.java
          • tajo-core/src/main/java/org/apache/tajo/master/querymaster/QueryJobManager.java
          • CHANGES
          • tajo-core/src/main/java/org/apache/tajo/master/querymaster/QueryMaster.java
          • tajo-core/src/test/java/org/apache/tajo/QueryTestCaseBase.java
          hudson Hudson added a comment -

          ABORTED: Integrated in Tajo-master-CODEGEN-build #178 (See https://builds.apache.org/job/Tajo-master-CODEGEN-build/178/)
          TAJO-1279: Cleanup TajoAsyncDispatcher and interrupt stop events. (jinho) (jhkim: rev 6582d8656a3e8147984a86a9e62688b52ec1f681)

          • tajo-core/src/test/java/org/apache/tajo/cli/tsql/TestTajoCli.java
          • tajo-core/src/test/java/org/apache/tajo/QueryTestCaseBase.java
          • tajo-core/src/test/java/org/apache/tajo/TajoTestingCluster.java
          • tajo-core/src/test/java/org/apache/tajo/scheduler/TestFifoScheduler.java
          • tajo-core/src/test/java/org/apache/tajo/TpchTestBase.java
          • tajo-core/src/main/java/org/apache/tajo/master/event/QueryStopEvent.java
          • tajo-core/src/main/java/org/apache/tajo/master/querymaster/QueryInProgress.java
          • tajo-core/src/main/java/org/apache/tajo/master/querymaster/QueryJobManager.java
          • tajo-core/src/test/java/org/apache/tajo/jdbc/TestTajoJdbc.java
          • tajo-core/src/main/java/org/apache/tajo/master/DefaultTaskScheduler.java
          • tajo-core/src/test/java/org/apache/tajo/worker/TestHistory.java
          • tajo-core/src/test/java/org/apache/tajo/master/querymaster/TestKillQuery.java
          • tajo-core/src/main/java/org/apache/tajo/master/querymaster/QueryJobEvent.java
          • tajo-core/src/main/java/org/apache/tajo/benchmark/TPCH.java
          • tajo-core/src/main/java/org/apache/tajo/master/querymaster/QueryMasterTask.java
          • tajo-core/src/main/java/org/apache/tajo/master/querymaster/QueryMaster.java
          • tajo-core/src/main/java/org/apache/tajo/master/querymaster/Stage.java
          • CHANGES
          • tajo-core/src/main/java/org/apache/tajo/master/TajoAsyncDispatcher.java

            People

            • Assignee:
              jhkim Jinho Kim
              Reporter:
              jhkim Jinho Kim
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development