Uploaded image for project: 'Tajo'
  1. Tajo
  2. TAJO-1254

Fix getProgress race conditions in Query

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.9.0
    • Fix Version/s: 0.10.0
    • Component/s: QueryMaster
    • Labels:
      None

      Description

      org.apache.tajo.engine.query.TestJoinQuery.testLeftOuterJoinWithEmptyTable4(TestJoinQuery.java:400)
      Caused by: org.apache.tajo.rpc.TajoServiceException: java.util.ConcurrentModificationException
      	at org.apache.tajo.rpc.BlockingRpcClient.makeTajoServiceException(BlockingRpcClient.java:171)
      	at org.apache.tajo.rpc.BlockingRpcClient.access$400(BlockingRpcClient.java:42)
      	at org.apache.tajo.rpc.BlockingRpcClient$ClientChannelUpstreamHandler.messageReceived(BlockingRpcClient.java:191)
      	at org.jboss.netty.channel.SimpleChannelUpstreamHandler.handleUpstream(SimpleChannelUpstreamHandler.java:70)
      	at org.jboss.netty.channel.DefaultChannelPipeline.sendUpstream(DefaultChannelPipeline.java:564)
      	at org.jboss.netty.channel.DefaultChannelPipeline$DefaultChannelHandlerContext.sendUpstream(DefaultChannelPipeline.java:791)
      	at org.jboss.netty.channel.Channels.fireMessageReceived(Channels.java:296)
      	at org.jboss.netty.handler.codec.oneone.OneToOneDecoder.handleUpstream(OneToOneDecoder.java:70)
      	at org.jboss.netty.channel.DefaultChannelPipeline.sendUpstream(DefaultChannelPipeline.java:564)
      	at org.jboss.netty.channel.DefaultChannelPipeline$DefaultChannelHandlerContext.sendUpstream(DefaultChannelPipeline.java:791)
      	at org.jboss.netty.channel.Channels.fireMessageReceived(Channels.java:296)
      	at org.jboss.netty.handler.codec.frame.FrameDecoder.unfoldAndFireMessageReceived(FrameDecoder.java:462)
      	at org.jboss.netty.handler.codec.frame.FrameDecoder.callDecode(FrameDecoder.java:443)
      	at org.jboss.netty.handler.codec.frame.FrameDecoder.messageReceived(FrameDecoder.java:310)
      	at org.jboss.netty.channel.SimpleChannelUpstreamHandler.handleUpstream(SimpleChannelUpstreamHandler.java:70)
      	at org.jboss.netty.channel.DefaultChannelPipeline.sendUpstream(DefaultChannelPipeline.java:564)
      	at org.jboss.netty.channel.DefaultChannelPipeline.sendUpstream(DefaultChannelPipeline.java:559)
      	at org.jboss.netty.channel.Channels.fireMessageReceived(Channels.java:268)
      	at org.jboss.netty.channel.Channels.fireMessageReceived(Channels.java:255)
      	at org.jboss.netty.channel.socket.nio.NioWorker.read(NioWorker.java:88)
      	at org.jboss.netty.channel.socket.nio.AbstractNioWorker.process(AbstractNioWorker.java:109)
      	at org.jboss.netty.channel.socket.nio.AbstractNioSelector.run(AbstractNioSelector.java:312)
      	at org.jboss.netty.channel.socket.nio.AbstractNioWorker.run(AbstractNioWorker.java:90)
      	at org.jboss.netty.channel.socket.nio.NioWorker.run(NioWorker.java:178)
      	at org.jboss.netty.util.ThreadRenamingRunnable.run(ThreadRenamingRunnable.java:108)
      	at org.jboss.netty.util.internal.DeadLockProofWorker$1.run(DeadLockProofWorker.java:42)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1146)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      	at java.lang.Thread.run(Thread.java:701)
      Caused by: com.google.protobuf.ServiceException: java.util.ConcurrentModificationException
      	at java.util.HashMap$HashIterator.nextEntry(HashMap.java:810)
      	at java.util.HashMap$ValueIterator.next(HashMap.java:839)
      	at java.util.AbstractCollection.toArray(AbstractCollection.java:141)
      	at java.util.ArrayList.addAll(ArrayList.java:497)
      	at org.apache.tajo.master.querymaster.Query.getProgress(Query.java:242)
      

        Activity

        githubbot ASF GitHub Bot added a comment -

        GitHub user jinossy opened a pull request:

        https://github.com/apache/tajo/pull/304

        TAJO-1254: Fix getProgress race conditions in Query

        You can merge this pull request into a Git repository by running:

        $ git pull https://github.com/jinossy/tajo TAJO-1254

        Alternatively you can review and apply these changes as the patch at:

        https://github.com/apache/tajo/pull/304.patch

        To close this pull request, make a commit to your master/trunk branch
        with (at least) the following in the commit message:

        This closes #304


        commit 4da7e5b399cc2bf95cbc6b5ec4b092bde06cf663
        Author: jhkim <jhkim@apache.org>
        Date: 2014-12-17T09:42:51Z

        TAJO-1254: Fix getProgress race conditions in Query


        githubbot ASF GitHub Bot added a comment -

        Github user hyunsik commented on the pull request:

        https://github.com/apache/tajo/pull/304#issuecomment-67314913

        +1

        githubbot ASF GitHub Bot added a comment -

        Github user asfgit closed the pull request at:

        https://github.com/apache/tajo/pull/304

        jhkim Jinho Kim added a comment -

        committed it.

        hudson Hudson added a comment -

        FAILURE: Integrated in Tajo-master-CODEGEN-build #150 (See https://builds.apache.org/job/Tajo-master-CODEGEN-build/150/)
        TAJO-1254: Fix getProgress race conditions in Query. (jinho) (jhkim: rev ff57c77ea6ea790a0689b59272600325e5b73345)

        • CHANGES
        • tajo-core/src/main/java/org/apache/tajo/master/querymaster/Query.java
        hudson Hudson added a comment -

        SUCCESS: Integrated in Tajo-master-build #509 (See https://builds.apache.org/job/Tajo-master-build/509/)
        TAJO-1254: Fix getProgress race conditions in Query. (jinho) (jhkim: rev ff57c77ea6ea790a0689b59272600325e5b73345)

        • tajo-core/src/main/java/org/apache/tajo/master/querymaster/Query.java
        • CHANGES

          People

          • Assignee:
            jhkim Jinho Kim
            Reporter:
            jhkim Jinho Kim
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development