Uploaded image for project: 'Tajo'
  1. Tajo
  2. TAJO-1250

RawFileAppender occasionally causes BufferOverflowException

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.8.0, 0.9.0
    • Fix Version/s: 0.10.0
    • Component/s: Data Shuffle, Storage
    • Labels:
      None

      Description

      The main problem is the maximum bytes size of variant int64.
      if a value is long.max, varint64 length is 10 bytes .

      • Variant int32 : 1~5 bytes
      • Variant int64 : 1~10 bytes
      2014-12-15 13:25:47,908 ERROR org.apache.tajo.engine.planner.physical.HashShuffleFileWriteExec:
      java.nio.BufferOverflowException
              at java.nio.Buffer.nextPutIndex(Buffer.java:513)
              at java.nio.DirectByteBuffer.put(DirectByteBuffer.java:291)
              at org.apache.tajo.storage.RawFile$RawFileAppender.writeRawVarint64(RawFile.java:604)
              at org.apache.tajo.storage.RawFile$RawFileAppender.addTuple(RawFile.java:659)
              at org.apache.tajo.storage.HashShuffleAppender.addTuples(HashShuffleAppender.java:92)
              at org.apache.tajo.engine.planner.physical.HashShuffleFileWriteExec.next(HashShuffleFileWriteExec.java:137)
              at org.apache.tajo.worker.Task.run(Task.java:407)
              at org.apache.tajo.worker.TaskRunner$1.run(TaskRunner.java:276)
              at java.lang.Thread.run(Thread.java:745)
      2014-12-15 13:25:47,910 ERROR org.apache.tajo.worker.Task: java.nio.BufferOverflowException
      java.io.IOException: java.nio.BufferOverflowException
              at org.apache.tajo.engine.planner.physical.HashShuffleFileWriteExec.next(HashShuffleFileWriteExec.java:152)
              at org.apache.tajo.worker.Task.run(Task.java:407)
              at org.apache.tajo.worker.TaskRunner$1.run(TaskRunner.java:276)
              at java.lang.Thread.run(Thread.java:745)
      Caused by: java.nio.BufferOverflowException
              at java.nio.Buffer.nextPutIndex(Buffer.java:513)
              at java.nio.DirectByteBuffer.put(DirectByteBuffer.java:291)
              at org.apache.tajo.storage.RawFile$RawFileAppender.writeRawVarint64(RawFile.java:604)
              at org.apache.tajo.storage.RawFile$RawFileAppender.addTuple(RawFile.java:659)
              at org.apache.tajo.storage.HashShuffleAppender.addTuples(HashShuffleAppender.java:92)
              at org.apache.tajo.engine.planner.physical.HashShuffleFileWriteExec.next(HashShuffleFileWriteExec.java:137)
      

        Activity

        githubbot ASF GitHub Bot added a comment -

        GitHub user jinossy opened a pull request:

        https://github.com/apache/tajo/pull/303

        TAJO-1250: RawFileAppender occasionally causes BufferOverflowException.

        You can merge this pull request into a Git repository by running:

        $ git pull https://github.com/jinossy/tajo TAJO-1250

        Alternatively you can review and apply these changes as the patch at:

        https://github.com/apache/tajo/pull/303.patch

        To close this pull request, make a commit to your master/trunk branch
        with (at least) the following in the commit message:

        This closes #303


        commit bddf997031a6daf666fb3f491d8b64e10ef1d138
        Author: jhkim <jhkim@apache.org>
        Date: 2014-12-16T05:54:21Z

        TAJO-1250: RawFileAppender occasionally causes BufferOverflowException.


        githubbot ASF GitHub Bot added a comment -

        Github user jihoonson commented on a diff in the pull request:

        https://github.com/apache/tajo/pull/303#discussion_r21949532

        — Diff: tajo-common/src/main/java/org/apache/tajo/conf/TajoConf.java —
        @@ -272,6 +272,10 @@ public static int setDateOrder(int dateOrder) {
        // Geo IP
        GEOIP_DATA("tajo.function.geoip-database-location", ""),

        + // Storage IO BUFFER
        + STORAGE_IO_WRITE_BUFFER_SIZE("tajo.io.write.buffer.size", 128 * 1024),
        + STORAGE_IO_READ_BUFFER_SIZE("tajo.io.read.buffer.size", 128 * 1024),
        — End diff –

        They seem buffer sizes for HDFS.
        I think that we will support various types of storages.
        In addition, it would be more intuititive if it represents the size unit such as KB.
        So, how about change the property name such as tajo.hdfs.write.buffer.size.KB?

        githubbot ASF GitHub Bot added a comment -

        Github user hyunsik commented on a diff in the pull request:

        https://github.com/apache/tajo/pull/303#discussion_r21949903

        — Diff: tajo-common/src/main/java/org/apache/tajo/conf/TajoConf.java —
        @@ -272,6 +272,10 @@ public static int setDateOrder(int dateOrder) {
        // Geo IP
        GEOIP_DATA("tajo.function.geoip-database-location", ""),

        + // Storage IO BUFFER
        + STORAGE_IO_WRITE_BUFFER_SIZE("tajo.io.write.buffer.size", 128 * 1024),
        + STORAGE_IO_READ_BUFFER_SIZE("tajo.io.read.buffer.size", 128 * 1024),
        — End diff –

        His change occurs in mainly RawFile for local file system. So, we need to use another word instead of HDFS.

        githubbot ASF GitHub Bot added a comment -

        Github user jinossy commented on a diff in the pull request:

        https://github.com/apache/tajo/pull/303#discussion_r21949956

        — Diff: tajo-common/src/main/java/org/apache/tajo/conf/TajoConf.java —
        @@ -272,6 +272,10 @@ public static int setDateOrder(int dateOrder) {
        // Geo IP
        GEOIP_DATA("tajo.function.geoip-database-location", ""),

        + // Storage IO BUFFER
        + STORAGE_IO_WRITE_BUFFER_SIZE("tajo.io.write.buffer.size", 128 * 1024),
        + STORAGE_IO_READ_BUFFER_SIZE("tajo.io.read.buffer.size", 128 * 1024),
        — End diff –

        Thank you for the review.
        HDFS buffer property is io.file.buffer.size. and RawFile is not HDFS.
        So, tajo.io.write.buffer.bytes is looks good to me. Any idea?

        githubbot ASF GitHub Bot added a comment -

        Github user hyunsik commented on a diff in the pull request:

        https://github.com/apache/tajo/pull/303#discussion_r21950158

        — Diff: tajo-common/src/main/java/org/apache/tajo/conf/TajoConf.java —
        @@ -272,6 +272,10 @@ public static int setDateOrder(int dateOrder) {
        // Geo IP
        GEOIP_DATA("tajo.function.geoip-database-location", ""),

        + // Storage IO BUFFER
        + STORAGE_IO_WRITE_BUFFER_SIZE("tajo.io.write.buffer.size", 128 * 1024),
        + STORAGE_IO_READ_BUFFER_SIZE("tajo.io.read.buffer.size", 128 * 1024),
        — End diff –

        BTW, I also have the same concern about the config key name. The properties may vary in file formats.

        So, I propose using ```storage-default.xml``` and ```tajo.storage.[storetype].io.read-buffer.bytes``` which can be specified according to file formats.

        Our config naming convention includes some unit like ```bytes``` or ```mb``` because it reduces misuse of values. So, I'd like to suggest ```io.read-buffer.bytes``` or ```io.write-buffer.bytes``` for table properties.

        githubbot ASF GitHub Bot added a comment -

        Github user hyunsik commented on a diff in the pull request:

        https://github.com/apache/tajo/pull/303#discussion_r21950196

        — Diff: tajo-common/src/main/java/org/apache/tajo/conf/TajoConf.java —
        @@ -272,6 +272,10 @@ public static int setDateOrder(int dateOrder) {
        // Geo IP
        GEOIP_DATA("tajo.function.geoip-database-location", ""),

        + // Storage IO BUFFER
        + STORAGE_IO_WRITE_BUFFER_SIZE("tajo.io.write.buffer.size", 128 * 1024),
        + STORAGE_IO_READ_BUFFER_SIZE("tajo.io.read.buffer.size", 128 * 1024),
        — End diff –

        Also, we could use various properties even specified for each file if we use the prefix ```tajo.storage.[storetype]```.

        githubbot ASF GitHub Bot added a comment -

        Github user hyunsik commented on the pull request:

        https://github.com/apache/tajo/pull/303#issuecomment-67271729

        Except for issues about config key, the patch looks good to me.

        githubbot ASF GitHub Bot added a comment -

        Github user jinossy commented on a diff in the pull request:

        https://github.com/apache/tajo/pull/303#discussion_r21950515

        — Diff: tajo-common/src/main/java/org/apache/tajo/conf/TajoConf.java —
        @@ -272,6 +272,10 @@ public static int setDateOrder(int dateOrder) {
        // Geo IP
        GEOIP_DATA("tajo.function.geoip-database-location", ""),

        + // Storage IO BUFFER
        + STORAGE_IO_WRITE_BUFFER_SIZE("tajo.io.write.buffer.size", 128 * 1024),
        + STORAGE_IO_READ_BUFFER_SIZE("tajo.io.read.buffer.size", 128 * 1024),
        — End diff –

        @hyunsik Good idea!

        @jihoonson If you agree, I will update the patch

        githubbot ASF GitHub Bot added a comment -

        Github user jihoonson commented on a diff in the pull request:

        https://github.com/apache/tajo/pull/303#discussion_r21950805

        — Diff: tajo-common/src/main/java/org/apache/tajo/conf/TajoConf.java —
        @@ -272,6 +272,10 @@ public static int setDateOrder(int dateOrder) {
        // Geo IP
        GEOIP_DATA("tajo.function.geoip-database-location", ""),

        + // Storage IO BUFFER
        + STORAGE_IO_WRITE_BUFFER_SIZE("tajo.io.write.buffer.size", 128 * 1024),
        + STORAGE_IO_READ_BUFFER_SIZE("tajo.io.read.buffer.size", 128 * 1024),
        — End diff –

        @jinho, @hyunsik you are right.
        I confused with RowFile.
        Thanks for your comment.
        Herr is +1.
        Ship it!

        githubbot ASF GitHub Bot added a comment -

        Github user jinossy commented on the pull request:

        https://github.com/apache/tajo/pull/303#issuecomment-67297042

        I've updated config key

        githubbot ASF GitHub Bot added a comment -

        Github user hyunsik commented on a diff in the pull request:

        https://github.com/apache/tajo/pull/303#discussion_r22088859

        — Diff: tajo-storage/tajo-storage-hdfs/src/main/java/org/apache/tajo/storage/text/DelimitedLineReader.java —
        @@ -60,12 +60,18 @@
        private AtomicInteger lineReadBytes = new AtomicInteger();
        private FileFragment fragment;
        private Configuration conf;
        + private int bufferSize;

        public DelimitedLineReader(Configuration conf, final FileFragment fragment) throws IOException {
        + this(conf, fragment, 128 * StorageUnit.KB);
        — End diff –

        How about using some constants for default block size?

        githubbot ASF GitHub Bot added a comment -

        Github user hyunsik commented on a diff in the pull request:

        https://github.com/apache/tajo/pull/303#discussion_r22088891

        — Diff: tajo-storage/tajo-storage-hdfs/src/main/java/org/apache/tajo/storage/text/DelimitedTextFile.java —
        @@ -165,8 +167,9 @@ public void init() throws IOException {
        serializer = getLineSerde().createSerializer(schema, meta);
        serializer.init();

        + bufferSize = conf.getInt(WRITE_BUFFER_SIZE, 128 * StorageUnit.KB);
        — End diff –

        How about using some constants for default buffer size? I know that in most cases default values is in storage-default.xml. Nevertheless, constants would be better.

        githubbot ASF GitHub Bot added a comment -

        Github user hyunsik commented on the pull request:

        https://github.com/apache/tajo/pull/303#issuecomment-67595871

        +1

        The patch looks good to me. I just leave some trivial suggestion. Please reflect the comments if you agree with my suggestion.

        githubbot ASF GitHub Bot added a comment -

        Github user jinossy commented on the pull request:

        https://github.com/apache/tajo/pull/303#issuecomment-67804313

        OK, I will do that

        githubbot ASF GitHub Bot added a comment -

        Github user asfgit closed the pull request at:

        https://github.com/apache/tajo/pull/303

        jhkim Jinho Kim added a comment -

        committed it.
        Thank you for the review!

        hudson Hudson added a comment -

        FAILURE: Integrated in Tajo-master-CODEGEN-build #156 (See https://builds.apache.org/job/Tajo-master-CODEGEN-build/156/)
        TAJO-1250: RawFileAppender occasionally causes BufferOverflowException. (jinho) (jhkim: rev cf66a390060c79ba757097886703e30f93d31401)

        • tajo-storage/tajo-storage-hdfs/src/main/java/org/apache/tajo/storage/text/DelimitedTextFile.java
        • tajo-storage/tajo-storage-common/src/main/java/org/apache/tajo/storage/StorageManager.java
        • tajo-storage/tajo-storage-hdfs/src/test/resources/storage-default.xml
        • tajo-storage/tajo-storage-hdfs/src/main/java/org/apache/tajo/storage/RawFile.java
        • tajo-storage/tajo-storage-common/src/main/resources/storage-default.xml
        • tajo-storage/tajo-storage-common/src/test/resources/storage-default.xml
        • tajo-storage/tajo-storage-hdfs/src/test/java/org/apache/tajo/storage/TestStorages.java
        • tajo-storage/tajo-storage-hdfs/src/main/java/org/apache/tajo/storage/text/DelimitedLineReader.java
        • CHANGES
        hudson Hudson added a comment -

        SUCCESS: Integrated in Tajo-master-build #516 (See https://builds.apache.org/job/Tajo-master-build/516/)
        TAJO-1250: RawFileAppender occasionally causes BufferOverflowException. (jinho) (jhkim: rev cf66a390060c79ba757097886703e30f93d31401)

        • CHANGES
        • tajo-storage/tajo-storage-hdfs/src/main/java/org/apache/tajo/storage/RawFile.java
        • tajo-storage/tajo-storage-hdfs/src/main/java/org/apache/tajo/storage/text/DelimitedLineReader.java
        • tajo-storage/tajo-storage-common/src/test/resources/storage-default.xml
        • tajo-storage/tajo-storage-common/src/main/resources/storage-default.xml
        • tajo-storage/tajo-storage-hdfs/src/test/resources/storage-default.xml
        • tajo-storage/tajo-storage-hdfs/src/main/java/org/apache/tajo/storage/text/DelimitedTextFile.java
        • tajo-storage/tajo-storage-hdfs/src/test/java/org/apache/tajo/storage/TestStorages.java
        • tajo-storage/tajo-storage-common/src/main/java/org/apache/tajo/storage/StorageManager.java

          People

          • Assignee:
            jhkim Jinho Kim
            Reporter:
            jhkim Jinho Kim
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development