Uploaded image for project: 'Tajo'
  1. Tajo
  2. TAJO-1177

Reduce the use of Sun proprietary API

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.10.0
    • Component/s: None
    • Labels:
      None

      Description

      Sometimes JVM developers tend to change their internal method signatures or implementations for performance issues or design issues when upgrading version of JVM. So if java class library provides public api for its implementation, I think that using public api might be a good choice to avoid compatibility issues.

        Activity

        githubbot ASF GitHub Bot added a comment -

        GitHub user ykrips opened a pull request:

        https://github.com/apache/tajo/pull/243

        TAJO-1177: Reduce the use of Sun proprietary API

        It has been passed test cases using JDK 1.6.0_45.

        You can merge this pull request into a Git repository by running:

        $ git pull https://github.com/ykrips/tajo TAJO-1177

        Alternatively you can review and apply these changes as the patch at:

        https://github.com/apache/tajo/pull/243.patch

        To close this pull request, make a commit to your master/trunk branch
        with (at least) the following in the commit message:

        This closes #243


        commit e7a5f8a39649cadf7acc6a29e388e130dcd2d2bc
        Author: Jihun Kang <ykrips@gmail.com>
        Date: 2014-11-14T14:50:35Z

        TAJO-1177: Reduce the use of Sun proprietary API


        githubbot ASF GitHub Bot added a comment -

        Github user hyunsik commented on the pull request:

        https://github.com/apache/tajo/pull/243#issuecomment-63291935

        +1

        The patch looks good to me. It's nice work.

        TravisCI shows the compilation error. I may be caused by the log size limit. I fixed the problem in #245. I manually verified 'mvn clean install'. I passed all unit tests.

        hyunsik Hyunsik Choi added a comment -

        I just committed the patch to master branch.

        hudson Hudson added a comment -

        SUCCESS: Integrated in Tajo-master-build #452 (See https://builds.apache.org/job/Tajo-master-build/452/)
        TAJO-1177: Reduce the use of Sun proprietary API. (Jihun Kang via hyunsik) (hyunsik: rev a0625a620bba9781c51f2ee0f47ec0aad1c36767)

        • tajo-storage/src/main/java/org/apache/tajo/tuple/offheap/HeapTuple.java
        • tajo-common/src/main/java/org/apache/tajo/util/UnsafeUtil.java
        • tajo-storage/src/main/java/org/apache/tajo/tuple/offheap/UnSafeTuple.java
        • tajo-common/src/main/java/org/apache/tajo/datum/TextDatum.java
        • CHANGES
        • tajo-common/src/main/java/org/apache/tajo/util/StringUtils.java
        • tajo-common/src/test/java/org/apache/tajo/datum/TestTextDatum.java
        • tajo-common/src/test/java/org/apache/tajo/util/TestStringUtil.java
        • tajo-core/src/test/java/org/apache/tajo/client/TestTajoClient.java
        • tajo-common/src/main/java/org/apache/tajo/util/KeyValueSet.java
        hudson Hudson added a comment -

        FAILURE: Integrated in Tajo-master-CODEGEN-build #94 (See https://builds.apache.org/job/Tajo-master-CODEGEN-build/94/)
        TAJO-1177: Reduce the use of Sun proprietary API. (Jihun Kang via hyunsik) (hyunsik: rev a0625a620bba9781c51f2ee0f47ec0aad1c36767)

        • tajo-storage/src/main/java/org/apache/tajo/tuple/offheap/UnSafeTuple.java
        • tajo-storage/src/main/java/org/apache/tajo/tuple/offheap/HeapTuple.java
        • tajo-common/src/main/java/org/apache/tajo/util/UnsafeUtil.java
        • CHANGES
        • tajo-core/src/test/java/org/apache/tajo/client/TestTajoClient.java
        • tajo-common/src/main/java/org/apache/tajo/datum/TextDatum.java
        • tajo-common/src/test/java/org/apache/tajo/util/TestStringUtil.java
        • tajo-common/src/main/java/org/apache/tajo/util/StringUtils.java
        • tajo-common/src/test/java/org/apache/tajo/datum/TestTextDatum.java
        • tajo-common/src/main/java/org/apache/tajo/util/KeyValueSet.java
        githubbot ASF GitHub Bot added a comment -

        Github user asfgit closed the pull request at:

        https://github.com/apache/tajo/pull/243


          People

          • Assignee:
            ykrips Jihun Kang
            Reporter:
            ykrips Jihun Kang
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development