Uploaded image for project: 'Tajo'
  1. Tajo
  2. TAJO-1176

Implements queryable virtual tables for catalog information

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.10.0
    • Component/s: None
    • Labels:
      None

      Description

      I would like to propose queryable interfaces for catalog information. And these information may contain tables, columns, any other information on tajo catalog.
      Currently, TajoCli offers some meta commands for retrieving table list, however queryable virtual tables can provide a handy way to tajo users.

        Issue Links

          Activity

          hyunsik Hyunsik Choi added a comment -

          +1 for this issue. It is really necessary work.

          githubbot ASF GitHub Bot added a comment -

          GitHub user ykrips opened a pull request:

          https://github.com/apache/tajo/pull/273

          TAJO-1176: Implements queryable virtual tables for catalog information

          You can merge this pull request into a Git repository by running:

          $ git pull https://github.com/ykrips/tajo TAJO-1176

          Alternatively you can review and apply these changes as the patch at:

          https://github.com/apache/tajo/pull/273.patch

          To close this pull request, make a commit to your master/trunk branch
          with (at least) the following in the commit message:

          This closes #273


          commit e878d414c4a722427e8fb8c9068371250fd3092f
          Author: Jihun Kang <ykrips@gmail.com>
          Date: 2014-11-29T10:54:19Z

          TAJO-1176: Implements queryable virtual tables for catalog information

          commit aa63c22339d9db28e94ee6cb6cdee1f602b736d5
          Author: Jihun Kang <ykrips@gmail.com>
          Date: 2014-11-29T10:56:48Z

          TAJO-1176: Implements queryable virtual tables for catalog information


          githubbot ASF GitHub Bot added a comment -

          Github user ykrips closed the pull request at:

          https://github.com/apache/tajo/pull/273

          githubbot ASF GitHub Bot added a comment -

          Github user ykrips commented on the pull request:

          https://github.com/apache/tajo/pull/273#issuecomment-65008049

          When I merged upstream/master branch, I did forget to run entire test cases for this patch. I'm sorry, and I will re-open again for this issue.

          githubbot ASF GitHub Bot added a comment -

          Github user hyunsik commented on the pull request:

          https://github.com/apache/tajo/pull/273#issuecomment-65010713

          No problem

          githubbot ASF GitHub Bot added a comment -

          GitHub user ykrips reopened a pull request:

          https://github.com/apache/tajo/pull/273

          TAJO-1176: Implements queryable virtual tables for catalog information

          You can merge this pull request into a Git repository by running:

          $ git pull https://github.com/ykrips/tajo TAJO-1176

          Alternatively you can review and apply these changes as the patch at:

          https://github.com/apache/tajo/pull/273.patch

          To close this pull request, make a commit to your master/trunk branch
          with (at least) the following in the commit message:

          This closes #273


          commit e878d414c4a722427e8fb8c9068371250fd3092f
          Author: Jihun Kang <ykrips@gmail.com>
          Date: 2014-11-29T10:54:19Z

          TAJO-1176: Implements queryable virtual tables for catalog information

          commit aa63c22339d9db28e94ee6cb6cdee1f602b736d5
          Author: Jihun Kang <ykrips@gmail.com>
          Date: 2014-11-29T10:56:48Z

          TAJO-1176: Implements queryable virtual tables for catalog information

          commit 11876693ed10bea3d62c74998eae1a47e3217dd3
          Author: Jihun Kang <ykrips@gmail.com>
          Date: 2014-12-01T07:19:13Z

          TAJO-1176: Implements queryable virtual tables for catalog information


          githubbot ASF GitHub Bot added a comment -

          Github user ykrips closed the pull request at:

          https://github.com/apache/tajo/pull/273

          githubbot ASF GitHub Bot added a comment -

          Github user ykrips commented on the pull request:

          https://github.com/apache/tajo/pull/273#issuecomment-65032859

          Well, I always run test cases with "dist" profile, and I did not notify the changes on catalog drivers. Root cause of this build issue has found and it will be fixed in the next commit.

          githubbot ASF GitHub Bot added a comment -

          GitHub user ykrips reopened a pull request:

          https://github.com/apache/tajo/pull/273

          TAJO-1176: Implements queryable virtual tables for catalog information

          You can merge this pull request into a Git repository by running:

          $ git pull https://github.com/ykrips/tajo TAJO-1176

          Alternatively you can review and apply these changes as the patch at:

          https://github.com/apache/tajo/pull/273.patch

          To close this pull request, make a commit to your master/trunk branch
          with (at least) the following in the commit message:

          This closes #273


          commit e878d414c4a722427e8fb8c9068371250fd3092f
          Author: Jihun Kang <ykrips@gmail.com>
          Date: 2014-11-29T10:54:19Z

          TAJO-1176: Implements queryable virtual tables for catalog information

          commit aa63c22339d9db28e94ee6cb6cdee1f602b736d5
          Author: Jihun Kang <ykrips@gmail.com>
          Date: 2014-11-29T10:56:48Z

          TAJO-1176: Implements queryable virtual tables for catalog information

          commit 11876693ed10bea3d62c74998eae1a47e3217dd3
          Author: Jihun Kang <ykrips@gmail.com>
          Date: 2014-12-01T07:19:13Z

          TAJO-1176: Implements queryable virtual tables for catalog information

          commit c8ba8315f9eb45bf8062bfb5ace05a4cf4c55535
          Author: Jihun Kang <ykrips@gmail.com>
          Date: 2014-12-01T08:33:50Z

          Merge remote-tracking branch 'upstream/master' into TAJO-1176

          commit 26b672324158eeff9dbb16e2e86a804793607a71
          Author: Jihun Kang <ykrips@gmail.com>
          Date: 2014-12-01T08:39:47Z

          TAJO-1176: Implements queryable virtual tables for catalog information


          githubbot ASF GitHub Bot added a comment -

          Github user hyunsik commented on the pull request:

          https://github.com/apache/tajo/pull/273#issuecomment-65375791

          I'm testing this feature. 'SYSTEM' database and tables are well represented in all APIs. Furthermore, I could query SQL queries on those tables. It's really awesome!!

          I'm reviewing the code. I'll give comments soon!

          githubbot ASF GitHub Bot added a comment -

          Github user hyunsik commented on the pull request:

          https://github.com/apache/tajo/pull/273#issuecomment-65762633

          It's really great job. I briefly investigated it in order to give good reviews. I'm still reviewing it. I'll give more comments soon.

          Now, I have one suggestion or discussion agenda related to this issue. It would be nice if ultimately we have a direction like *INFORMATION SCHEMA* (http://en.wikipedia.org/wiki/Information_schema). You may already know this concept more than me. It is required for Tajo to follow ANSI SQL standard.

          BTW, I don't think that we have to do it in this issue. We can commit your current work now, and mark it as an experimental and evolving feature, Then, we change it later if other committers agree with my suggestion. I'd also like to help this work.

          The following is my suggestion for the future. There may be two approaches to achieve ```INFORMATION SCHEMA```.

          One is that we change current schemas to follow ```INFORMATION SCHEMA```. But, this approach requires lots of burden. Also, it may be hard to optimize table schemas for our system characteristics.

          Another approach is to provide virtual tables for ```INFORMATION SCHEMA```. Actually, we don't need to have catalog schemas which are physically equivalent to ```INFORMATION SCHEMA```. For example, Postgresql uses different schemas to maintain its catalog, but it provides a virtual table to show information schema. I think that we can do like them.

          How do you think about my future direction?

          githubbot ASF GitHub Bot added a comment -

          Github user jihoonson commented on the pull request:

          https://github.com/apache/tajo/pull/273#issuecomment-65782990

          Thanks for your great discussion!
          IMHO, the second approach using virtual tables looks good.
          BTW, I also looked over the latest patch. It looks awesome!

          githubbot ASF GitHub Bot added a comment -

          Github user hyunsik commented on the pull request:

          https://github.com/apache/tajo/pull/273#issuecomment-65787189

          Hi @jihoonson,

          You will be amazed if you execute some queries on catalog tables rather than reading the patch.

          githubbot ASF GitHub Bot added a comment -

          Github user jihoonson commented on the pull request:

          https://github.com/apache/tajo/pull/273#issuecomment-65886775

          @hyunsik, I have just executed some queries on catalog tables.
          Yes, it is amazing..
          @ykrips, thanks for your work!

          githubbot ASF GitHub Bot added a comment -

          Github user ykrips commented on the pull request:

          https://github.com/apache/tajo/pull/273#issuecomment-65966012

          Hello @hyunsik,
          Yes, information schema is definitely ansi standard, and it would be better if we follow this standard. I agree with your opinion that implementing information schema is needed to split into multiple tasks, and catalog store and any other components needs to change to handle more information. It requires more time, and adopting a new feature could need lots of efforts on it.
          And let's talk about the strategy on information schema implementation. I would like to vote the second approach. I think that the first one would limit the capability of Tajo. When Tajo supports the view on it, we can define the information schema with this view feature.

          githubbot ASF GitHub Bot added a comment -

          Github user hyunsik commented on the pull request:

          https://github.com/apache/tajo/pull/273#issuecomment-66628730

          I'm sorry for late review. I'll finish the review by tomorrow.

          githubbot ASF GitHub Bot added a comment -

          Github user hyunsik commented on the pull request:

          https://github.com/apache/tajo/pull/273#issuecomment-66724735

          Could you rebase it against the latest revision? I'm very sorry for late review.

          githubbot ASF GitHub Bot added a comment -

          Github user ykrips commented on the pull request:

          https://github.com/apache/tajo/pull/273#issuecomment-66866828

          No problems

          githubbot ASF GitHub Bot added a comment -

          Github user hyunsik commented on the pull request:

          https://github.com/apache/tajo/pull/273#issuecomment-67274493

          While I'm reviewing this work, I found that Catalog API is not quryable, causing scalability problem against large tables and partitions. So, I created a jira issue related to this issue. You already may found this issue. https://issues.apache.org/jira/browse/TAJO-1253

          githubbot ASF GitHub Bot added a comment -

          Github user hyunsik commented on the pull request:

          https://github.com/apache/tajo/pull/273#issuecomment-67281145

          I also agree that virtual table is good approach to us.

          The first trial is to make this work closer to 'information schema', even through the details are different to the standard specification of 'information schema'.

          In this sense, I'd like to suggest as follows:

          • All names of databases and tables should be lower cases.
          • database name 'SYSTEM' to 'information_schema'
          • SYSTEM.DATABASE_ should be 'information_schema.databases'

          I'll also leave more comments soon.

          githubbot ASF GitHub Bot added a comment -

          Github user hyunsik commented on the pull request:

          https://github.com/apache/tajo/pull/273#issuecomment-67287866

          Similar to the above comments, all column names of schemas used in AbstractTableDescriptor should be lower case letters.

          githubbot ASF GitHub Bot added a comment -

          Github user hyunsik commented on a diff in the pull request:

          https://github.com/apache/tajo/pull/273#discussion_r21956997

          — Diff: tajo-catalog/tajo-catalog-server/src/main/java/org/apache/tajo/catalog/dictionary/SystemMetadataDictionary.java —
          @@ -0,0 +1,124 @@
          +/**
          + * Licensed to the Apache Software Foundation (ASF) under one
          + * or more contributor license agreements. See the NOTICE file
          + * distributed with this work for additional information
          + * regarding copyright ownership. The ASF licenses this file
          + * to you under the Apache License, Version 2.0 (the
          + * "License"); you may not use this file except in compliance
          + * with the License. You may obtain a copy of the License at
          + *
          + * http://www.apache.org/licenses/LICENSE-2.0
          + *
          + * Unless required by applicable law or agreed to in writing, software
          + * distributed under the License is distributed on an "AS IS" BASIS,
          + * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
          + * See the License for the specific language governing permissions and
          + * limitations under the License.
          + */
          +
          +package org.apache.tajo.catalog.dictionary;
          +
          +import java.util.ArrayList;
          +import java.util.Collections;
          +import java.util.List;
          +
          +import org.apache.tajo.catalog.exception.NoSuchTableException;
          +import org.apache.tajo.catalog.proto.CatalogProtos;
          +import org.apache.tajo.util.TUtil;
          +
          +public class SystemMetadataDictionary {
          — End diff –

          When it comes to trying to make this work closer to 'information schema', It's name needs to include the words 'information schema'.

          githubbot ASF GitHub Bot added a comment -

          Github user hyunsik commented on a diff in the pull request:

          https://github.com/apache/tajo/pull/273#discussion_r21957003

          — Diff: tajo-catalog/tajo-catalog-server/src/main/java/org/apache/tajo/catalog/dictionary/SystemMetadataDictionary.java —
          @@ -0,0 +1,124 @@
          +/**
          + * Licensed to the Apache Software Foundation (ASF) under one
          + * or more contributor license agreements. See the NOTICE file
          + * distributed with this work for additional information
          + * regarding copyright ownership. The ASF licenses this file
          + * to you under the Apache License, Version 2.0 (the
          + * "License"); you may not use this file except in compliance
          + * with the License. You may obtain a copy of the License at
          + *
          + * http://www.apache.org/licenses/LICENSE-2.0
          + *
          + * Unless required by applicable law or agreed to in writing, software
          + * distributed under the License is distributed on an "AS IS" BASIS,
          + * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
          + * See the License for the specific language governing permissions and
          + * limitations under the License.
          + */
          +
          +package org.apache.tajo.catalog.dictionary;
          +
          +import java.util.ArrayList;
          +import java.util.Collections;
          +import java.util.List;
          +
          +import org.apache.tajo.catalog.exception.NoSuchTableException;
          +import org.apache.tajo.catalog.proto.CatalogProtos;
          +import org.apache.tajo.util.TUtil;
          +
          +public class SystemMetadataDictionary {
          +
          + private static final String DATABASE_NAME = "SYSTEM";
          — End diff –

          it should be also 'information_schema'.

          githubbot ASF GitHub Bot added a comment -

          Github user hyunsik commented on a diff in the pull request:

          https://github.com/apache/tajo/pull/273#discussion_r21957026

          — Diff: tajo-catalog/tajo-catalog-server/src/main/java/org/apache/tajo/catalog/dictionary/SystemMetadataDictionary.java —
          @@ -0,0 +1,124 @@
          +/**
          + * Licensed to the Apache Software Foundation (ASF) under one
          + * or more contributor license agreements. See the NOTICE file
          + * distributed with this work for additional information
          + * regarding copyright ownership. The ASF licenses this file
          + * to you under the Apache License, Version 2.0 (the
          + * "License"); you may not use this file except in compliance
          + * with the License. You may obtain a copy of the License at
          + *
          + * http://www.apache.org/licenses/LICENSE-2.0
          + *
          + * Unless required by applicable law or agreed to in writing, software
          + * distributed under the License is distributed on an "AS IS" BASIS,
          + * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
          + * See the License for the specific language governing permissions and
          + * limitations under the License.
          + */
          +
          +package org.apache.tajo.catalog.dictionary;
          +
          +import java.util.ArrayList;
          +import java.util.Collections;
          +import java.util.List;
          +
          +import org.apache.tajo.catalog.exception.NoSuchTableException;
          +import org.apache.tajo.catalog.proto.CatalogProtos;
          +import org.apache.tajo.util.TUtil;
          +
          +public class SystemMetadataDictionary {
          +
          + private static final String DATABASE_NAME = "SYSTEM";
          +
          + private static enum DEFINED_TABLES

          { + TABLESPACES, + DATABASES, + TABLES, + COLUMNS, + INDEXES, + TABLEOPTIONS, + TABLESTATS, + PARTITIONS, + MAX_TABLE; + }

          +
          + private List<TableDescriptor> systemTableDescriptors = new ArrayList<TableDescriptor>(
          + Collections.nCopies(DEFINED_TABLES.MAX_TABLE.ordinal(), (TableDescriptor)null));
          +
          + public SystemMetadataDictionary()

          { + createSystemTableDescriptors(); + }

          +
          + private void createSystemTableDescriptors()

          { + systemTableDescriptors.set(DEFINED_TABLES.TABLESPACES.ordinal(), new TablespacesTableDescriptor(this)); + systemTableDescriptors.set(DEFINED_TABLES.DATABASES.ordinal(), new DatabasesTableDescriptor(this)); + systemTableDescriptors.set(DEFINED_TABLES.TABLES.ordinal(), new TablesTableDescriptor(this)); + systemTableDescriptors.set(DEFINED_TABLES.COLUMNS.ordinal(), new ColumnsTableDescriptor(this)); + systemTableDescriptors.set(DEFINED_TABLES.INDEXES.ordinal(), new IndexesTableDescriptor(this)); + systemTableDescriptors.set(DEFINED_TABLES.TABLEOPTIONS.ordinal(), new TableOptionsTableDescriptor(this)); + systemTableDescriptors.set(DEFINED_TABLES.TABLESTATS.ordinal(), new TableStatsTableDescriptor(this)); + systemTableDescriptors.set(DEFINED_TABLES.PARTITIONS.ordinal(), new PartitionsTableDescriptor(this)); + }

          +
          + public boolean isSystemDatabase(String databaseName) {
          — End diff –

          This name also should include the words 'information schema'.

          githubbot ASF GitHub Bot added a comment -

          Github user hyunsik commented on the pull request:

          https://github.com/apache/tajo/pull/273#issuecomment-67289076

          Hi @ykrips,

          In overall, the patch looks good to me. I leave some comments.

          githubbot ASF GitHub Bot added a comment -

          Github user ykrips commented on the pull request:

          https://github.com/apache/tajo/pull/273#issuecomment-67732660

          Good suggestions. I don't have any objections to change names of this schema. I will commit it in a short time.

          githubbot ASF GitHub Bot added a comment -

          Github user hyunsik commented on the pull request:

          https://github.com/apache/tajo/pull/273#issuecomment-67736515

          Thanks! I'll finish review after you update the patch.

          githubbot ASF GitHub Bot added a comment -

          Github user ykrips commented on the pull request:

          https://github.com/apache/tajo/pull/273#issuecomment-67820065

          Sorry for that. I will figure out why test build has failed, and will post a patch in a short time.

          githubbot ASF GitHub Bot added a comment -

          Github user ykrips commented on the pull request:

          https://github.com/apache/tajo/pull/273#issuecomment-68322655

          Hello All,
          These codes are rebased to the current stream.

          githubbot ASF GitHub Bot added a comment -

          Github user hyunsik commented on the pull request:

          https://github.com/apache/tajo/pull/273#issuecomment-68329167

          +1 Ship it!

          This work may be the first commit by yourself. Congratulation on joining Tajo committer.

          githubbot ASF GitHub Bot added a comment -

          Github user asfgit closed the pull request at:

          https://github.com/apache/tajo/pull/273

          githubbot ASF GitHub Bot added a comment -

          Github user ykrips commented on the pull request:

          https://github.com/apache/tajo/pull/273#issuecomment-68362507

          Thank you for reviewing this issue.

          hudson Hudson added a comment -

          SUCCESS: Integrated in Tajo-master-build #526 (See https://builds.apache.org/job/Tajo-master-build/526/)
          TAJO-1176: Implements queryable virtual tables for catalog information (jihun: rev 021a6f0b216ca9f67a5a889e72d2a8ce81c047f2)

          • tajo-core/src/main/java/org/apache/tajo/master/NonForwardQueryResultScanner.java
          • tajo-catalog/tajo-catalog-client/src/main/proto/CatalogProtocol.proto
          • tajo-catalog/tajo-catalog-server/src/main/java/org/apache/tajo/catalog/dictionary/TablespacesTableDescriptor.java
          • tajo-catalog/tajo-catalog-drivers/tajo-hcatalog/src/main/java/org/apache/tajo/catalog/store/HCatalogStore.java
          • tajo-catalog/tajo-catalog-server/src/main/java/org/apache/tajo/catalog/dictionary/TableDescriptor.java
          • tajo-catalog/tajo-catalog-server/src/main/java/org/apache/tajo/catalog/dictionary/TableOptionsTableDescriptor.java
          • tajo-core/src/main/java/org/apache/tajo/master/NonForwardQueryResultSystemScanner.java
          • tajo-catalog/tajo-catalog-server/src/main/java/org/apache/tajo/catalog/dictionary/PartitionsTableDescriptor.java
          • tajo-catalog/tajo-catalog-common/src/main/java/org/apache/tajo/catalog/CatalogService.java
          • tajo-catalog/tajo-catalog-server/src/main/java/org/apache/tajo/catalog/store/MemStore.java
          • tajo-plan/src/main/java/org/apache/tajo/plan/LogicalPlanner.java
          • tajo-core/src/main/java/org/apache/tajo/master/NonForwardQueryResultFileScanner.java
          • tajo-catalog/tajo-catalog-server/src/main/java/org/apache/tajo/catalog/CatalogServer.java
          • tajo-core/src/test/java/org/apache/tajo/master/TestNonForwardQueryResultSystemScanner.java
          • tajo-catalog/tajo-catalog-server/src/main/java/org/apache/tajo/catalog/store/AbstractDBStore.java
          • tajo-catalog/tajo-catalog-client/src/main/java/org/apache/tajo/catalog/AbstractCatalogClient.java
          • tajo-catalog/tajo-catalog-server/src/main/java/org/apache/tajo/catalog/dictionary/ColumnsTableDescriptor.java
          • tajo-catalog/tajo-catalog-common/src/main/proto/CatalogProtos.proto
          • tajo-plan/src/main/java/org/apache/tajo/plan/util/PlannerUtil.java
          • tajo-catalog/tajo-catalog-server/src/main/java/org/apache/tajo/catalog/dictionary/IndexesTableDescriptor.java
          • tajo-catalog/tajo-catalog-server/src/main/java/org/apache/tajo/catalog/dictionary/TableStatsTableDescriptor.java
          • tajo-catalog/tajo-catalog-server/src/main/java/org/apache/tajo/catalog/dictionary/DatabasesTableDescriptor.java
          • tajo-catalog/tajo-catalog-server/src/main/java/org/apache/tajo/catalog/dictionary/ColumnDescriptor.java
          • tajo-core/src/main/java/org/apache/tajo/master/exec/QueryExecutor.java
          • tajo-catalog/tajo-catalog-server/src/test/java/org/apache/tajo/catalog/TestCatalog.java
          • tajo-core/src/main/java/org/apache/tajo/master/TajoMasterClientService.java
          • tajo-catalog/tajo-catalog-server/src/main/java/org/apache/tajo/catalog/store/CatalogStore.java
          • tajo-catalog/tajo-catalog-server/src/main/java/org/apache/tajo/catalog/dictionary/TablesTableDescriptor.java
          • tajo-catalog/tajo-catalog-server/src/main/java/org/apache/tajo/catalog/dictionary/InfoSchemaMetadataDictionary.java
          • tajo-catalog/tajo-catalog-server/src/main/java/org/apache/tajo/catalog/dictionary/AbstractTableDescriptor.java
          hudson Hudson added a comment -

          FAILURE: Integrated in Tajo-master-CODEGEN-build #166 (See https://builds.apache.org/job/Tajo-master-CODEGEN-build/166/)
          TAJO-1176: Implements queryable virtual tables for catalog information (jihun: rev 021a6f0b216ca9f67a5a889e72d2a8ce81c047f2)

          • tajo-catalog/tajo-catalog-server/src/main/java/org/apache/tajo/catalog/store/AbstractDBStore.java
          • tajo-catalog/tajo-catalog-server/src/main/java/org/apache/tajo/catalog/dictionary/TableDescriptor.java
          • tajo-plan/src/main/java/org/apache/tajo/plan/util/PlannerUtil.java
          • tajo-catalog/tajo-catalog-server/src/main/java/org/apache/tajo/catalog/dictionary/InfoSchemaMetadataDictionary.java
          • tajo-catalog/tajo-catalog-common/src/main/proto/CatalogProtos.proto
          • tajo-catalog/tajo-catalog-server/src/main/java/org/apache/tajo/catalog/store/CatalogStore.java
          • tajo-catalog/tajo-catalog-server/src/main/java/org/apache/tajo/catalog/CatalogServer.java
          • tajo-catalog/tajo-catalog-server/src/main/java/org/apache/tajo/catalog/dictionary/TablesTableDescriptor.java
          • tajo-catalog/tajo-catalog-client/src/main/proto/CatalogProtocol.proto
          • tajo-catalog/tajo-catalog-server/src/main/java/org/apache/tajo/catalog/dictionary/ColumnsTableDescriptor.java
          • tajo-core/src/test/java/org/apache/tajo/master/TestNonForwardQueryResultSystemScanner.java
          • tajo-catalog/tajo-catalog-drivers/tajo-hcatalog/src/main/java/org/apache/tajo/catalog/store/HCatalogStore.java
          • tajo-catalog/tajo-catalog-server/src/main/java/org/apache/tajo/catalog/store/MemStore.java
          • tajo-core/src/main/java/org/apache/tajo/master/exec/QueryExecutor.java
          • tajo-catalog/tajo-catalog-server/src/main/java/org/apache/tajo/catalog/dictionary/TableStatsTableDescriptor.java
          • tajo-core/src/main/java/org/apache/tajo/master/NonForwardQueryResultScanner.java
          • tajo-catalog/tajo-catalog-server/src/main/java/org/apache/tajo/catalog/dictionary/AbstractTableDescriptor.java
          • tajo-core/src/main/java/org/apache/tajo/master/TajoMasterClientService.java
          • tajo-plan/src/main/java/org/apache/tajo/plan/LogicalPlanner.java
          • tajo-catalog/tajo-catalog-server/src/main/java/org/apache/tajo/catalog/dictionary/ColumnDescriptor.java
          • tajo-catalog/tajo-catalog-server/src/main/java/org/apache/tajo/catalog/dictionary/PartitionsTableDescriptor.java
          • tajo-catalog/tajo-catalog-server/src/main/java/org/apache/tajo/catalog/dictionary/TablespacesTableDescriptor.java
          • tajo-catalog/tajo-catalog-client/src/main/java/org/apache/tajo/catalog/AbstractCatalogClient.java
          • tajo-core/src/main/java/org/apache/tajo/master/NonForwardQueryResultFileScanner.java
          • tajo-catalog/tajo-catalog-server/src/test/java/org/apache/tajo/catalog/TestCatalog.java
          • tajo-catalog/tajo-catalog-server/src/main/java/org/apache/tajo/catalog/dictionary/IndexesTableDescriptor.java
          • tajo-catalog/tajo-catalog-server/src/main/java/org/apache/tajo/catalog/dictionary/DatabasesTableDescriptor.java
          • tajo-core/src/main/java/org/apache/tajo/master/NonForwardQueryResultSystemScanner.java
          • tajo-catalog/tajo-catalog-server/src/main/java/org/apache/tajo/catalog/dictionary/TableOptionsTableDescriptor.java
          • tajo-catalog/tajo-catalog-common/src/main/java/org/apache/tajo/catalog/CatalogService.java

            People

            • Assignee:
              ykrips Jihun Kang
              Reporter:
              ykrips Jihun Kang
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development