Uploaded image for project: 'Tajo'
  1. Tajo
  2. TAJO-1047

DefaultTaskScheduler:allocateRackTask is failed occasionally on JDK 1.7

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.9.0
    • Component/s: QueryMaster
    • Labels:
      None

      Description

      It is multi thread issue.

      2014-09-03 05:17:14,378 FATAL org.apache.tajo.master.DefaultTaskScheduler: Comparison method violates its general contract!
      java.lang.IllegalArgumentException: Comparison method violates its general contract!
             at java.util.TimSort.mergeLo(TimSort.java:747)
             at java.util.TimSort.mergeAt(TimSort.java:483)
             at java.util.TimSort.mergeForceCollapse(TimSort.java:426)
             at java.util.TimSort.sort(TimSort.java:223)
             at java.util.TimSort.sort(TimSort.java:173)
             at java.util.Arrays.sort(Arrays.java:659)
             at java.util.Collections.sort(Collections.java:217)
             at org.apache.tajo.master.DefaultTaskScheduler$ScheduledRequests.allocateRackTask(DefaultTaskScheduler.java:678)
             at org.apache.tajo.master.DefaultTaskScheduler$ScheduledRequests.assignToLeafTasks(DefaultTaskScheduler.java:798)
             at org.apache.tajo.master.DefaultTaskScheduler.schedule(DefaultTaskScheduler.java:154)
             at org.apache.tajo.master.DefaultTaskScheduler$1.run(DefaultTaskScheduler.java:95)
      

        Activity

        hudson Hudson added a comment -

        SUCCESS: Integrated in Tajo-block_iteration-branch-build #4 (See https://builds.apache.org/job/Tajo-block_iteration-branch-build/4/)
        TAJO-1047: DefaultTaskScheduler:allocateRackTask is failed occasionally on JDK 1.7. (jinho) (jhkim: rev 1b3d51e149039db86d8c65f1fe3f0c8953b6faf4)

        • CHANGES
        • tajo-core/src/main/java/org/apache/tajo/master/DefaultTaskScheduler.java
        hudson Hudson added a comment -

        FAILURE: Integrated in Tajo-master-CODEGEN-build #10 (See https://builds.apache.org/job/Tajo-master-CODEGEN-build/10/)
        TAJO-1047: DefaultTaskScheduler:allocateRackTask is failed occasionally on JDK 1.7. (jinho) (jhkim: rev 1b3d51e149039db86d8c65f1fe3f0c8953b6faf4)

        • CHANGES
        • tajo-core/src/main/java/org/apache/tajo/master/DefaultTaskScheduler.java
        hudson Hudson added a comment -

        SUCCESS: Integrated in Tajo-master-build #368 (See https://builds.apache.org/job/Tajo-master-build/368/)
        TAJO-1047: DefaultTaskScheduler:allocateRackTask is failed occasionally on JDK 1.7. (jinho) (jhkim: rev 1b3d51e149039db86d8c65f1fe3f0c8953b6faf4)

        • CHANGES
        • tajo-core/src/main/java/org/apache/tajo/master/DefaultTaskScheduler.java
        jhkim Jinho Kim added a comment -

        committed it.
        Thank you!

        githubbot ASF GitHub Bot added a comment -

        Github user asfgit closed the pull request at:

        https://github.com/apache/tajo/pull/144

        githubbot ASF GitHub Bot added a comment -

        Github user hyunsik commented on the pull request:

        https://github.com/apache/tajo/pull/144#issuecomment-56259611

        +1

        The patch looks good to me.

        githubbot ASF GitHub Bot added a comment -

        Github user jinossy commented on the pull request:

        https://github.com/apache/tajo/pull/144#issuecomment-56255940

        @hyunsik
        If a worker send a request before all of queryunit are not scheduled, it caused occasionally.
        Additionally, I remove wrong event caused by TAJO-1015.

        githubbot ASF GitHub Bot added a comment -

        Github user hyunsik commented on the pull request:

        https://github.com/apache/tajo/pull/144#issuecomment-56183195

        Could you share the main cause of this bug? It seems to be a concurrency problem.

        githubbot ASF GitHub Bot added a comment -

        GitHub user jinossy opened a pull request:

        https://github.com/apache/tajo/pull/144

        TAJO-1047: DefaultTaskScheduler:allocateRackTask is failed occasionally ...

        You can merge this pull request into a Git repository by running:

        $ git pull https://github.com/jinossy/tajo TAJO-1047

        Alternatively you can review and apply these changes as the patch at:

        https://github.com/apache/tajo/pull/144.patch

        To close this pull request, make a commit to your master/trunk branch
        with (at least) the following in the commit message:

        This closes #144


        commit 00fcc780a1a3cc069340cf05bbf47bc5036a70e5
        Author: jhkim <jhkim@apache.org>
        Date: 2014-09-17T08:48:52Z

        TAJO-1047: DefaultTaskScheduler:allocateRackTask is failed occasionally on JDK 1.7.



          People

          • Assignee:
            jhkim Jinho Kim
            Reporter:
            jhkim Jinho Kim
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development