Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.9.0
    • Component/s: RPC
    • Labels:
      None

      Description

      Currently, tajo has many rpc port in worker. It is difficult to use. we need to refactor code.

        Activity

        githubbot ASF GitHub Bot added a comment -

        GitHub user jinossy opened a pull request:

        https://github.com/apache/tajo/pull/125

        TAJO-1016: Refactor worker rpc information.

        You can merge this pull request into a Git repository by running:

        $ git pull https://github.com/jinossy/tajo TAJO-1016

        Alternatively you can review and apply these changes as the patch at:

        https://github.com/apache/tajo/pull/125.patch

        To close this pull request, make a commit to your master/trunk branch
        with (at least) the following in the commit message:

        This closes #125


        commit f922dd181676bb5a62008480744e5d833c9a65c0
        Author: jhkim <jhkim@apache.org>
        Date: 2014-08-26T09:42:58Z

        TAJO-1016: Refactor worker rpc information.


        githubbot ASF GitHub Bot added a comment -

        Github user hyunsik commented on the pull request:

        https://github.com/apache/tajo/pull/125#issuecomment-55072664

        It also needs rebase.

        githubbot ASF GitHub Bot added a comment -

        Github user jinossy commented on the pull request:

        https://github.com/apache/tajo/pull/125#issuecomment-55215256

        I’ve rebase this issue

        githubbot ASF GitHub Bot added a comment -

        Github user hyunsik commented on a diff in the pull request:

        https://github.com/apache/tajo/pull/125#discussion_r17600629

        — Diff: tajo-core/src/main/java/org/apache/tajo/master/cluster/WorkerConnectionInfo.java —
        @@ -0,0 +1,178 @@
        +/**
        + * Licensed to the Apache Software Foundation (ASF) under one
        + * or more contributor license agreements. See the NOTICE file
        + * distributed with this work for additional information
        + * regarding copyright ownership. The ASF licenses this file
        + * to you under the Apache License, Version 2.0 (the
        + * "License"); you may not use this file except in compliance
        + * with the License. You may obtain a copy of the License at
        + *
        + * http://www.apache.org/licenses/LICENSE-2.0
        + *
        + * Unless required by applicable law or agreed to in writing, software
        + * distributed under the License is distributed on an "AS IS" BASIS,
        + * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
        + * See the License for the specific language governing permissions and
        + * limitations under the License.
        + */
        +
        +package org.apache.tajo.master.cluster;
        +
        +import org.apache.tajo.common.ProtoObject;
        +
        +import static org.apache.tajo.TajoProtos.WorkerConnectionInfoProto;
        +
        +public class WorkerConnectionInfo implements ProtoObject<WorkerConnectionInfoProto>, Comparable<WorkerConnectionInfo> {
        + private WorkerConnectionInfoProto.Builder builder;
        + /**
        + * unique worker id
        + */
        + private int id;
        + /**
        + * Hostname
        + */
        + private String host;
        + /**
        + * Peer rpc port
        + */
        + private int peerRpcPort;
        + /**
        + * pull server port
        + */
        + private int pullServerPort;
        + /**
        + * QueryMaster rpc port
        + */
        + private int queryMasterPort;
        + /**
        + * the port of client rpc which provides an client API
        + */
        + private int clientPort;
        + /**
        + * http info port
        + */
        + private int httpInfoPort;
        +
        + public WorkerConnectionInfo()

        { + builder = WorkerConnectionInfoProto.newBuilder(); + }

        +
        + public WorkerConnectionInfo(WorkerConnectionInfoProto proto)

        { + this(); + this.id = proto.getId(); + this.host = proto.getHost(); + this.peerRpcPort = proto.getPeerRpcPort(); + this.pullServerPort = proto.getPullServerPort(); + this.clientPort = proto.getClientPort(); + this.httpInfoPort = proto.getHttpInfoPort(); + this.queryMasterPort = proto.getQueryMasterPort(); + }

        +
        + public WorkerConnectionInfo(String host, int peerRpcPort, int pullServerPort, int clientPort,
        + int queryMasterPort, int httpInfoPort)

        { + this(); + this.host = host; + this.peerRpcPort = peerRpcPort; + this.pullServerPort = pullServerPort; + this.clientPort = clientPort; + this.queryMasterPort = queryMasterPort; + this.httpInfoPort = httpInfoPort; + this.id = hashCode(); + }

        +
        + public String getHost()

        { + return host; + }

        +
        + public int getPeerRpcPort()

        { + return peerRpcPort; + }

        +
        + public int getPullServerPort()

        { + return pullServerPort; + }

        +
        + public int getQueryMasterPort()

        { + return queryMasterPort; + }

        +
        + public int getClientPort()

        { + return clientPort; + }

        +
        + public int getHttpInfoPort()

        { + return httpInfoPort; + }

        +
        + public int getId()

        { + return id; + }

        +
        + public String getHostAndPeerRpcPort()

        { + return this.getHost() + ":" + this.getPeerRpcPort(); + }

        +
        + @Override
        + public WorkerConnectionInfoProto getProto() {
        + builder.setId(id)
        — End diff –

        It reuses builder. Recently, we've experienced race condition of builder object. Is there no possibility of concurrency problem?

        githubbot ASF GitHub Bot added a comment -

        Github user hyunsik commented on the pull request:

        https://github.com/apache/tajo/pull/125#issuecomment-55743207

        It's nice code cleanup and refactoring.

        It's just wondering. Is there no possibility to cause some potential problem caused by changing hostname to unique worker id?

        githubbot ASF GitHub Bot added a comment -

        Github user jinossy commented on the pull request:

        https://github.com/apache/tajo/pull/125#issuecomment-55856729

        @hyunsik Thank you for the review!
        This patch will fix potential problem caused by FQDN. Actually I was tested for 2 month.
        if you still have any problem, I will commit after 0.9.0 release

        githubbot ASF GitHub Bot added a comment -

        Github user hyunsik commented on the pull request:

        https://github.com/apache/tajo/pull/125#issuecomment-56182860

        +1
        Ship it!

        jhkim Jinho Kim added a comment -

        Thank you for the review!
        committed it.

        githubbot ASF GitHub Bot added a comment -

        Github user asfgit closed the pull request at:

        https://github.com/apache/tajo/pull/125

        hudson Hudson added a comment -

        SUCCESS: Integrated in Tajo-master-build #365 (See https://builds.apache.org/job/Tajo-master-build/365/)
        TAJO-1016: Refactor worker rpc information. (jinho) (jhkim: rev 28282b561ad0a75f9603936bf04f2aa5c99b6b58)

        • tajo-core/src/main/java/org/apache/tajo/master/rm/WorkerResourceManager.java
        • tajo-core/src/main/java/org/apache/tajo/master/TajoMasterClientService.java
        • tajo-core/src/main/java/org/apache/tajo/worker/TaskRunnerManager.java
        • tajo-core/src/main/resources/webapps/admin/query.jsp
        • CHANGES
        • tajo-core/src/main/resources/webapps/worker/querytasks.jsp
        • tajo-core/src/main/resources/webapps/admin/index.jsp
        • tajo-client/src/main/proto/ClientProtos.proto
        • tajo-core/src/main/java/org/apache/tajo/master/cluster/WorkerConnectionInfo.java
        • tajo-core/src/main/java/org/apache/tajo/master/TajoContainerProxy.java
        • tajo-client/src/main/java/org/apache/tajo/client/TajoAdmin.java
        • tajo-core/src/main/java/org/apache/tajo/master/rm/TajoWorkerResourceManager.java
        • tajo-core/src/main/java/org/apache/tajo/master/rm/TajoRMContext.java
        • tajo-core/src/main/java/org/apache/tajo/master/rm/WorkerStatusEvent.java
        • tajo-core/src/main/java/org/apache/tajo/worker/ExecutionBlockContext.java
        • tajo-core/src/main/java/org/apache/tajo/master/querymaster/QueryJobManager.java
        • tajo-core/src/main/java/org/apache/tajo/worker/AbstractResourceAllocator.java
        • tajo-core/src/main/java/org/apache/tajo/worker/event/TaskRunnerStartEvent.java
        • tajo-core/src/main/java/org/apache/tajo/master/querymaster/QueryMasterManagerService.java
        • tajo-core/src/main/proto/TajoWorkerProtocol.proto
        • tajo-core/src/test/java/org/apache/tajo/master/rm/TestTajoResourceManager.java
        • tajo-core/src/main/java/org/apache/tajo/worker/TajoWorker.java
        • tajo-yarn-pullserver/src/main/java/org/apache/tajo/pullserver/TajoPullServerService.java
        • tajo-core/src/main/java/org/apache/tajo/worker/TajoWorkerClientService.java
        • tajo-core/src/main/resources/webapps/worker/taskdetail.jsp
        • tajo-core/src/main/java/org/apache/tajo/master/DefaultTaskScheduler.java
        • tajo-common/src/main/proto/tajo_protos.proto
        • tajo-core/src/main/java/org/apache/tajo/worker/Task.java
        • tajo-core/src/main/java/org/apache/tajo/master/querymaster/QueryMaster.java
        • tajo-core/src/main/java/org/apache/tajo/master/TajoMasterService.java
        • tajo-core/src/main/java/org/apache/tajo/master/LazyTaskScheduler.java
        • tajo-core/src/main/proto/ResourceTrackerProtocol.proto
        • tajo-core/src/main/java/org/apache/tajo/master/rm/Worker.java
        • tajo-core/src/main/java/org/apache/tajo/worker/TajoResourceAllocator.java
        • tajo-core/src/main/resources/webapps/admin/cluster.jsp
        • tajo-core/src/main/resources/webapps/worker/tasks.jsp
        • tajo-core/src/test/java/org/apache/tajo/cluster/TestWorkerConnectionInfo.java
        • tajo-core/src/main/java/org/apache/tajo/master/querymaster/QueryUnit.java
        • tajo-core/src/main/java/org/apache/tajo/master/rm/WorkerEvent.java
        • tajo-core/src/main/proto/TajoMasterProtocol.proto
        • tajo-core/src/main/java/org/apache/tajo/master/querymaster/QueryInProgress.java
        • tajo-core/src/main/java/org/apache/tajo/worker/TajoWorkerManagerService.java
        • tajo-core/src/main/java/org/apache/tajo/master/event/TaskAttemptAssignedEvent.java
        • tajo-core/src/main/java/org/apache/tajo/master/rm/WorkerReconnectEvent.java
        • tajo-core/src/main/java/org/apache/tajo/worker/TaskRunner.java
        • tajo-core/src/main/java/org/apache/tajo/worker/WorkerHeartbeatService.java
        • tajo-core/src/main/java/org/apache/tajo/master/querymaster/QueryUnitAttempt.java
        • tajo-core/src/main/java/org/apache/tajo/master/event/TaskRequestEvent.java
        • tajo-core/src/main/java/org/apache/tajo/master/rm/TajoResourceTracker.java
        • tajo-core/src/main/java/org/apache/tajo/master/rm/WorkerLivelinessMonitor.java
        hudson Hudson added a comment -

        SUCCESS: Integrated in Tajo-master-CODEGEN-build #7 (See https://builds.apache.org/job/Tajo-master-CODEGEN-build/7/)
        TAJO-1016: Refactor worker rpc information. (jinho) (jhkim: rev 28282b561ad0a75f9603936bf04f2aa5c99b6b58)

        • tajo-core/src/main/resources/webapps/worker/querytasks.jsp
        • tajo-core/src/main/resources/webapps/admin/cluster.jsp
        • tajo-core/src/main/java/org/apache/tajo/master/LazyTaskScheduler.java
        • tajo-core/src/main/java/org/apache/tajo/master/event/TaskAttemptAssignedEvent.java
        • tajo-core/src/main/resources/webapps/worker/tasks.jsp
        • tajo-core/src/test/java/org/apache/tajo/master/rm/TestTajoResourceManager.java
        • tajo-common/src/main/proto/tajo_protos.proto
        • tajo-core/src/main/resources/webapps/admin/index.jsp
        • tajo-core/src/main/java/org/apache/tajo/worker/TaskRunnerManager.java
        • tajo-core/src/main/java/org/apache/tajo/master/rm/TajoWorkerResourceManager.java
        • tajo-core/src/main/java/org/apache/tajo/master/rm/WorkerEvent.java
        • tajo-core/src/main/resources/webapps/admin/query.jsp
        • tajo-core/src/main/java/org/apache/tajo/worker/WorkerHeartbeatService.java
        • tajo-client/src/main/java/org/apache/tajo/client/TajoAdmin.java
        • tajo-yarn-pullserver/src/main/java/org/apache/tajo/pullserver/TajoPullServerService.java
        • tajo-core/src/main/proto/TajoWorkerProtocol.proto
        • tajo-core/src/main/java/org/apache/tajo/master/rm/TajoRMContext.java
        • tajo-core/src/main/java/org/apache/tajo/master/querymaster/QueryUnit.java
        • tajo-core/src/main/java/org/apache/tajo/master/querymaster/QueryUnitAttempt.java
        • tajo-core/src/main/java/org/apache/tajo/master/querymaster/QueryMaster.java
        • tajo-core/src/main/java/org/apache/tajo/worker/TajoResourceAllocator.java
        • tajo-core/src/main/java/org/apache/tajo/master/querymaster/QueryMasterManagerService.java
        • tajo-client/src/main/proto/ClientProtos.proto
        • tajo-core/src/main/java/org/apache/tajo/worker/TajoWorker.java
        • tajo-core/src/main/java/org/apache/tajo/worker/AbstractResourceAllocator.java
        • tajo-core/src/main/java/org/apache/tajo/master/rm/WorkerResourceManager.java
        • tajo-core/src/main/java/org/apache/tajo/worker/TaskRunner.java
        • tajo-core/src/main/java/org/apache/tajo/master/rm/WorkerLivelinessMonitor.java
        • tajo-core/src/main/java/org/apache/tajo/master/TajoMasterClientService.java
        • tajo-core/src/main/java/org/apache/tajo/master/cluster/WorkerConnectionInfo.java
        • tajo-core/src/main/java/org/apache/tajo/master/rm/TajoResourceTracker.java
        • tajo-core/src/main/java/org/apache/tajo/master/event/TaskRequestEvent.java
        • tajo-core/src/main/java/org/apache/tajo/worker/event/TaskRunnerStartEvent.java
        • tajo-core/src/main/proto/ResourceTrackerProtocol.proto
        • tajo-core/src/main/java/org/apache/tajo/worker/ExecutionBlockContext.java
        • tajo-core/src/main/java/org/apache/tajo/master/querymaster/QueryJobManager.java
        • tajo-core/src/main/java/org/apache/tajo/worker/TajoWorkerManagerService.java
        • tajo-core/src/main/java/org/apache/tajo/master/TajoContainerProxy.java
        • tajo-core/src/main/java/org/apache/tajo/master/TajoMasterService.java
        • tajo-core/src/main/java/org/apache/tajo/master/rm/WorkerStatusEvent.java
        • tajo-core/src/main/proto/TajoMasterProtocol.proto
        • tajo-core/src/main/java/org/apache/tajo/master/rm/Worker.java
        • tajo-core/src/main/java/org/apache/tajo/master/rm/WorkerReconnectEvent.java
        • tajo-core/src/main/resources/webapps/worker/taskdetail.jsp
        • tajo-core/src/main/java/org/apache/tajo/master/DefaultTaskScheduler.java
        • tajo-core/src/main/java/org/apache/tajo/master/querymaster/QueryInProgress.java
        • tajo-core/src/test/java/org/apache/tajo/cluster/TestWorkerConnectionInfo.java
        • CHANGES
        • tajo-core/src/main/java/org/apache/tajo/worker/TajoWorkerClientService.java
        • tajo-core/src/main/java/org/apache/tajo/worker/Task.java
        hudson Hudson added a comment -

        SUCCESS: Integrated in Tajo-block_iteration-branch-build #4 (See https://builds.apache.org/job/Tajo-block_iteration-branch-build/4/)
        TAJO-1016: Refactor worker rpc information. (jinho) (jhkim: rev 28282b561ad0a75f9603936bf04f2aa5c99b6b58)

        • tajo-yarn-pullserver/src/main/java/org/apache/tajo/pullserver/TajoPullServerService.java
        • tajo-core/src/main/java/org/apache/tajo/worker/TajoWorkerClientService.java
        • tajo-core/src/main/java/org/apache/tajo/master/rm/WorkerEvent.java
        • tajo-core/src/main/java/org/apache/tajo/worker/TajoWorker.java
        • tajo-core/src/main/resources/webapps/admin/cluster.jsp
        • tajo-core/src/main/java/org/apache/tajo/worker/WorkerHeartbeatService.java
        • tajo-core/src/main/java/org/apache/tajo/master/rm/TajoRMContext.java
        • tajo-core/src/main/java/org/apache/tajo/master/event/TaskAttemptAssignedEvent.java
        • tajo-core/src/main/java/org/apache/tajo/master/rm/WorkerReconnectEvent.java
        • tajo-core/src/main/java/org/apache/tajo/master/querymaster/QueryMasterManagerService.java
        • tajo-core/src/main/java/org/apache/tajo/master/querymaster/QueryMaster.java
        • tajo-core/src/main/java/org/apache/tajo/master/rm/WorkerLivelinessMonitor.java
        • tajo-core/src/main/java/org/apache/tajo/worker/Task.java
        • tajo-client/src/main/proto/ClientProtos.proto
        • tajo-core/src/main/proto/TajoMasterProtocol.proto
        • tajo-core/src/main/java/org/apache/tajo/master/rm/TajoResourceTracker.java
        • tajo-core/src/main/java/org/apache/tajo/master/TajoMasterService.java
        • tajo-core/src/main/resources/webapps/admin/index.jsp
        • tajo-core/src/main/java/org/apache/tajo/master/rm/TajoWorkerResourceManager.java
        • tajo-core/src/main/java/org/apache/tajo/worker/TaskRunner.java
        • tajo-core/src/main/java/org/apache/tajo/master/querymaster/QueryUnitAttempt.java
        • tajo-core/src/main/java/org/apache/tajo/master/rm/WorkerStatusEvent.java
        • tajo-core/src/main/java/org/apache/tajo/worker/TajoWorkerManagerService.java
        • tajo-core/src/main/java/org/apache/tajo/master/querymaster/QueryInProgress.java
        • tajo-core/src/main/java/org/apache/tajo/master/DefaultTaskScheduler.java
        • tajo-core/src/main/java/org/apache/tajo/master/event/TaskRequestEvent.java
        • tajo-core/src/main/java/org/apache/tajo/master/querymaster/QueryJobManager.java
        • tajo-core/src/test/java/org/apache/tajo/master/rm/TestTajoResourceManager.java
        • tajo-core/src/main/resources/webapps/worker/tasks.jsp
        • tajo-core/src/main/java/org/apache/tajo/worker/TaskRunnerManager.java
        • tajo-core/src/main/resources/webapps/worker/querytasks.jsp
        • tajo-core/src/main/java/org/apache/tajo/worker/event/TaskRunnerStartEvent.java
        • tajo-core/src/main/proto/ResourceTrackerProtocol.proto
        • tajo-client/src/main/java/org/apache/tajo/client/TajoAdmin.java
        • tajo-core/src/main/java/org/apache/tajo/worker/AbstractResourceAllocator.java
        • tajo-core/src/main/java/org/apache/tajo/master/TajoContainerProxy.java
        • tajo-core/src/main/java/org/apache/tajo/master/querymaster/QueryUnit.java
        • tajo-core/src/main/java/org/apache/tajo/master/TajoMasterClientService.java
        • tajo-core/src/main/java/org/apache/tajo/master/cluster/WorkerConnectionInfo.java
        • tajo-core/src/main/java/org/apache/tajo/worker/ExecutionBlockContext.java
        • tajo-core/src/main/java/org/apache/tajo/worker/TajoResourceAllocator.java
        • tajo-core/src/main/proto/TajoWorkerProtocol.proto
        • tajo-core/src/main/java/org/apache/tajo/master/rm/WorkerResourceManager.java
        • CHANGES
        • tajo-core/src/main/java/org/apache/tajo/master/LazyTaskScheduler.java
        • tajo-core/src/main/java/org/apache/tajo/master/rm/Worker.java
        • tajo-core/src/main/resources/webapps/worker/taskdetail.jsp
        • tajo-common/src/main/proto/tajo_protos.proto
        • tajo-core/src/main/resources/webapps/admin/query.jsp
        • tajo-core/src/test/java/org/apache/tajo/cluster/TestWorkerConnectionInfo.java

          People

          • Assignee:
            jhkim Jinho Kim
            Reporter:
            jhkim Jinho Kim
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development