Uploaded image for project: 'Syncope'
  1. Syncope
  2. SYNCOPE-1371

After upgrade from 2.0, error when updating Realm: ClassCastException: Expected LOGIC_ACTIONS, got PULL_ACTIONS

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.1.1
    • Fix Version/s: 2.1.2
    • Component/s: core
    • Labels:
      None

      Description

      After upgrading from 2.0 and updating a Realm, the following error is reported if such a Realm has a LogicActions implementation associated:

      ClassCastException: Expected LOGIC_ACTIONS, got PULL_ACTIONS
      

        Attachments

          Activity

            People

            • Assignee:
              ilgrosso Francesco Chicchiriccò
              Reporter:
              ilgrosso Francesco Chicchiriccò
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: