Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Won't Fix
    • Affects Version/s: 1.1
    • Fix Version/s: FUTURE
    • Component/s: Core
    • Labels:
      None
    • Environment:
      cygwin
      sh synapse.sh
      java version "1.5.0_06"
      %JAVA_HOME%/jre/lib/i386/jvm.cfg -server parameter is commented out
      # -server KNOWN

      synapse 1.1

      Description

      $ sh synapse.sh
      Using Bouncy castle JAR for Java 1.5
      Starting Synapse/Java ...
      Using SYNAPSE_HOME: f:\Synapse\SYNAPS~1.1
      Using JAVA_HOME: c:\Java
      Using SYNAPSE_XML: -Dsynapse.xml=f:\Synapse\SYNAPS~1.1/repository/conf/synapse.xml
      Unrecognized option: -server
      Could not create the Java virtual machine.

      what is causing this error?

        Activity

        Hide
        Paul Fremantle added a comment -

        Martin

        1. Have you tried Synapse 1.2?
        2. Have you tried outside cygwin?

        Paul

        Show
        Paul Fremantle added a comment - Martin 1. Have you tried Synapse 1.2? 2. Have you tried outside cygwin? Paul
        Hide
        Andreas Veithen added a comment - - edited

        IBM's (and possibly other) JREs don't support the -server option. The synapse.sh script should contain some logic to exclude this option if it is not supported by the JRE.

        Show
        Andreas Veithen added a comment - - edited IBM's (and possibly other) JREs don't support the -server option. The synapse.sh script should contain some logic to exclude this option if it is not supported by the JRE.
        Hide
        Andreas Veithen added a comment -

        Lowering the priority of this issue because there is a simple workaround, which is to edit the synapse.sh script. Also changing the fix version because 1.1.1 has already been released.

        Show
        Andreas Veithen added a comment - Lowering the priority of this issue because there is a simple workaround, which is to edit the synapse.sh script. Also changing the fix version because 1.1.1 has already been released.
        Hide
        Asankha C. Perera added a comment -

        The default scripts would be against the Sun JDK versions, and may require slight editing to suit other environments. Typically users are expected to tune these scripts to adjust memory etc, so I would not consider this as a bug anymore.

        Show
        Asankha C. Perera added a comment - The default scripts would be against the Sun JDK versions, and may require slight editing to suit other environments. Typically users are expected to tune these scripts to adjust memory etc, so I would not consider this as a bug anymore.

          People

          • Assignee:
            Asankha C. Perera
            Reporter:
            Martin Gainty
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 8,736h
              8,736h
              Remaining:
              Remaining Estimate - 8,736h
              8,736h
              Logged:
              Time Spent - Not Specified
              Not Specified

                Development