Uploaded image for project: 'Subversion'
  1. Subversion
  2. SVN-4688

New conflict resolver bug in tracing history

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: trunk
    • Fix Version/s: None
    • Component/s: libsvn_client

      Description

      I just ran into the following bug. It appears that the conflict resolver
      doesn't properly follow branch (copy) history when searching for details.

      [[[
      $ svn sw ^/subversion/branches/shelve-checkpoint3
      [...]

      $ svn merge ^/subversion/trunk@1802151
      — Merging r1801593 through r1802151 into '.':
      [...]
      C tools/dist/templates/nightly-candidates.ezt
      — Recording mergeinfo for merge of r1801593 through r1802151 into '.':
      U .
      Summary of conflicts:
      Tree conflicts: 1
      Searching tree conflict details for
      'tools/dist/templates/nightly-candidates.ezt' in repository:
      Checking r1801838...svn: warning: apr_err=SVN_ERR_FS_NOT_FOUND
      svn: warning: W160013:
      '/repos/asf/!svn/rvr/1802151/subversion/branches/shelve-checkpoint3/tools/dist/templates'
      path not found
      /home/julianfoad/src/subversion-c/subversion/svn/merge-cmd.c:553,
      /home/julianfoad/src/subversion-c/subversion/svn/resolve-cmd.c:157:
      (apr_err=SVN_ERR_WC_CONFLICT_RESOLVER_FAILURE)
      svn: E155027: Failure occurred resolving one or more conflicts
      ]]]

      The conflict is a delete-delete: the file 'nightly-candidates.ezt' was
      deleted in branch shelve-checkpoint@r1801823 (note: that's a different
      branch) and also in trunk@r1801838. That branch was branched to
      shelve-checkpoint3 in r1802284.

      The problem is that the look-up of the parent full-path (including
      branch name) fails because the branch 'shelve-checkpoint3' didn't exist
      in r1802151.

        Activity

        stsp Stefan Sperling added a comment - - edited

          People

          • Assignee:
            Unassigned
            Reporter:
            julianfoad Julian Foad
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development