Uploaded image for project: 'Subversion'
  1. Subversion
  2. SVN-1945

Subversion repository breaks and needs recovery

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Trivial
    • Resolution: Invalid
    • Affects Version/s: all
    • Fix Version/s: unscheduled
    • Component/s: libsvn_fs
    • Labels:
      None
    • Environment:

      Linux

      Description

      About every few days and at least once a week Subversion has broken something
      for itself and will only respond after svnadmin recover has been executed. As
      this requires me to manually shutdown the Apache server to prevent simultanous
      access, it has become a definite show-stopper. 
      
      This issue has been present since 0.37 up to and including 1.0.5. I am running
      Subversion on a Gentoo Linux box and the all repository access occurs through
      WebDAV (Apache2 and mod_svn).
      
      If there are any logging options or other mechanisms I can enable in order to
      provide more details on the problem, or of I can otherwise be helpful in
      troubleshooting this, let me know. It's a major problem for me and I would
      really like to see it solved.
      

      Original issue reported by eprime

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              subversion-importer Subversion Importer
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: