Uploaded image for project: 'Subversion'
  1. Subversion
  2. SVN-1678

Document reporter requirements; require depth-first

    XMLWordPrintableJSON

    Details

    • Type: Task
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: all
    • Fix Version/s: 1.0-consider
    • Component/s: libsvn_ra
    • Labels:
      None

      Description

      The attached patch formalizes many informal aspects of the reporter interface. 
      The most important new requirement (which we already meet) is that reports be
      presented in depth-first order.  This patch is technically an API change, since
      it documents requirements not previously documented or enforced.
      
      Requiring depth-first reports will allow us to process reports without creating
      FS transactions in a future version of the server.
      

        Attachments

        1. 2_diff.txt
          2 kB
          Greg Hudson
        2. 1_diff.txt
          2 kB
          Greg Hudson

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              ghudson Greg Hudson
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: