Uploaded image for project: 'Stratos'
  1. Stratos
  2. STRATOS-95

Build failure on trunk (3.0.0-SNAPSHOT)

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.0.0
    • Fix Version/s: 3.0.0
    • Component/s: None
    • Labels:
      None

      Description

      Builds fail in org.apache.stratos.account.mgt due to a missing dependency on javax.activation:activation:jar:1.0.2.

      A quick mvn -X dependency:tree shows it as being a transitive dependency coming from org.wso2.carbon:atlassian-jira.

      [DEBUG]    org.wso2.carbon:atlassian-jira:jar:1.0.0.wso2v1:compile
      [...]
      [DEBUG]       javax.xml:jaxrpc-api:jar:1.1:compile
      [DEBUG]          javax.xml.soap:saaj-api:jar:1.3:compile
      [DEBUG]             javax.activation:activation:jar:1.0.2:compile
      

      A simple excludes of the transitive dependency solves the problem (patch attached). Ideally this would be done directly in carbon/atlassian-jira in a future release and removed from here.

      Cheers

      1. stratos-95.patch
        0.7 kB
        Hadrian Zbarcea

        Activity

        udaraliyanage Udara Liyanage added a comment -

        Resolving since build fails no more.

        hadrian Hadrian Zbarcea added a comment -

        Well, sure I did. If I were to guess the only reason it works for you is that you have custom settings. From the repository URL, I infer that you have a local nexus proxy and I suspect you have another private repository defined in your ~/.m2/settings.xml. Both Maven Central and the wso2-public repo do not have a .jar present for javax.activation:activation:jar:1.0.2, only a pom.

        http://central.maven.org/maven2/javax/activation/activation/1.0.2/
        http://maven.wso2.org/nexus/content/groups/wso2-public/javax/activation/activation/1.0.2/

        dineshb Dinesh Bandara added a comment -

        Hi,
        Have you build with a clean repo? I have built the trunk with clean repo and unable to reproduce the failure.

        Thanks.


          People

          • Assignee:
            Unassigned
            Reporter:
            hadrian Hadrian Zbarcea
          • Votes:
            1 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development