Uploaded image for project: 'Stratos'
  1. Stratos
  2. STRATOS-858

Error in publishing artifact updated event

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Cannot Reproduce
    • Affects Version/s: 4.1.0 M1
    • Fix Version/s: 4.1.0 RC3
    • Component/s: Eventing, Stratos Manager
    • Labels:
      None

      Description

      I'm getting following exception, with MQTT

      TID: [0] [STRATOS] [2014-10-01 09:48:02,214] INFO

      {org.apache.stratos.manager.listener.InstanceStatusListener} - Instance status message received {org.apache.stratos.manager.listener.InstanceStatusListener}

      TID: [0] [STRATOS] [2014-10-01 09:48:02,215] INFO

      {org.apache.stratos.manager.listener.InstanceStatusListener} - Event class name: org.apache.stratos.messaging.event.instance.status.InstanceStartedEvent {org.apache.stratos.manager.listener.InstanceStatusListener}

      TID: [0] [STRATOS] [2014-10-01 09:48:02,215] INFO

      {org.apache.stratos.cloud.controller.topic.instance.status.InstanceStatusEventMessageDelegator} - Instance status event message received from queue: org.apache.stratos.messaging.event.instance.status.InstanceStartedEvent {org.apache.stratos.cloud.controller.topic.instance.status.InstanceStatusEventMessageDelegator}

      TID: [0] [STRATOS] [2014-10-01 09:48:02,216] INFO

      {org.apache.stratos.cloud.controller.topology.TopologyBuilder} - member started event adding status started {org.apache.stratos.cloud.controller.topology.TopologyBuilder}

      TID: [0] [STRATOS] [2014-10-01 09:48:02,216] INFO

      {org.apache.stratos.manager.listener.InstanceStatusListener} - Cluster id: php106sajith.php.domain {org.apache.stratos.manager.listener.InstanceStatusListener}

      TID: [0] [STRATOS] [2014-10-01 09:48:02,220] INFO

      {org.apache.stratos.manager.publisher.InstanceNotificationPublisher} - Publishing artifact updated event: [cluster] php106sajith.php.domain [repo-URL] https://github.com/sajhak/mytestphp.git [repo-username] sajhak@gmail.com [tenant-id] -1234 {org.apache.stratos.manager.publisher.InstanceNotificationPublisher}

      TID: [0] [STRATOS] [2014-10-01 09:48:02,244] INFO

      {org.apache.stratos.cloud.controller.topology.TopologyEventPublisher} - Publishing member started event: [service] php [cluster] php106sajith.php.domain [network-partition] ec2 [partition] P1 [member] php106sajith.php.domained5ed889-225d-4577-8899-91c40afb4042 {org.apache.stratos.cloud.controller.topology.TopologyEventPublisher}

      TID: [0] [STRATOS] [2014-10-01 09:48:02,247] ERROR

      {org.apache.stratos.messaging.broker.publish.TopicPublisher} - Error while publishing to the topic: instance/notifier/ArtifactUpdatedEvent {org.apache.stratos.messaging.broker.publish.TopicPublisher}

      Broker unavailable (3)
      at org.eclipse.paho.client.mqttv3.internal.ExceptionHelper.createMqttException(ExceptionHelper.java:27)
      at org.eclipse.paho.client.mqttv3.internal.ClientState.notifyReceivedAck(ClientState.java:773)
      at org.eclipse.paho.client.mqttv3.internal.CommsReceiver.run(CommsReceiver.java:110)
      at java.lang.Thread.run(Thread.java:745)
      TID: [0] [STRATOS] [2014-10-01 09:48:02,251] INFO

      {org.apache.stratos.messaging.broker.publish.TopicPublisher} - Will try to re-publish in 60 sec {org.apache.stratos.messaging.broker.publish.TopicPublisher}

      TID: [0] [STRATOS] [2014-10-01 09:49:02,317] INFO

      {org.apache.stratos.messaging.message.processor.topology.MemberStartedMessageProcessor} - Member started: [service] php [cluster] php106sajith.php.domain [member] php106sajith.php.domained5ed889-225d-4577-8899-91c40afb4042 {org.apache.stratos.messaging.message.processor.topology.MemberStartedMessageProcessor}

      TID: [0] [STRATOS] [2014-10-01 09:49:02,318] WARN

      {org.apache.stratos.messaging.message.processor.topology.MemberStartedMessageProcessor} - Member already started: [service] php [cluster] php106sajith.php.domain [member] php106sajith.php.domained5ed889-225d-4577-8899-91c40afb4042 {org.apache.stratos.messaging.message.processor.topology.MemberStartedMessageProcessor}

      TID: [0] [STRATOS] [2014-10-01 09:49:02,319] WARN

      {org.apache.stratos.messaging.message.processor.topology.MemberStartedMessageProcessor} - Member already started: [service] php [cluster] php106sajith.php.domain [member] php106sajith.php.domained5ed889-225d-4577-8899-91c40afb4042 {org.apache.stratos.messaging.message.processor.topology.MemberStartedMessageProcessor}

        Activity

        nirmal Nirmal Fernando added a comment -

        We couldn't reproduce this issue with M2.


          People

          • Assignee:
            gayangk Gayan Gunarathne
            Reporter:
            sajith Sajith Kariyawasam
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development