Uploaded image for project: 'Stratos'
  1. Stratos
  2. STRATOS-798

Error while login to Stratos in docker-integration branch

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 4.1.0 M1
    • Fix Version/s: 4.1.0 RC3
    • Component/s: Stratos Manager
    • Labels:
      None

      Description

      TID: [0] [STRATOS] [2014-09-14 22:35:28,347] ERROR

      {org.jaggeryjs.jaggery.core.manager.WebAppManager} - org.mozilla.javascript.WrappedException: Wrapped org.jaggeryjs.scriptengine.exceptions.ScriptException: ClientAbortException: java.io.IOException: Broken pipe (/console/modules/file.js#32) {org.jaggeryjs.jaggery.core.manager.WebAppManager}

      org.jaggeryjs.scriptengine.exceptions.ScriptException: org.mozilla.javascript.WrappedException: Wrapped org.jaggeryjs.scriptengine.exceptions.ScriptException: ClientAbortException: java.io.IOException: Broken pipe (/console/modules/file.js#32)
      at org.jaggeryjs.scriptengine.engine.RhinoEngine.execScript(RhinoEngine.java:571)
      at org.jaggeryjs.scriptengine.engine.RhinoEngine.exec(RhinoEngine.java:273)
      at org.jaggeryjs.jaggery.core.manager.WebAppManager.execute(WebAppManager.java:447)
      at org.jaggeryjs.jaggery.core.JaggeryServlet.doGet(JaggeryServlet.java:24)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:735)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:848)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:305)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
      at org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:749)
      at org.apache.catalina.core.ApplicationDispatcher.processRequest(ApplicationDispatcher.java:487)
      at org.apache.catalina.core.ApplicationDispatcher.doForward(ApplicationDispatcher.java:379)
      at org.apache.catalina.core.ApplicationDispatcher.forward(ApplicationDispatcher.java:339)
      at org.jaggeryjs.jaggery.core.JaggeryFilter.doFilter(JaggeryFilter.java:21)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:243)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
      at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:222)
      at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:123)
      at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:472)
      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:171)
      at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:99)
      at org.wso2.carbon.tomcat.ext.valves.CompositeValve.continueInvocation(CompositeValve.java:178)
      at org.wso2.carbon.tomcat.ext.valves.CarbonTomcatValve$1.invoke(CarbonTomcatValve.java:47)
      at org.wso2.carbon.webapp.mgt.TenantLazyLoaderValve.invoke(TenantLazyLoaderValve.java:56)
      at org.wso2.carbon.tomcat.ext.valves.TomcatValveContainer.invokeValves(TomcatValveContainer.java:47)
      at org.wso2.carbon.tomcat.ext.valves.CompositeValve.invoke(CompositeValve.java:141)
      at org.wso2.carbon.tomcat.ext.valves.CarbonStuckThreadDetectionValve.invoke(CarbonStuckThreadDetectionValve.java:156)
      at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:936)
      at org.wso2.carbon.tomcat.ext.valves.CarbonContextCreatorValve.invoke(CarbonContextCreatorValve.java:52)
      at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:118)
      at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:407)
      at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1004)
      at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:589)
      at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.run(NioEndpoint.java:1653)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918)
      at java.lang.Thread.run(Thread.java:695)
      Caused by: org.mozilla.javascript.WrappedException: Wrapped org.jaggeryjs.scriptengine.exceptions.ScriptException: ClientAbortException: java.io.IOException: Broken pipe (/console/modules/file.js#32)
      at org.mozilla.javascript.Context.throwAsScriptRuntimeEx(Context.java:1754)
      at org.mozilla.javascript.MemberBox.invoke(MemberBox.java:148)
      at org.mozilla.javascript.FunctionObject.call(FunctionObject.java:386)
      at org.mozilla.javascript.optimizer.OptRuntime.callName(OptRuntime.java:63)
      at org.jaggeryjs.rhino.console.modules.c1._c_anonymous_1(/console/modules/file.js:32)
      at org.jaggeryjs.rhino.console.modules.c1.call(/console/modules/file.js)
      at org.mozilla.javascript.optimizer.OptRuntime.call1(OptRuntime.java:32)
      at org.jaggeryjs.rhino.console.controllers.c0._c_anonymous_1(/console/controllers/router.jag:57)
      at org.jaggeryjs.rhino.console.controllers.c0.call(/console/controllers/router.jag)
      at org.mozilla.javascript.optimizer.OptRuntime.call0(OptRuntime.java:23)
      at org.jaggeryjs.rhino.console.controllers.c0._c_script_0(/console/controllers/router.jag:23)
      at org.jaggeryjs.rhino.console.controllers.c0.call(/console/controllers/router.jag)
      at org.mozilla.javascript.ContextFactory.doTopCall(ContextFactory.java:394)
      at org.mozilla.javascript.ScriptRuntime.doTopCall(ScriptRuntime.java:3091)
      at org.jaggeryjs.rhino.console.controllers.c0.call(/console/controllers/router.jag)
      at org.jaggeryjs.rhino.console.controllers.c0.exec(/console/controllers/router.jag)
      at org.jaggeryjs.scriptengine.engine.RhinoEngine.execScript(RhinoEngine.java:567)
      ... 35 more
      Caused by: org.jaggeryjs.scriptengine.exceptions.ScriptException: ClientAbortException: java.io.IOException: Broken pipe
      at org.jaggeryjs.jaggery.core.manager.CommonManager.print(CommonManager.java:297)
      at org.jaggeryjs.jaggery.core.manager.WebAppManager.print(WebAppManager.java:171)
      at sun.reflect.GeneratedMethodAccessor67.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.mozilla.javascript.MemberBox.invoke(MemberBox.java:126)
      ... 50 more
      Caused by: ClientAbortException: java.io.IOException: Broken pipe
      at org.apache.catalina.connector.OutputBuffer.realWriteBytes(OutputBuffer.java:388)
      at org.apache.tomcat.util.buf.ByteChunk.flushBuffer(ByteChunk.java:462)
      at org.apache.tomcat.util.buf.ByteChunk.append(ByteChunk.java:366)
      at org.apache.catalina.connector.OutputBuffer.writeBytes(OutputBuffer.java:413)
      at org.apache.catalina.connector.OutputBuffer.write(OutputBuffer.java:401)
      at org.apache.catalina.connector.CoyoteOutputStream.write(CoyoteOutputStream.java:91)
      at org.jaggeryjs.jaggery.core.manager.CommonManager.print(CommonManager.java:292)
      ... 55 more
      Caused by: java.io.IOException: Broken pipe
      at sun.nio.ch.FileDispatcher.write0(Native Method)
      at sun.nio.ch.SocketDispatcher.write(SocketDispatcher.java:29)
      at sun.nio.ch.IOUtil.writeFromNativeBuffer(IOUtil.java:69)
      at sun.nio.ch.IOUtil.write(IOUtil.java:26)
      at sun.nio.ch.SocketChannelImpl.write(SocketChannelImpl.java:336)
      at org.apache.tomcat.util.net.SecureNioChannel.flush(SecureNioChannel.java:135)
      at org.apache.tomcat.util.net.SecureNioChannel.write(SecureNioChannel.java:509)
      at org.apache.tomcat.util.net.NioBlockingSelector.write(NioBlockingSelector.java:94)
      at org.apache.tomcat.util.net.NioSelectorPool.write(NioSelectorPool.java:174)
      at org.apache.coyote.http11.InternalNioOutputBuffer.writeToSocket(InternalNioOutputBuffer.java:163)
      at org.apache.coyote.http11.InternalNioOutputBuffer.flushBuffer(InternalNioOutputBuffer.java:242)
      at org.apache.coyote.http11.InternalNioOutputBuffer.addToBB(InternalNioOutputBuffer.java:213)
      at org.apache.coyote.http11.InternalNioOutputBuffer.access$000(InternalNioOutputBuffer.java:41)
      at org.apache.coyote.http11.InternalNioOutputBuffer$SocketOutputBuffer.doWrite(InternalNioOutputBuffer.java:268)
      at org.apache.coyote.http11.filters.ChunkedOutputFilter.doWrite(ChunkedOutputFilter.java:119)
      at org.apache.coyote.http11.AbstractOutputBuffer.doWrite(AbstractOutputBuffer.java:192)
      at org.apache.coyote.Response.doWrite(Response.java:505)
      at org.apache.catalina.connector.OutputBuffer.realWriteBytes(OutputBuffer.java:383)
      ... 61 more
      TID: [0] [STRATOS] [2014-09-14 22:35:32,890] ERROR

      {org.jaggeryjs.jaggery.core.manager.WebAppManager} - org.mozilla.javascript.WrappedException: Wrapped org.jaggeryjs.scriptengine.exceptions.ScriptException: org.mozilla.javascript.EcmaError: TypeError: Cannot read property "length" from undefined (/console/themes/theme1/renderers/index.js#49) (/console/controllers/router.jag#119) {org.jaggeryjs.jaggery.core.manager.WebAppManager}

      org.jaggeryjs.scriptengine.exceptions.ScriptException: org.mozilla.javascript.WrappedException: Wrapped org.jaggeryjs.scriptengine.exceptions.ScriptException: org.mozilla.javascript.EcmaError: TypeError: Cannot read property "length" from undefined (/console/themes/theme1/renderers/index.js#49) (/console/controllers/router.jag#119)
      at org.jaggeryjs.scriptengine.engine.RhinoEngine.execScript(RhinoEngine.java:571)
      at org.jaggeryjs.scriptengine.engine.RhinoEngine.exec(RhinoEngine.java:273)
      at org.jaggeryjs.jaggery.core.manager.WebAppManager.execute(WebAppManager.java:447)
      at org.jaggeryjs.jaggery.core.JaggeryServlet.doGet(JaggeryServlet.java:24)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:735)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:848)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:305)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
      at org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:749)
      at org.apache.catalina.core.ApplicationDispatcher.processRequest(ApplicationDispatcher.java:487)
      at org.apache.catalina.core.ApplicationDispatcher.doForward(ApplicationDispatcher.java:379)
      at org.apache.catalina.core.ApplicationDispatcher.forward(ApplicationDispatcher.java:339)
      at org.jaggeryjs.jaggery.core.JaggeryFilter.doFilter(JaggeryFilter.java:21)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:243)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
      at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:222)
      at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:123)
      at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:472)
      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:171)
      at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:99)
      at org.wso2.carbon.tomcat.ext.valves.CompositeValve.continueInvocation(CompositeValve.java:178)
      at org.wso2.carbon.tomcat.ext.valves.CarbonTomcatValve$1.invoke(CarbonTomcatValve.java:47)
      at org.wso2.carbon.webapp.mgt.TenantLazyLoaderValve.invoke(TenantLazyLoaderValve.java:56)
      at org.wso2.carbon.tomcat.ext.valves.TomcatValveContainer.invokeValves(TomcatValveContainer.java:47)
      at org.wso2.carbon.tomcat.ext.valves.CompositeValve.invoke(CompositeValve.java:141)
      at org.wso2.carbon.tomcat.ext.valves.CarbonStuckThreadDetectionValve.invoke(CarbonStuckThreadDetectionValve.java:156)
      at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:936)
      at org.wso2.carbon.tomcat.ext.valves.CarbonContextCreatorValve.invoke(CarbonContextCreatorValve.java:52)
      at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:118)
      at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:407)
      at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1004)
      at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:589)
      at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.run(NioEndpoint.java:1653)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918)
      at java.lang.Thread.run(Thread.java:695)
      Caused by: org.mozilla.javascript.WrappedException: Wrapped org.jaggeryjs.scriptengine.exceptions.ScriptException: org.mozilla.javascript.EcmaError: TypeError: Cannot read property "length" from undefined (/console/themes/theme1/renderers/index.js#49) (/console/controllers/router.jag#119)
      at org.mozilla.javascript.Context.throwAsScriptRuntimeEx(Context.java:1754)
      at org.mozilla.javascript.MemberBox.invoke(MemberBox.java:148)
      at org.mozilla.javascript.FunctionObject.call(FunctionObject.java:386)
      at org.mozilla.javascript.optimizer.OptRuntime.callName(OptRuntime.java:63)
      at org.jaggeryjs.rhino.console.controllers.c0._c_anonymous_1(/console/controllers/router.jag:119)
      at org.jaggeryjs.rhino.console.controllers.c0.call(/console/controllers/router.jag)
      at org.mozilla.javascript.optimizer.OptRuntime.call0(OptRuntime.java:23)
      at org.jaggeryjs.rhino.console.controllers.c0._c_script_0(/console/controllers/router.jag:23)
      at org.jaggeryjs.rhino.console.controllers.c0.call(/console/controllers/router.jag)
      at org.mozilla.javascript.ContextFactory.doTopCall(ContextFactory.java:394)
      at org.mozilla.javascript.ScriptRuntime.doTopCall(ScriptRuntime.java:3091)
      at org.jaggeryjs.rhino.console.controllers.c0.call(/console/controllers/router.jag)
      at org.jaggeryjs.rhino.console.controllers.c0.exec(/console/controllers/router.jag)
      at org.jaggeryjs.scriptengine.engine.RhinoEngine.execScript(RhinoEngine.java:567)
      ... 35 more
      Caused by: org.jaggeryjs.scriptengine.exceptions.ScriptException: org.mozilla.javascript.EcmaError: TypeError: Cannot read property "length" from undefined (/console/themes/theme1/renderers/index.js#49)
      at org.jaggeryjs.scriptengine.engine.RhinoEngine.execScript(RhinoEngine.java:571)
      at org.jaggeryjs.scriptengine.engine.RhinoEngine.exec(RhinoEngine.java:273)
      at org.jaggeryjs.jaggery.core.manager.WebAppManager.executeScript(WebAppManager.java:273)
      at org.jaggeryjs.jaggery.core.manager.WebAppManager.include(WebAppManager.java:127)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.mozilla.javascript.MemberBox.invoke(MemberBox.java:126)
      ... 47 more
      Caused by: org.mozilla.javascript.EcmaError: TypeError: Cannot read property "length" from undefined (/console/themes/theme1/renderers/index.js#49)
      at org.mozilla.javascript.ScriptRuntime.constructError(ScriptRuntime.java:3687)
      at org.mozilla.javascript.ScriptRuntime.constructError(ScriptRuntime.java:3665)
      at org.mozilla.javascript.ScriptRuntime.typeError(ScriptRuntime.java:3693)
      at org.mozilla.javascript.ScriptRuntime.typeError2(ScriptRuntime.java:3712)
      at org.mozilla.javascript.ScriptRuntime.undefReadError(ScriptRuntime.java:3725)
      at org.mozilla.javascript.ScriptRuntime.getObjectProp(ScriptRuntime.java:1483)
      at org.jaggeryjs.rhino.console.themes.theme_1.renderers.c1._c_anonymous_1(/console/themes/theme1/renderers/index.js:49)
      at org.jaggeryjs.rhino.console.themes.theme_1.renderers.c1.call(/console/themes/theme1/renderers/index.js)
      at org.mozilla.javascript.optimizer.OptRuntime.callName(OptRuntime.java:63)
      at org.mozilla.javascript.gen.caramel_handlebars_js_5._c_anonymous_28(caramel.handlebars.js:453)
      at org.mozilla.javascript.gen.caramel_handlebars_js_5.call(caramel.handlebars.js)
      at org.mozilla.javascript.optimizer.OptRuntime.call2(OptRuntime.java:42)
      at org.mozilla.javascript.gen.caramel_core_js_4._c_anonymous_13(caramel-core.js:212)
      at org.mozilla.javascript.gen.caramel_core_js_4.call(caramel-core.js)
      at org.mozilla.javascript.optimizer.OptRuntime.call1(OptRuntime.java:32)
      at org.jaggeryjs.rhino.console.c1._c_script_0(/console//index.jag:45)
      at org.jaggeryjs.rhino.console.c1.call(/console//index.jag)
      at org.jaggeryjs.rhino.console.c1.exec(/console//index.jag)
      at org.jaggeryjs.scriptengine.engine.RhinoEngine.execScript(RhinoEngine.java:567)
      ... 55 more
      TID: [0] [STRATOS] [2014-09-14 22:35:33,025] ERROR

      {org.jaggeryjs.jaggery.core.manager.WebAppManager} - org.mozilla.javascript.WrappedException: Wrapped org.jaggeryjs.scriptengine.exceptions.ScriptException: org.mozilla.javascript.EcmaError: TypeError: Cannot read property "length" from undefined (/console/themes/theme1/renderers/index.js#49) (/console/controllers/router.jag#119) {org.jaggeryjs.jaggery.core.manager.WebAppManager}

      org.jaggeryjs.scriptengine.exceptions.ScriptException: org.mozilla.javascript.WrappedException: Wrapped org.jaggeryjs.scriptengine.exceptions.ScriptException: org.mozilla.javascript.EcmaError: TypeError: Cannot read property "length" from undefined (/console/themes/theme1/renderers/index.js#49) (/console/controllers/router.jag#119)
      at org.jaggeryjs.scriptengine.engine.RhinoEngine.execScript(RhinoEngine.java:571)
      at org.jaggeryjs.scriptengine.engine.RhinoEngine.exec(RhinoEngine.java:273)
      at org.jaggeryjs.jaggery.core.manager.WebAppManager.execute(WebAppManager.java:447)
      at org.jaggeryjs.jaggery.core.JaggeryServlet.doGet(JaggeryServlet.java:24)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:735)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:848)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:305)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
      at org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:749)
      at org.apache.catalina.core.ApplicationDispatcher.processRequest(ApplicationDispatcher.java:487)
      at org.apache.catalina.core.ApplicationDispatcher.doForward(ApplicationDispatcher.java:379)
      at org.apache.catalina.core.ApplicationDispatcher.forward(ApplicationDispatcher.java:339)
      at org.jaggeryjs.jaggery.core.JaggeryFilter.doFilter(JaggeryFilter.java:21)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:243)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
      at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:222)
      at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:123)
      at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:472)
      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:171)
      at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:99)
      at org.wso2.carbon.tomcat.ext.valves.CompositeValve.continueInvocation(CompositeValve.java:178)
      at org.wso2.carbon.tomcat.ext.valves.CarbonTomcatValve$1.invoke(CarbonTomcatValve.java:47)
      at org.wso2.carbon.webapp.mgt.TenantLazyLoaderValve.invoke(TenantLazyLoaderValve.java:56)
      at org.wso2.carbon.tomcat.ext.valves.TomcatValveContainer.invokeValves(TomcatValveContainer.java:47)
      at org.wso2.carbon.tomcat.ext.valves.CompositeValve.invoke(CompositeValve.java:141)
      at org.wso2.carbon.tomcat.ext.valves.CarbonStuckThreadDetectionValve.invoke(CarbonStuckThreadDetectionValve.java:156)
      at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:936)
      at org.wso2.carbon.tomcat.ext.valves.CarbonContextCreatorValve.invoke(CarbonContextCreatorValve.java:52)
      at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:118)
      at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:407)
      at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1004)
      at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:589)
      at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.run(NioEndpoint.java:1653)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918)
      at java.lang.Thread.run(Thread.java:695)
      Caused by: org.mozilla.javascript.WrappedException: Wrapped org.jaggeryjs.scriptengine.exceptions.ScriptException: org.mozilla.javascript.EcmaError: TypeError: Cannot read property "length" from undefined (/console/themes/theme1/renderers/index.js#49) (/console/controllers/router.jag#119)
      at org.mozilla.javascript.Context.throwAsScriptRuntimeEx(Context.java:1754)
      at org.mozilla.javascript.MemberBox.invoke(MemberBox.java:148)
      at org.mozilla.javascript.FunctionObject.call(FunctionObject.java:386)
      at org.mozilla.javascript.optimizer.OptRuntime.callName(OptRuntime.java:63)
      at org.jaggeryjs.rhino.console.controllers.c0._c_anonymous_1(/console/controllers/router.jag:119)
      at org.jaggeryjs.rhino.console.controllers.c0.call(/console/controllers/router.jag)
      at org.mozilla.javascript.optimizer.OptRuntime.call0(OptRuntime.java:23)
      at org.jaggeryjs.rhino.console.controllers.c0._c_script_0(/console/controllers/router.jag:23)
      at org.jaggeryjs.rhino.console.controllers.c0.call(/console/controllers/router.jag)
      at org.mozilla.javascript.ContextFactory.doTopCall(ContextFactory.java:394)
      at org.mozilla.javascript.ScriptRuntime.doTopCall(ScriptRuntime.java:3091)
      at org.jaggeryjs.rhino.console.controllers.c0.call(/console/controllers/router.jag)
      at org.jaggeryjs.rhino.console.controllers.c0.exec(/console/controllers/router.jag)
      at org.jaggeryjs.scriptengine.engine.RhinoEngine.execScript(RhinoEngine.java:567)
      ... 35 more
      Caused by: org.jaggeryjs.scriptengine.exceptions.ScriptException: org.mozilla.javascript.EcmaError: TypeError: Cannot read property "length" from undefined (/console/themes/theme1/renderers/index.js#49)
      at org.jaggeryjs.scriptengine.engine.RhinoEngine.execScript(RhinoEngine.java:571)
      at org.jaggeryjs.scriptengine.engine.RhinoEngine.exec(RhinoEngine.java:273)
      at org.jaggeryjs.jaggery.core.manager.WebAppManager.executeScript(WebAppManager.java:273)
      at org.jaggeryjs.jaggery.core.manager.WebAppManager.include(WebAppManager.java:127)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.mozilla.javascript.MemberBox.invoke(MemberBox.java:126)
      ... 47 more
      Caused by: org.mozilla.javascript.EcmaError: TypeError: Cannot read property "length" from undefined (/console/themes/theme1/renderers/index.js#49)
      at org.mozilla.javascript.ScriptRuntime.constructError(ScriptRuntime.java:3687)
      at org.mozilla.javascript.ScriptRuntime.constructError(ScriptRuntime.java:3665)
      at org.mozilla.javascript.ScriptRuntime.typeError(ScriptRuntime.java:3693)
      at org.mozilla.javascript.ScriptRuntime.typeError2(ScriptRuntime.java:3712)
      at org.mozilla.javascript.ScriptRuntime.undefReadError(ScriptRuntime.java:3725)
      at org.mozilla.javascript.ScriptRuntime.getObjectProp(ScriptRuntime.java:1483)
      at org.jaggeryjs.rhino.console.themes.theme_1.renderers.c1._c_anonymous_1(/console/themes/theme1/renderers/index.js:49)
      at org.jaggeryjs.rhino.console.themes.theme_1.renderers.c1.call(/console/themes/theme1/renderers/index.js)
      at org.mozilla.javascript.optimizer.OptRuntime.callName(OptRuntime.java:63)
      at org.mozilla.javascript.gen.caramel_handlebars_js_5._c_anonymous_28(caramel.handlebars.js:453)
      at org.mozilla.javascript.gen.caramel_handlebars_js_5.call(caramel.handlebars.js)
      at org.mozilla.javascript.optimizer.OptRuntime.call2(OptRuntime.java:42)
      at org.mozilla.javascript.gen.caramel_core_js_4._c_anonymous_13(caramel-core.js:212)
      at org.mozilla.javascript.gen.caramel_core_js_4.call(caramel-core.js)
      at org.mozilla.javascript.optimizer.OptRuntime.call1(OptRuntime.java:32)
      at org.jaggeryjs.rhino.console.c1._c_script_0(/console//index.jag:45)
      at org.jaggeryjs.rhino.console.c1.call(/console//index.jag)
      at org.jaggeryjs.rhino.console.c1.exec(/console//index.jag)
      at org.jaggeryjs.scriptengine.engine.RhinoEngine.execScript(RhinoEngine.java:567)
      ... 55 more

        Activity

        ravihansa Akila added a comment -

        Fixed in 7cf4bbc10ba6fb6cdd2430d6885b0db166817e2c

        githubbot ASF GitHub Bot added a comment -

        Github user asfgit closed the pull request at:

        https://github.com/apache/stratos/pull/36

        githubbot ASF GitHub Bot added a comment -

        GitHub user R-Rajkumar opened a pull request:

        https://github.com/apache/stratos/pull/36

        Fixing STRATOS-798

        You can merge this pull request into a Git repository by running:

        $ git pull https://github.com/R-Rajkumar/stratos docker-integration

        Alternatively you can review and apply these changes as the patch at:

        https://github.com/apache/stratos/pull/36.patch

        To close this pull request, make a commit to your master/trunk branch
        with (at least) the following in the commit message:

        This closes #36


        commit 7cf4bbc10ba6fb6cdd2430d6885b0db166817e2c
        Author: R-Rajkumar <rraju1990@gmail.com>
        Date: 2014-09-14T20:02:30Z

        fixing jaggery error handling when server side error

        commit 6882882edd567b27f479432e067463faa15ff5f4
        Author: R-Rajkumar <rraju1990@gmail.com>
        Date: 2014-09-15T02:51:19Z

        handling redirects response (300-399) in jaggery console app



          People

          • Assignee:
            rajkumarr Rajkumar Rajaratnam
            Reporter:
            nirmal Nirmal Fernando
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development